Bug 913878

Summary: apache-commons-fileupload: FTBFS in rawhide
Product: [Fedora] Fedora Reporter: Dennis Gilmore <dennis>
Component: apache-commons-fileuploadAssignee: Mikolaj Izdebski <mizdebsk>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: high    
Version: rawhideCC: java-sig-commits, jerboaa, mizdebsk, msrb, sochotni, SpikeFedora, tradej
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: 1.2.2-11 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-03-11 14:47:30 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 914651    
Bug Blocks: 913825    

Description Dennis Gilmore 2013-02-22 09:09:22 UTC
Your package apache-commons-fileupload failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=4957279

Build logs:
root.log: http://kojipkgs.fedoraproject.org/work/tasks/7279/4957279/root.log
build.log: http://kojipkgs.fedoraproject.org/work/tasks/7279/4957279/build.log
state.log: http://kojipkgs.fedoraproject.org/work/tasks/7279/4957279/state.log
NOTE: build logs are cleaned up after 1 week

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild

Comment 1 Mat Booth 2013-02-22 10:06:18 UTC
*** Bug 914220 has been marked as a duplicate of this bug. ***

Comment 2 Mikolaj Izdebski 2013-02-22 12:33:18 UTC
So far this package doesn't build in rawhide because
of broken bouncycastle-main, see bug #914574 for more details.

I am adding dependency on bug #914574 and I will investigate
the real cause of the FTBFS once bouncycastle-mail is fixed.

Comment 3 Mikolaj Izdebski 2013-02-22 12:36:57 UTC
In comment #1 I meant bug #914651, not bug #914574.
Fixing bug dependency. Sorry.

Comment 4 Mikolaj Izdebski 2013-02-28 13:04:56 UTC
I just sis a scratch build and this package still
fails to build from source in rawhide:

Package apache-commons-fileupload (5064081):
  noarch (5064113):
    build.log           : http://kojipkgs.fedoraproject.org/work/tasks/4113/5064113/build.log
    state.log           : http://kojipkgs.fedoraproject.org/work/tasks/4113/5064113/state.log
    mock_output.log     : http://kojipkgs.fedoraproject.org/work/tasks/4113/5064113/mock_output.log
    root.log            : http://kojipkgs.fedoraproject.org/work/tasks/4113/5064113/root.log

Comment 5 Mikolaj Izdebski 2013-02-28 13:19:10 UTC
Incompatible servlet API problem.

Comment 6 Mikolaj Izdebski 2013-03-11 14:26:49 UTC
Fixed in apache-commons-fileupload-1.2.2-11

Comment 7 Mikolaj Izdebski 2013-03-11 14:47:30 UTC
I believe that this bug is fixed in apache-commons-fileupload-1.2.2-11,
which is available in Fedora Rawhide, so I am closing this bug now.
Thank you for reporting it.  You are welcome to submit any further reports.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=401643