Bug 923364

Summary: [3.7.92] Despite moving mouse in Black Screen(Blank Screen), gnome-shell doesn't switch to unlock screen
Product: [Fedora] Fedora Reporter: sangu <sangu.fedora>
Component: gnome-shellAssignee: Owen Taylor <otaylor>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 19CC: admiller, awilliam, bnocera, bochecha, drago01, fmuellner, kparal, mfabian, michele, nicolas.mailhot, otaylor, rmatos, robatino, rstrode, samkraju, tadej.j, walters
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: RejectedBlocker
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-06-11 20:47:41 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description sangu 2013-03-19 12:35:01 EDT
Description of problem:
[3.7.92] Despite moving mouse in Back Screen, gnome-shell doesn't switch to unlock screen.
gnome-shell may be deadlock.

Only mouse arrow moves in black screen.

$ killall -s SEGV gnome-shell in console 

$ gdb gnome-shell coredump

Core was generated by `/usr/bin/gnome-shell'.
Program terminated with signal 11, Segmentation fault.
#0  0x00007fb1204218fd in poll () from /lib64/libc.so.6

(gdb) bt
#0  0x00007fb1204218fd in poll () from /lib64/libc.so.6
#1  0x00007fb11e4e0f42 in poll (__timeout=-1, __nfds=1, __fds=0x7fff8e3c8a30)
    at /usr/include/bits/poll2.h:46
#2  _xcb_conn_wait (c=c@entry=0x1ec64d0, cond=cond@entry=0x1ec75a0, 
    vector=vector@entry=0x7fff8e3c8a88, count=count@entry=0x7fff8e3c8a84)
    at xcb_conn.c:414
#3  0x00007fb11e4e1473 in _xcb_out_send (c=c@entry=0x1ec64d0, 
    vector=vector@entry=0x7fff8e3c8b00, count=count@entry=3) at xcb_out.c:349
#4  0x00007fb11e4e14f3 in xcb_writev (c=c@entry=0x1ec64d0, 
    vector=vector@entry=0x7fff8e3c8b00, count=count@entry=3, 
    requests=requests@entry=2) at xcb_out.c:297
#5  0x00007fb122be55f6 in _XSend (dpy=0x1ec5280, data=data@entry=0x0, 
    size=size@entry=0) at xcb_io.c:494
#6  0x00007fb122be5ad8 in _XReply (dpy=dpy@entry=0x1ec5280, 
    rep=rep@entry=0x7fff8e3c8bd0, extra=extra@entry=0, discard=discard@entry=1)
    at xcb_io.c:580
#7  0x00007fb122be17ad in XSync (dpy=dpy@entry=0x1ec5280, 
    discard=discard@entry=0) at Sync.c:44
#8  0x00007fb1297f7dda in meta_window_actor_handle_updates (
    self=0x3a060c0 [MetaWindowActor]) at compositor/meta-window-actor.c:2378
#9  0x00007fb1297f900f in meta_window_actor_pre_paint (self=<optimized out>)
    at compositor/meta-window-actor.c:2394
#10 0x00007fb1297edd28 in pre_paint_windows (info=<optimized out>)
---Type <return> to continue, or q <return> to quit---
    at compositor/compositor.c:1441
#11 meta_repaint_func (data=<optimized out>) at compositor/compositor.c:1458
#12 0x00007fb124a11c0d in _clutter_run_repaint_functions (flags=flags@entry=
    CLUTTER_REPAINT_FLAGS_PRE_PAINT) at ./clutter-main.c:3692
#13 0x00007fb124a14107 in master_clock_update_stages (
    stages=0x508b0b0 = {...}, master_clock=0x32ae370 [ClutterMasterClock])
    at ./clutter-master-clock.c:451
#14 clutter_clock_dispatch (source=source@entry=0x33cff60, 
    callback=<optimized out>, user_data=<optimized out>)
    at ./clutter-master-clock.c:589
#15 0x00007fb12073ee96 in g_main_dispatch (context=0x1e92000) at gmain.c:3054
#16 g_main_context_dispatch (context=context@entry=0x1e92000) at gmain.c:3630
#17 0x00007fb12073f1e8 in g_main_context_iterate (context=0x1e92000, 
    block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>)
    at gmain.c:3701
#18 0x00007fb12073f5ea in g_main_loop_run (loop=0x1e98cd0) at gmain.c:3895
#19 0x00007fb1298104c1 in meta_run () at core/main.c:556
#20 0x0000000000401f59 in main (argc=1, argv=0x7fff8e3c9158) at main.c:430

Version-Release number of selected component (if applicable):
3.7.92-1.fc19

How reproducible:
always, After activating Blank Screen)

Steps to Reproduce:
1. doen't touch computer for Back Screen setting time
2.
3.
  
Actual results:


Expected results:


Additional info:
mutter-3.7.92-1.fc19.x86_64
clutter-1.13.8-1.fc19.x86_64
libX11-1.5.99.901-2.fc19.x86_64
libxcb-1.9-2.fc19.x86_64
Comment 1 sangu 2013-03-20 02:43:41 EDT
maybe Duplicated bug 923386 bug 923586 ?
Comment 2 Adam Williamson 2013-03-20 05:07:12 EDT
Looks like it, yeah. Good catch.
Comment 3 Adam Williamson 2013-03-20 05:07:28 EDT
*** Bug 923586 has been marked as a duplicate of this bug. ***
Comment 4 Adam Williamson 2013-03-20 05:08:56 EDT
*** Bug 923386 has been marked as a duplicate of this bug. ***
Comment 5 Adam Williamson 2013-03-20 05:10:30 EDT
Info from the dupes: Nic and I both see a lot of these errors in journalctl:

Mar 20 02:33:58 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!   Exception was: Error: Expected type gunichar for Argument 'c' but got type 'number' (nil)
Mar 20 02:33:58 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     message = '"Expected type gunichar for Argument 'c' but got type 'number' (nil)"'
Mar 20 02:33:58 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     fileName = '"/usr/share/gnome-shell/js/ui/screenShield.js"'
Mar 20 02:33:58 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     lineNumber = '606'
Mar 20 02:33:58 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     stack = '"([object GObject_Object],[object GObject_Union])@/usr/share/gnome-shell/js/ui/screenShield.js:606
Mar 20 02:33:59 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!   Exception was: Error: Expected type gunichar for Argument 'c' but got type 'number' (nil)
Mar 20 02:33:59 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     message = '"Expected type gunichar for Argument 'c' but got type 'number' (nil)"'
Mar 20 02:33:59 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     fileName = '"/usr/share/gnome-shell/js/ui/screenShield.js"'
Mar 20 02:33:59 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     lineNumber = '606'
Mar 20 02:33:59 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     stack = '"([object GObject_Object],[object GObject_Union])@/usr/share/gnome-shell/js/ui/screenShield.js:606
...
Mar 20 02:34:05 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!   Exception was: Error: Expected type gunichar for Argument 'c' but got type 'number' (nil)
Mar 20 02:34:05 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     message = '"Expected type gunichar for Argument 'c' but got type 'number' (nil)"'
Mar 20 02:34:05 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     fileName = '"/usr/share/gnome-shell/js/ui/screenShield.js"'
Mar 20 02:34:05 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     lineNumber = '611'
Mar 20 02:34:05 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!     stack = '"([object GObject_Object],[object GObject_Union])@/usr/share/gnome-shell/js/ui/screenShield.js:611

It does not appear to happen if you disable locking (for me anyway). I am uploading a live image at present:

http://fedorapeople.org/groups/qa/20130320-desktop-x86_64.iso
sha256sum: 38ffc3ca990f4d111f2e2e5c4a185358ef665f2bfaa9513b849102658a5e79d1

upload should be complete in 25 minutes. Live env should work OK, installed system will work if you don't use virtio drives ( https://bugzilla.redhat.com/show_bug.cgi?id=922988 ) and work around gnome-initial-setup being broken ( https://bugzilla.redhat.com/show_bug.cgi?id=923501 ).
Comment 6 Rui Matos 2013-03-20 05:30:13 EDT
(In reply to comment #5)
> Mar 20 02:33:58 localhost.localdomain /etc/gdm/Xsession[1221]: JS ERROR: !!!
> Exception was: Error: Expected type gunichar for Argument 'c' but got type
> 'number' (nil)

This should be fixed in clutter 1.13.10 or any git checkout after https://git.gnome.org/browse/clutter/commit/?h=clutter-1.14&id=ab274364381e68c87486cf0e5f9293fd0c40daf9 .
Comment 7 Adam Williamson 2013-03-20 11:54:43 EDT
It would be great to get a downstream build, as we need to build Alpha TC1 and GNOME Test Day images. If no-one else gets to that in a few hours, I'll do it.
Comment 8 Michele Baldessari 2013-03-20 15:04:15 EDT
Hi all,

I upgraded to clutter 1.13.10-1.fc19.x86_64 but I still have the issue (black screen with mouse moving and no way to get the shell back). 

Backtrace:
#0  0x00000034dfaea8fd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00000034e3e09f42 in poll (__timeout=-1, __nfds=1, __fds=0x7fff20b9dad0) at /usr/include/bits/poll2.h:46
#2  _xcb_conn_wait (c=c@entry=0x8d7c30, cond=cond@entry=0x7fff20b9db50, vector=vector@entry=0x0, count=count@entry=0x0) at xcb_conn.c:414
#3  0x00000034e3e0b37f in wait_for_reply (c=c@entry=0x8d7c30, request=5331, e=e@entry=0x7fff20b9dc18) at xcb_in.c:394
#4  0x00000034e3e0b492 in xcb_wait_for_reply (c=c@entry=0x8d7c30, request=5331, e=e@entry=0x7fff20b9dc18) at xcb_in.c:424
#5  0x00000034e4241b87 in _XReply (dpy=dpy@entry=0x8d69e0, rep=rep@entry=0x7fff20b9dcb0, extra=extra@entry=0, discard=discard@entry=1) at xcb_io.c:601
#6  0x00000034e4229424 in _XGetWindowAttributes (dpy=dpy@entry=0x8d69e0, w=16777243, attr=0x7fff20b9dd30) at GetWAttrs.c:114
#7  0x00000034e4229591 in XGetWindowAttributes (dpy=0x8d69e0, w=w@entry=16777243, attr=attr@entry=0x7fff20b9dd30) at GetWAttrs.c:149
#8  0x00000034f34468cf in meta_display_screen_for_xwindow (display=display@entry=0x1cab8f0, xwindow=16777243) at core/display.c:1169
#9  0x00000034f3455fa4 in meta_display_process_key_event (display=display@entry=0x1cab8f0, window=window@entry=0x0, event=event@entry=0x37f1df0)at core/keybindings.c:1798
#10 0x00000034f344adce in event_callback (event=0x7fff20b9e130, data=0x1cab8f0) at core/display.c:2056
#11 0x00000034f3493ec3 in filter_func (xevent=0x7fff20b9e130, event=<optimized out>, data=<optimized out>) at ui/ui.c:254
#12 0x00000034f5c51fe1 in gdk_event_apply_filters (xevent=xevent@entry=0x7fff20b9e130, event=event@entry=0x311e6a0, window=window@entry=0x0) at gdkeventsource.c:81
#13 0x00000034f5c522ba in gdk_event_source_translate_event (xevent=0x7fff20b9e130, event_source=0x8e4680) at gdkeventsource.c:195
#14 _gdk_x11_display_queue_events (display=0x8e3050) at gdkeventsource.c:338
#15 0x00000034f5c23d48 in gdk_display_get_event (display=display@entry=0x8e3050) at gdkdisplay.c:313
#16 0x00000034f5c52062 in gdk_event_source_dispatch (source=source@entry=0x8e4680, callback=<optimized out>, user_data=<optimized out>) at gdkeventsource.c:360
#17 0x00007f8c2fb33fe6 in g_main_dispatch (context=0x8b3870) at gmain.c:3054
#18 g_main_context_dispatch (context=context@entry=0x8b3870) at gmain.c:3630
#19 0x00007f8c2fb34338 in g_main_context_iterate (context=0x8b3870, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3701
#20 0x00007f8c2fb3473a in g_main_loop_run (loop=0x8b6110) at gmain.c:3895
#21 0x00000034f34584c1 in meta_run () at core/main.c:556
#22 0x0000000000401f59 in main (argc=1, argv=0x7fff20b9e538) at main.c:430

I do not see the errors like in c#5. I only see the following:
Mar 20 19:49:28 fante.int.rhx /etc/gdm/Xsession[27030]: ** Message: applet now removed from the notification area
Mar 20 19:49:28 fante.int.rhx /etc/gdm/Xsession[27030]: ** Message: applet now embedded in the notification area
Mar 20 19:49:46 fante.int.rhx systemd-logind[805]: Removed session c2.
Mar 20 19:49:46 fante.int.rhx systemd-journal[534]: Forwarding to syslog missed 3 messages.
Mar 20 19:49:46 fante.int.rhx gdm[26930]: AccountsService: ActUserManager: ignoring tty session '3' since it's not graphical
Mar 20 19:49:47 fante.int.rhx fprintd[27013]: ** Message: No devices in use, exit
Mar 20 19:54:38 fante.int.rhx dbus-daemon[813]: dbus[813]: [system] Rejected send message, 2 matched rules; type="method_return", sender=":1.1" (uid=0 pid=805 comm="/usr/lib/systemd/systemd-logind ") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=":1.134" (uid=1000 pid
=27030 comm="gnome-session ")
Mar 20 19:54:38 fante.int.rhx dbus[813]: [system] Rejected send message, 2 matched rules; type="method_return", sender=":1.1" (uid=0 pid=805 comm="/usr/lib/systemd/systemd-logind ") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=":1.134" (uid=1000 pid=27030 comm="gnome
-session ")
Mar 20 19:56:24 fante.int.rhx gdm[26930]: AccountsService: ActUserManager: ignoring tty session '3' since it's not graphical
Mar 20 19:56:24 fante.int.rhx gdm[26930]: AccountsService: ActUserManager: ignoring tty session '3' since it's not graphical
Mar 20 19:57:31 fante.int.rhx gdm[26930]: AccountsService: ActUserManager: ignoring tty session '3' since it's not graphical
Mar 20 19:57:31 fante.int.rhx systemd[1]: Starting Getty on tty3...

Messages at 19:54:38 seem suspicious. Stuff at 19:56:24 is me opening a console on tty 3 to get the gdb output

gnome-shell is at 3.7.92-1

Hope this helps,
Michele
Comment 9 Ray Strode [halfline] 2013-03-20 15:57:40 EDT
if you wait 25 seconds after moving the mouse, does it come up?
Comment 10 Michele Baldessari 2013-03-20 16:11:56 EDT
Nope it does not come up. Although after about 15 seconds powersaving kicks in here. And if I wait 1 minute or so to press a key or move a mouse it still does not come up.
Comment 11 Bastien Nocera 2013-03-21 04:10:38 EDT
This looks like a problem:
Mar 20 19:54:38 fante.int.rhx dbus-daemon[813]: dbus[813]: [system] Rejected send message, 2 matched rules; type="method_return", sender=":1.1" (uid=0 pid=805 comm="/usr/lib/systemd/systemd-logind ") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=":1.134" (uid=1000 pid
=27030 comm="gnome-session ")
Mar 20 19:54:38 fante.int.rhx dbus[813]: [system] Rejected send message, 2 matched rules; type="method_return", sender=":1.1" (uid=0 pid=805 comm="/usr/lib/systemd/systemd-logind ") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=":1.134" (uid=1000 pid=27030 comm="gnome
-session ")
Comment 12 Kamil Páral 2013-03-21 13:07:17 EDT
Proposing as an Alpha Blocker. This renders the system very hardly usable, when it "freezes" every few minutes that you're not working with it.
Comment 13 Adam Williamson 2013-03-21 13:14:53 EDT
I actually intentionally didn't propose it as a blocker myself, because it's fairly trivially workaroundable: just disable the screen lock / blank timeouts. People are expected to be able to work around issues at Alpha.
Comment 14 Kamil Páral 2013-03-21 15:18:19 EDT
I haven't noticed the workaround mentioned, but we can always agree on a different milestone (Beta).
Comment 15 drago01 2013-03-26 05:16:23 EDT
FWIW we have two separate fixes upstream (the bug is in libgnome-desktop) one is to fix libgnome-desktop (backport the fixes from master to 3.8) the other is to add a workaround in gnome-shell.

We should have a fixed version in 3.8.0 (either gnome-shell or libgnome-desktop) depending on which fix we chose. It should be out tomorrow.
Comment 16 Adam Williamson 2013-03-27 13:10:01 EDT
Discussed at 2013-03-27 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-03-27/f19alpha-blocker-review-3.2013-03-27-16.01.log.txt . Rejected as a blocker: this can be worked around simply by pressing Esc, or by disabling the lock timeouts. We would definitely like to have the fix in Alpha, though - we hope you guys get 3.8 packaged ahead of freeze.
Comment 17 Florian Müllner 2013-03-27 15:43:43 EDT
It pretty much is already, see https://koji.fedoraproject.org/koji/buildinfo?buildID=406763
Comment 18 Adam Williamson 2013-06-11 20:47:41 EDT
This is pretty clearly fixed by now, let's close it out.