Bug 952662

Summary: Traceback when doing custom partitioning: NameError: global name 'fs_type_changed' is not defined
Product: [Fedora] Fedora Reporter: Karsten Hopp <karsten>
Component: anacondaAssignee: David Lehman <dlehman>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: 19CC: aj.werkman, anaconda-maint-list, atigro, awilliam, g.kaviyarasu, jonathan, mkolman, robatino, sbueno, tflink, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: ppc64   
OS: Linux   
Whiteboard: RejectedBlocker AcceptedFreezeException
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-04-19 05:48:22 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 834085, 920768    

Description Karsten Hopp 2013-04-16 11:37:54 UTC
Description of problem:
I've tried a custom partition installation on PPC64 with the latest install images which contain anaconda-19.19-1.fc19 and python-blivet-0.11-1.fc19 to work around bug #950700.
The previous system had several partitions, 2 of them encrypted. 
When I tried to re-use one of them (doesn't matter if encrypted or not), selected 'reformat', unselected 'encrypt' and pressed 'apply' I got the following error:

Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/accordion.py", line 239, in _onSelectorClicked
    cb(selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2065, in on_selector_clicked
    self._save_current_selector()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2055, in _save_current_selector
    self._save_right_side(self._current_selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1214, in _save_right_side
    fs_type_changed or
NameError: global name 'fs_type_changed' is not defined


Version-Release number of selected component (if applicable):
anaconda-19.19-1.fc19 
python-blivet-0.11-1.fc19

How reproducible:
always

Steps to Reproduce:
1. re-install an older Fedora system
2. re-use one of the existing partitions
3. press 'Apply'
  
Actual results:


Expected results:


Additional info:

Comment 1 David Lehman 2013-04-16 15:52:13 UTC
*** Bug 952727 has been marked as a duplicate of this bug. ***

Comment 2 Adam Williamson 2013-04-16 16:36:08 UTC
-1 blocker, custom partitioning does not block Alpha. Unfortunate, though. Is this a new bug compared to RC2 or TC6?

Comment 3 David Lehman 2013-04-16 20:53:50 UTC
(In reply to comment #2)
> -1 blocker, custom partitioning does not block Alpha. Unfortunate, though.
> Is this a new bug compared to RC2 or TC6?

It was introduced at the same times as 950700. The fix for that exposed this.

Comment 4 Adam Williamson 2013-04-16 21:07:45 UTC
ah, so basically, the practical upshot is that custom partitioning is fairly borked in both RC2 and RC3. not great, but not terrible.

Comment 5 Adam Williamson 2013-04-16 21:39:03 UTC
https://www.happyassassin.net/extras/updates-952662.img should address this (fix thanks to dlehman). can those affected please check and see if it works for you, and if you can now use custom partitioning successfully without hitting any subsequent bugs? thanks.

Comment 6 Adam Williamson 2013-04-16 22:02:44 UTC
Better updates.img: https://www.happyassassin.net/extras/updates-952662-2.img

Comment 7 Adam Williamson 2013-04-16 23:02:54 UTC
I'd vote -1 blocker, +1 freeze exception. This bug affects all re-use of existing partitions in custom partitioning. This isn't required functionality for Alpha, but it would help testing coverage if we could make it work. Other votes?

Comment 8 Kevin Fenzi 2013-04-16 23:05:46 UTC
Ditto. -1 blocker, but +1 FE

Comment 9 Tim Flink 2013-04-16 23:07:42 UTC
-1 blocker, +1 FE for a well tested fix

That makes -3 blocker, +3 FE. Moving to RejectedBlocker, AcceptedFreezeException

Comment 10 Fedora Update System 2013-04-17 00:51:06 UTC
python-blivet-0.11-1.fc19, lorax-19.2-1.fc19, anaconda-19.20-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/FEDORA-2013-5795/lorax-19.2-1.fc19,python-blivet-0.11-1.fc19,anaconda-19.20-1.fc19

Comment 11 Fedora Update System 2013-04-17 16:27:13 UTC
Package python-blivet-0.11-1.fc19, lorax-19.2-1.fc19, anaconda-19.20-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-blivet-0.11-1.fc19 lorax-19.2-1.fc19 anaconda-19.20-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-5795/lorax-19.2-1.fc19,python-blivet-0.11-1.fc19,anaconda-19.20-1.fc19
then log in and leave karma (feedback).

Comment 12 Adam Williamson 2013-04-18 03:45:03 UTC
Verified fix with RC4.

Comment 13 Fedora Update System 2013-04-19 05:48:25 UTC
python-blivet-0.11-1.fc19, lorax-19.2-1.fc19, anaconda-19.20-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.