Bug 1000889 - AttributeError: 'DeviceFormat' object has no attribute 'mount'
AttributeError: 'DeviceFormat' object has no attribute 'mount'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:7f552d334179e61f8479536ab74...
:
: 997947 (view as bug list)
Depends On:
Blocks: F20AlphaBlocker 1008050
  Show dependency treegraph
 
Reported: 2013-08-26 00:00 EDT by Clyde E. Kunkel
Modified: 2015-01-05 11:24 EST (History)
21 users (show)

See Also:
Fixed In Version: anaconda-20.17-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1008050 (view as bug list)
Environment:
Last Closed: 2013-09-18 22:42:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda.log (8.88 KB, text/plain)
2013-08-26 00:01 EDT, Clyde E. Kunkel
no flags Details
File: environ (441 bytes, text/plain)
2013-08-26 00:01 EDT, Clyde E. Kunkel
no flags Details
File: lsblk_output (12.09 KB, text/plain)
2013-08-26 00:01 EDT, Clyde E. Kunkel
no flags Details
File: nmcli_dev_list (480 bytes, text/plain)
2013-08-26 00:01 EDT, Clyde E. Kunkel
no flags Details
File: os_info (281 bytes, text/plain)
2013-08-26 00:01 EDT, Clyde E. Kunkel
no flags Details
File: program.log (315.51 KB, text/plain)
2013-08-26 00:01 EDT, Clyde E. Kunkel
no flags Details
File: storage.log (957.29 KB, text/plain)
2013-08-26 00:01 EDT, Clyde E. Kunkel
no flags Details
File: syslog (131.16 KB, text/plain)
2013-08-26 00:01 EDT, Clyde E. Kunkel
no flags Details
File: ifcfg.log (573 bytes, text/plain)
2013-08-26 00:01 EDT, Clyde E. Kunkel
no flags Details
File: packaging.log (430.82 KB, text/plain)
2013-08-26 00:01 EDT, Clyde E. Kunkel
no flags Details
File: anaconda-tb (1.53 MB, application/octet-stream)
2013-08-26 00:01 EDT, Clyde E. Kunkel
no flags Details

  None (edit)
Description Clyde E. Kunkel 2013-08-26 00:00:56 EDT
Description of problem:
Selected single disk, btrfs filesystem and custom partitioning.  Clicked done and error occurred.

Version-Release number of selected component:
anaconda-20.8-1

The following was filed automatically by anaconda:
anaconda 20.8-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/image.py", line 194, in opticalInstallMedia
    dev.format.mount(mountpoint=mountpoint)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/source.py", line 581, in _initialize
    self._cdrom = opticalInstallMedia(self.storage.devicetree)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
AttributeError: 'DeviceFormat' object has no attribute 'mount'

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:UUID=a9901eab-13b6-4f9d-8a40-991dd02acaa2 enforcing=0 BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.0-0.rc6.git4.1.fc20.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20-Alpha-TC1

Potential duplicate: bug 997947
Comment 1 Clyde E. Kunkel 2013-08-26 00:01:01 EDT
Created attachment 790250 [details]
File: anaconda.log
Comment 2 Clyde E. Kunkel 2013-08-26 00:01:06 EDT
Created attachment 790251 [details]
File: environ
Comment 3 Clyde E. Kunkel 2013-08-26 00:01:10 EDT
Created attachment 790252 [details]
File: lsblk_output
Comment 4 Clyde E. Kunkel 2013-08-26 00:01:14 EDT
Created attachment 790253 [details]
File: nmcli_dev_list
Comment 5 Clyde E. Kunkel 2013-08-26 00:01:17 EDT
Created attachment 790254 [details]
File: os_info
Comment 6 Clyde E. Kunkel 2013-08-26 00:01:21 EDT
Created attachment 790255 [details]
File: program.log
Comment 7 Clyde E. Kunkel 2013-08-26 00:01:28 EDT
Created attachment 790256 [details]
File: storage.log
Comment 8 Clyde E. Kunkel 2013-08-26 00:01:32 EDT
Created attachment 790257 [details]
File: syslog
Comment 9 Clyde E. Kunkel 2013-08-26 00:01:36 EDT
Created attachment 790258 [details]
File: ifcfg.log
Comment 10 Clyde E. Kunkel 2013-08-26 00:01:41 EDT
Created attachment 790259 [details]
File: packaging.log
Comment 11 Clyde E. Kunkel 2013-08-26 00:01:49 EDT
Created attachment 790260 [details]
File: anaconda-tb
Comment 12 Clyde E. Kunkel 2013-08-26 10:01:36 EDT
May be related to, or same as, 1000703.
Comment 13 A.J. Werkman 2013-08-27 03:12:08 EDT
Just booted and on entering the central UI this bug appears.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:UUID=3cd4da1d-ffdf-4320-afb0-b375dc0d0fb8
hashmarkername: anaconda
kernel:         3.11.0-0.rc6.git4.1.fc20.x86_64
package:        anaconda-20.8-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20-Alpha-TC1
Comment 14 Kamil Páral 2013-08-27 09:20:18 EDT
Selected /dev/sda and hit Reclaim Space

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   inst.repo=nfs:nfs.englab.brq.redhat.com:/pub/fedora/fedora-alt/stage/20-Alpha-TC1/Fedora/x86_64/iso/Fedora-20-Alpha-TC1-x86_64-DVD.iso initrd=F20/Alpha-TC1/x86_64/initrd.img BOOT_IMAGE=F20/Alpha-TC1/x86_64/vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-0.rc6.git4.1.fc20.x86_64
package:        anaconda-20.8-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20-Alpha-TC1
Comment 15 Kamil Páral 2013-08-27 09:24:25 EDT
Proposing Alpha blocker:
The installer must be able to complete an installation to a single disk using automatic partitioning. 
https://fedoraproject.org/wiki/Fedora_20_Alpha_Release_Criteria#Disk_layouts
Comment 16 stan 2013-08-27 10:25:41 EDT
Custom partitioning using standard partitioning using netinstall.

Want to reuse occupied ext4 partitions as install target.

Installer checked media before install.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha-TC1\x20x86_64 rd.live.check quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-0.rc6.git4.1.fc20.x86_64
package:        anaconda-20.8-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20-Alpha-TC1
Comment 17 Kamil Páral 2013-08-28 12:10:34 EDT
Discussed at 2013-08-28 blocker review meeting [1]. This is accepted as an Alpha blocker, because it violates the following F20 alpha release criterion: "The installer must be able to complete an installation to a single disk using automatic partitioning." [2]

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-08-28/
[2] https://fedoraproject.org/wiki/Fedora_20_Alpha_Release_Criteria#Disk_layouts
Comment 18 Chuck Forsberg 2013-08-29 01:50:46 EDT
Booted installer from jump drive 64 bit tc2

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha-TC2\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-0.rc7.git0.1.fc20.x86_64
package:        anaconda-20.9-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20-Alpha-TC2
Comment 19 A.J. Werkman 2013-08-29 02:21:09 EDT
During fetching of repodata this error comes up.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.repo=http://thlin.digifarma.nl/fedora/releases/220-Alpha-TC2/Fedora/x86_64/os inst.stage2=hd:UUID=3cd4da1d-ffdf-4320-afb0-b375dc0d0fb8
hashmarkername: anaconda
kernel:         3.11.0-0.rc7.git0.1.fc20.x86_64
package:        anaconda-20.9-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20-Alpha-TC2
Comment 20 Clyde E. Kunkel 2013-08-29 12:44:56 EDT
Same problem as in 20.8-1, bz 1000889. 

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:UUID=a9901eab-13b6-4f9d-8a40-991dd02acaa2 enforcing=0 BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-0.rc7.git0.1.fc20.x86_64
package:        anaconda-20.9-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20-Alpha-TC2
Comment 21 Stephen Gallagher 2013-08-29 13:15:37 EDT
I used liveusb-creator to burn the F20 Alpha TC2 netinst ISO to a USB stick and booted from it.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=LIVE quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-0.rc7.git0.1.fc20.x86_64
package:        anaconda-20.9-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20-Alpha-TC2
Comment 22 Igor Gnatenko 2013-09-01 02:54:27 EDT
Started install F20 TC2

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha-TC2\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-0.rc7.git0.1.fc20.x86_64
package:        anaconda-20.9-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20-Alpha-TC2
Comment 23 Chuck Forsberg 2013-09-01 11:26:00 EDT
loaded with pxeboot
Anaconda 20.9-1 I think

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img ramdisk_size=9216 root=live:http://192.168.1.13/squashfs.img repo=http://192.168.1.13/fc20/os BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-0.rc7.git4.1.fc20.x86_64
package:        anaconda-20.9-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20
Comment 24 Ed Greshko 2013-09-01 19:27:57 EDT
Apologies to caf@omen.com.  My ill cat wearing a soft collar plunked herself down on my mouse and inadvertently clicked on the unsubscribe link he had included in a email to the test mailing list.  I hope I can add him back from the Cc: list.
Comment 25 Felix Miata 2013-09-01 22:59:43 EDT
I've tried to install this TC2 via HTTP several times. It errored early every time. This time was a second error at the same earliest point, without having clicked anything on the "spoke" screen, while waiting on all spokes except partitioning to reach ready state. Last click was on the beta software ackknowledgement.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   stage2=hd:/dev/sda12:/squashfs.img repo=http://alt.fedoraproject.org/pub/alt/stage/20-Alpha-TC2/Fedora/x86_64/os selinux=0 ip=192.168.0.41::192.168.0.50:255.255.255.0:big41::none nameserver=192.168.0.50 resolution='1024x768' video=1280x1024 vga=791 FONT=latarcyrheb-sun16 splash=verbose rd.luks=0 rd.md=0 rd.dm=0 nofirewire
hashmarkername: anaconda
kernel:         3.11.0-0.rc7.git0.1.fc20.x86_64
package:        anaconda-20.9-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20-Alpha-TC2
Comment 26 Martin Bříza 2013-09-03 09:50:34 EDT
Started the Fedora 20 installer from September 2nd, tried to set keyboard layout.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=/distrotrees/63980/initrd method=http://download-01.eng.brq.redhat.com/pub/fedora/linux/development-snapshot-20130903/20/x86_64/os/ repo=http://download-01.eng.brq.redhat.com/pub/fedora/linux/development-snapshot-20130903/20/x86_64/os/  BOOT_IMAGE=/distrotrees/63980/kernel 
hashmarkername: anaconda
kernel:         3.11.0-0.rc7.git4.1.fc20.x86_64
package:        anaconda-20.9-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20
Comment 27 Martin Bříza 2013-09-03 09:53:41 EDT
Tried the text mode installation, anaconda crashed when I tried to select my timezone

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=/distrotrees/63980/initrd method=http://download-01.eng.brq.redhat.com/pub/fedora/linux/development-snapshot-20130903/20/x86_64/os/ repo=http://download-01.eng.brq.redhat.com/pub/fedora/linux/development-snapshot-20130903/20/x86_64/os/  BOOT_IMAGE=/distrotrees/63980/kernel 
hashmarkername: anaconda
kernel:         3.11.0-0.rc7.git4.1.fc20.x86_64
package:        anaconda-20.9-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20
Comment 28 John Reiser 2013-09-04 17:28:13 EDT
Select one drive from 4, click on "Full disk summary and bootloader", try to omit install of bootloader.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha-TC3\x20x86_64 rd.live.check BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-0.rc7.git5.1.fc20.x86_64
package:        anaconda-20.9-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20-Alpha-TC3
Comment 29 Felix Miata 2013-09-04 19:28:48 EDT
ditto comment 25 but with TC3

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   stage2=hd:/dev/sda12:/squashfs.img repo=http://alt.fedoraproject.org/pub/alt/stage/20-Alpha-TC2/Fedora/x86_64/os selinux=0 ip=192.168.0.41::192.168.0.50:255.255.255.0:big41::none nameserver=192.168.0.50 resolution='1024x768' video=1280x1024 vga=791 splash=verbose nofirewire ipv6.disable=1
hashmarkername: anaconda
kernel:         3.11.0-0.rc7.git5.1.fc20.x86_64
package:        anaconda-20.9-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20-Alpha-TC3
Comment 30 stan 2013-09-04 22:17:32 EDT
If you haven't downloaded TC3 yet, don't waste your time.  It still has anaconda 20.9.1.  The fix for this problem is in 20.10.1.  I guess communication just got crossed.  The new version is on koji, in fact there is a 20.10.2 out there.  I might try downloading it and rebuilding the iso with the new version.  Or I might just wait for it to get fixed.
Comment 31 Chuck Forsberg 2013-09-05 09:43:34 EDT
Abended right after "accept your fate" answered.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img ramdisk_size=9216 root=live:http://192.168.1.13/squashfs.img repo=http://192.168.1.13/fc20/os BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
package:        anaconda-20.10-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20
Comment 32 Chuck Forsberg 2013-09-05 10:02:46 EDT
right after "fate"

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha-TC4\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
package:        anaconda-20.10-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20-Alpha-TC4
Comment 33 A.J. Werkman 2013-09-05 12:39:11 EDT
Did nothing special. Just entered the central pane and there it was.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz ip=172.18.92.70::172.18.92.65:255.255.255.192:cfl.lc.digifarma.nl::none ip=[2001:838:375:2::70]::[2001:838:375:2::1]:64:cfl.lc.digifarma.nl::none nameserver=172.18.92.65 nameserver=2001:838:375:2::1 inst.stage2=hd:UUID=5bc83d42-0167-44d3-9767-4d8de9516c61
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
package:        anaconda-20.10-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20-Alpha-TC4
Comment 34 Felix Miata 2013-09-05 16:13:51 EDT
ditto comment 25, except using TC4 instead
"downloading metadata" never cleared from the two center spokes before the error window appeared.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   stage2=hd:/dev/sda12:/squashfs.img repo=http://alt.fedoraproject.org/pub/alt/stage/20-Alpha-TC2/Fedora/x86_64/os selinux=0 ip=192.168.0.41::192.168.0.50:255.255.255.0:big41::none nameserver=192.168.0.50 resolution='1024x768' video=1280x1024 vga=791 splash=verbose ipv6.disable=1
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
package:        anaconda-20.10-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20-Alpha-TC4
Comment 35 Fedora Update System 2013-09-05 20:54:42 EDT
anaconda-20.11-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.11-1.fc20
Comment 36 Mukundan Ragavan 2013-09-05 22:11:26 EDT
This crash **seems** to be happening after a certain duration of navigating around anaconda when installing via USB.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha-TC4\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
package:        anaconda-20.10-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20-Alpha-TC4
Comment 37 Alexander Volovics 2013-09-06 06:43:55 EDT
Using netinstall for F20. Halted when anaconda was being started.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora\x2020-Alpha-TC4\x20x86_64 quiet
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
package:        anaconda-20.10-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20-Alpha-TC4
Comment 38 Chuck Forsberg 2013-09-06 10:58:21 EDT
Right after "fate" without any other user input

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img ramdisk_size=9216 root=live:http://192.168.1.13/squashfs.img repo=http://192.168.1.13/fc20/os BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
package:        anaconda-20.10-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20
Comment 39 Fedora Update System 2013-09-06 13:27:41 EDT
Package anaconda-20.11-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-20.11-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15977/anaconda-20.11-1.fc20
then log in and leave karma (feedback).
Comment 40 Fedora Update System 2013-09-06 18:43:29 EDT
anaconda-20.12-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.12-1.fc20
Comment 41 Felix Miata 2013-09-09 07:21:44 EDT
Finally this did not happen with TC5.
Comment 42 Mukundan Ragavan 2013-09-09 09:21:35 EDT
No issues with TC5 on this across multiple installation attempts. Everything proceeds as normal.
Comment 43 stan 2013-09-09 13:09:30 EDT
TC5 does not get this error anymore.  Looks like anaconda 20-11.1 fixed it as it said it would.  Unfortunately, while this bug seems to be fixed, TC5 failed every time with bug BZ 1004846.
Comment 44 Fedora Update System 2013-09-09 20:12:20 EDT
anaconda-20.13-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.13-1.fc20
Comment 45 Kamil Páral 2013-09-10 07:31:12 EDT
Setting VERIFIED per comments 41 through 43.
Comment 46 Fedora Update System 2013-09-10 15:49:31 EDT
anaconda-20.14-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.14-1.fc20
Comment 47 Fedora Update System 2013-09-11 21:04:32 EDT
anaconda-20.15-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.15-1.fc20
Comment 48 Alex Perez 2013-09-13 19:13:27 EDT
I just chose 1 for "text install" and it bombed

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   xdriver=vesa nomodeset text repo=http://mirrors.kernel.org/fedora/development/20/x86_64/os
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
package:        anaconda-20.10-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20
Comment 49 Alex Perez 2013-09-13 19:26:52 EDT
just started VNC install via netboot

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   xdriver=vesa nomodeset text repo=http://mirrors.kernel.org/fedora/development/20/x86_64/os
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
package:        anaconda-20.10-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20
Comment 50 Fedora Update System 2013-09-13 21:06:16 EDT
anaconda-20.16-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.16-1.fc20
Comment 51 Phil 2013-09-14 00:13:00 EDT
I currently have F19 installed to sda1 which is formatted with XFS.  I have no need for swap or boot so just have xfs taking up the entire ssd.  If in the future i have a need to expand the drive I will buy a new ssd and use my 1337 skills to format it and move data.  I do have a dvd rom installed, but it is empty.  That's the most I can discern from the stack trace - python isn't my forte..

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img.f20 repo=http://repo/pub/fedora/linux/development/20/x86_64/os ip=dhcp ipv6=none keymap=us BOOT_IMAGE=vmlinuz.f20 
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
package:        anaconda-20.10-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20
Comment 52 Phil 2013-09-14 01:15:01 EDT
I can confirm that the update in comment 47 fixes this issue.
# read http://fedoraproject.org/wiki/Anaconda/Updates
# download the srpm and the 3 compiled rpms for your arch from http://koji.fedoraproject.org/koji/buildinfo?buildID=463917
# rpmdev-setuptree
# rpm -ivh $srpm && cd ~/rpmbuild/SOURCES && tar jxf anaconda<tab> && cd $dir
# ./scripts/makeupdates -a $rpm1 -a $rpm2 -a $rpm3
# put updates.img in the correct place per the guide
# boot in to the installer
# profit
Comment 53 Fedora Update System 2013-09-16 13:49:17 EDT
anaconda-20.17-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.17-1.fc20
Comment 54 Fedora Update System 2013-09-18 22:42:22 EDT
anaconda-20.17-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 55 David Shea 2015-01-05 11:24:07 EST
*** Bug 997947 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.