Bug 1008050 - AttributeError: 'DeviceFormat' object has no attribute 'mount'
AttributeError: 'DeviceFormat' object has no attribute 'mount'
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.0
x86_64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
abrt_hash:7f552d334179e61f8479536ab74...
:
Depends On: 1000889
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-13 20:10 EDT by Brian Lane
Modified: 2014-09-13 15:00 EDT (History)
21 users (show)

See Also:
Fixed In Version: anaconda-19.31.17-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1000889
Environment:
Last Closed: 2014-06-13 08:38:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Lane 2013-09-13 20:10:35 EDT
+++ This bug was initially created as a clone of Bug #1000889 +++

Description of problem:
Selected single disk, btrfs filesystem and custom partitioning.  Clicked done and error occurred.

Version-Release number of selected component:
anaconda-20.8-1

The following was filed automatically by anaconda:
anaconda 20.8-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/image.py", line 194, in opticalInstallMedia
    dev.format.mount(mountpoint=mountpoint)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/source.py", line 581, in _initialize
    self._cdrom = opticalInstallMedia(self.storage.devicetree)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
AttributeError: 'DeviceFormat' object has no attribute 'mount'

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:UUID=a9901eab-13b6-4f9d-8a40-991dd02acaa2 enforcing=0 BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.0-0.rc6.git4.1.fc20.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20-Alpha-TC1

Potential duplicate: bug 997947

--- Additional comment from Clyde E. Kunkel on 2013-08-26 00:01:01 EDT ---



--- Additional comment from Clyde E. Kunkel on 2013-08-26 00:01:06 EDT ---



--- Additional comment from Clyde E. Kunkel on 2013-08-26 00:01:10 EDT ---



--- Additional comment from Clyde E. Kunkel on 2013-08-26 00:01:14 EDT ---



--- Additional comment from Clyde E. Kunkel on 2013-08-26 00:01:17 EDT ---



--- Additional comment from Clyde E. Kunkel on 2013-08-26 00:01:21 EDT ---



--- Additional comment from Clyde E. Kunkel on 2013-08-26 00:01:28 EDT ---



--- Additional comment from Clyde E. Kunkel on 2013-08-26 00:01:32 EDT ---



--- Additional comment from Clyde E. Kunkel on 2013-08-26 00:01:36 EDT ---



--- Additional comment from Clyde E. Kunkel on 2013-08-26 00:01:41 EDT ---



--- Additional comment from Clyde E. Kunkel on 2013-08-26 00:01:49 EDT ---



--- Additional comment from Clyde E. Kunkel on 2013-08-26 10:01:36 EDT ---

May be related to, or same as, 1000703.

--- Additional comment from A.J. Werkman on 2013-08-27 03:12:08 EDT ---

Just booted and on entering the central UI this bug appears.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:UUID=3cd4da1d-ffdf-4320-afb0-b375dc0d0fb8
hashmarkername: anaconda
kernel:         3.11.0-0.rc6.git4.1.fc20.x86_64
package:        anaconda-20.8-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20-Alpha-TC1

--- Additional comment from Kamil Páral on 2013-08-27 09:20:18 EDT ---

Selected /dev/sda and hit Reclaim Space

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   inst.repo=nfs:nfs.englab.brq.redhat.com:/pub/fedora/fedora-alt/stage/20-Alpha-TC1/Fedora/x86_64/iso/Fedora-20-Alpha-TC1-x86_64-DVD.iso initrd=F20/Alpha-TC1/x86_64/initrd.img BOOT_IMAGE=F20/Alpha-TC1/x86_64/vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-0.rc6.git4.1.fc20.x86_64
package:        anaconda-20.8-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20-Alpha-TC1

--- Additional comment from Kamil Páral on 2013-08-27 09:24:25 EDT ---

Proposing Alpha blocker:
The installer must be able to complete an installation to a single disk using automatic partitioning. 
https://fedoraproject.org/wiki/Fedora_20_Alpha_Release_Criteria#Disk_layouts

--- Additional comment from stan on 2013-08-27 10:25:41 EDT ---

Custom partitioning using standard partitioning using netinstall.

Want to reuse occupied ext4 partitions as install target.

Installer checked media before install.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha-TC1\x20x86_64 rd.live.check quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-0.rc6.git4.1.fc20.x86_64
package:        anaconda-20.8-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20-Alpha-TC1

--- Additional comment from Kamil Páral on 2013-08-28 12:10:34 EDT ---

Discussed at 2013-08-28 blocker review meeting [1]. This is accepted as an Alpha blocker, because it violates the following F20 alpha release criterion: "The installer must be able to complete an installation to a single disk using automatic partitioning." [2]

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-08-28/
[2] https://fedoraproject.org/wiki/Fedora_20_Alpha_Release_Criteria#Disk_layouts

--- Additional comment from Chuck Forsberg on 2013-08-29 01:50:46 EDT ---

Booted installer from jump drive 64 bit tc2

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha-TC2\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-0.rc7.git0.1.fc20.x86_64
package:        anaconda-20.9-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20-Alpha-TC2

--- Additional comment from A.J. Werkman on 2013-08-29 02:21:09 EDT ---

During fetching of repodata this error comes up.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.repo=http://thlin.digifarma.nl/fedora/releases/220-Alpha-TC2/Fedora/x86_64/os inst.stage2=hd:UUID=3cd4da1d-ffdf-4320-afb0-b375dc0d0fb8
hashmarkername: anaconda
kernel:         3.11.0-0.rc7.git0.1.fc20.x86_64
package:        anaconda-20.9-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20-Alpha-TC2

--- Additional comment from Clyde E. Kunkel on 2013-08-29 12:44:56 EDT ---

Same problem as in 20.8-1, bz 1000889. 

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:UUID=a9901eab-13b6-4f9d-8a40-991dd02acaa2 enforcing=0 BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-0.rc7.git0.1.fc20.x86_64
package:        anaconda-20.9-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20-Alpha-TC2

--- Additional comment from Stephen Gallagher on 2013-08-29 13:15:37 EDT ---

I used liveusb-creator to burn the F20 Alpha TC2 netinst ISO to a USB stick and booted from it.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=LIVE quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-0.rc7.git0.1.fc20.x86_64
package:        anaconda-20.9-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20-Alpha-TC2

--- Additional comment from Igor Gnatenko on 2013-09-01 02:54:27 EDT ---

Started install F20 TC2

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha-TC2\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-0.rc7.git0.1.fc20.x86_64
package:        anaconda-20.9-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20-Alpha-TC2

--- Additional comment from Chuck Forsberg on 2013-09-01 11:26:00 EDT ---

loaded with pxeboot
Anaconda 20.9-1 I think

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img ramdisk_size=9216 root=live:http://192.168.1.13/squashfs.img repo=http://192.168.1.13/fc20/os BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-0.rc7.git4.1.fc20.x86_64
package:        anaconda-20.9-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20

--- Additional comment from Ed Greshko on 2013-09-01 19:27:57 EDT ---

Apologies to caf@omen.com.  My ill cat wearing a soft collar plunked herself down on my mouse and inadvertently clicked on the unsubscribe link he had included in a email to the test mailing list.  I hope I can add him back from the Cc: list.

--- Additional comment from Felix Miata on 2013-09-01 22:59:43 EDT ---

I've tried to install this TC2 via HTTP several times. It errored early every time. This time was a second error at the same earliest point, without having clicked anything on the "spoke" screen, while waiting on all spokes except partitioning to reach ready state. Last click was on the beta software ackknowledgement.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   stage2=hd:/dev/sda12:/squashfs.img repo=http://alt.fedoraproject.org/pub/alt/stage/20-Alpha-TC2/Fedora/x86_64/os selinux=0 ip=192.168.0.41::192.168.0.50:255.255.255.0:big41::none nameserver=192.168.0.50 resolution='1024x768' video=1280x1024 vga=791 FONT=latarcyrheb-sun16 splash=verbose rd.luks=0 rd.md=0 rd.dm=0 nofirewire
hashmarkername: anaconda
kernel:         3.11.0-0.rc7.git0.1.fc20.x86_64
package:        anaconda-20.9-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20-Alpha-TC2

--- Additional comment from Martin Bříza on 2013-09-03 09:50:34 EDT ---

Started the Fedora 20 installer from September 2nd, tried to set keyboard layout.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=/distrotrees/63980/initrd method=http://download-01.eng.brq.redhat.com/pub/fedora/linux/development-snapshot-20130903/20/x86_64/os/ repo=http://download-01.eng.brq.redhat.com/pub/fedora/linux/development-snapshot-20130903/20/x86_64/os/  BOOT_IMAGE=/distrotrees/63980/kernel 
hashmarkername: anaconda
kernel:         3.11.0-0.rc7.git4.1.fc20.x86_64
package:        anaconda-20.9-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20

--- Additional comment from Martin Bříza on 2013-09-03 09:53:41 EDT ---

Tried the text mode installation, anaconda crashed when I tried to select my timezone

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=/distrotrees/63980/initrd method=http://download-01.eng.brq.redhat.com/pub/fedora/linux/development-snapshot-20130903/20/x86_64/os/ repo=http://download-01.eng.brq.redhat.com/pub/fedora/linux/development-snapshot-20130903/20/x86_64/os/  BOOT_IMAGE=/distrotrees/63980/kernel 
hashmarkername: anaconda
kernel:         3.11.0-0.rc7.git4.1.fc20.x86_64
package:        anaconda-20.9-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20

--- Additional comment from John Reiser on 2013-09-04 17:28:13 EDT ---

Select one drive from 4, click on "Full disk summary and bootloader", try to omit install of bootloader.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha-TC3\x20x86_64 rd.live.check BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-0.rc7.git5.1.fc20.x86_64
package:        anaconda-20.9-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20-Alpha-TC3

--- Additional comment from Felix Miata on 2013-09-04 19:28:48 EDT ---

ditto comment 25 but with TC3

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   stage2=hd:/dev/sda12:/squashfs.img repo=http://alt.fedoraproject.org/pub/alt/stage/20-Alpha-TC2/Fedora/x86_64/os selinux=0 ip=192.168.0.41::192.168.0.50:255.255.255.0:big41::none nameserver=192.168.0.50 resolution='1024x768' video=1280x1024 vga=791 splash=verbose nofirewire ipv6.disable=1
hashmarkername: anaconda
kernel:         3.11.0-0.rc7.git5.1.fc20.x86_64
package:        anaconda-20.9-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20-Alpha-TC3

--- Additional comment from stan on 2013-09-04 22:17:32 EDT ---

If you haven't downloaded TC3 yet, don't waste your time.  It still has anaconda 20.9.1.  The fix for this problem is in 20.10.1.  I guess communication just got crossed.  The new version is on koji, in fact there is a 20.10.2 out there.  I might try downloading it and rebuilding the iso with the new version.  Or I might just wait for it to get fixed.

--- Additional comment from Chuck Forsberg on 2013-09-05 09:43:34 EDT ---

Abended right after "accept your fate" answered.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img ramdisk_size=9216 root=live:http://192.168.1.13/squashfs.img repo=http://192.168.1.13/fc20/os BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
package:        anaconda-20.10-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20

--- Additional comment from Chuck Forsberg on 2013-09-05 10:02:46 EDT ---

right after "fate"

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha-TC4\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
package:        anaconda-20.10-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20-Alpha-TC4

--- Additional comment from A.J. Werkman on 2013-09-05 12:39:11 EDT ---

Did nothing special. Just entered the central pane and there it was.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz ip=172.18.92.70::172.18.92.65:255.255.255.192:cfl.lc.digifarma.nl::none ip=[2001:838:375:2::70]::[2001:838:375:2::1]:64:cfl.lc.digifarma.nl::none nameserver=172.18.92.65 nameserver=2001:838:375:2::1 inst.stage2=hd:UUID=5bc83d42-0167-44d3-9767-4d8de9516c61
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
package:        anaconda-20.10-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20-Alpha-TC4

--- Additional comment from Felix Miata on 2013-09-05 16:13:51 EDT ---

ditto comment 25, except using TC4 instead
"downloading metadata" never cleared from the two center spokes before the error window appeared.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   stage2=hd:/dev/sda12:/squashfs.img repo=http://alt.fedoraproject.org/pub/alt/stage/20-Alpha-TC2/Fedora/x86_64/os selinux=0 ip=192.168.0.41::192.168.0.50:255.255.255.0:big41::none nameserver=192.168.0.50 resolution='1024x768' video=1280x1024 vga=791 splash=verbose ipv6.disable=1
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
package:        anaconda-20.10-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20-Alpha-TC4

--- Additional comment from Fedora Update System on 2013-09-05 20:54:42 EDT ---

anaconda-20.11-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.11-1.fc20

--- Additional comment from  on 2013-09-05 22:11:26 EDT ---

This crash **seems** to be happening after a certain duration of navigating around anaconda when installing via USB.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha-TC4\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
package:        anaconda-20.10-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20-Alpha-TC4

--- Additional comment from Alexander Volovics on 2013-09-06 06:43:55 EDT ---

Using netinstall for F20. Halted when anaconda was being started.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora\x2020-Alpha-TC4\x20x86_64 quiet
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
package:        anaconda-20.10-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20-Alpha-TC4

--- Additional comment from Chuck Forsberg on 2013-09-06 10:58:21 EDT ---

Right after "fate" without any other user input

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img ramdisk_size=9216 root=live:http://192.168.1.13/squashfs.img repo=http://192.168.1.13/fc20/os BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
package:        anaconda-20.10-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20

--- Additional comment from Fedora Update System on 2013-09-06 13:27:41 EDT ---

Package anaconda-20.11-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-20.11-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15977/anaconda-20.11-1.fc20
then log in and leave karma (feedback).

--- Additional comment from Fedora Update System on 2013-09-06 18:43:29 EDT ---

anaconda-20.12-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.12-1.fc20

--- Additional comment from Felix Miata on 2013-09-09 07:21:44 EDT ---

Finally this did not happen with TC5.

--- Additional comment from  on 2013-09-09 09:21:35 EDT ---

No issues with TC5 on this across multiple installation attempts. Everything proceeds as normal.

--- Additional comment from stan on 2013-09-09 13:09:30 EDT ---

TC5 does not get this error anymore.  Looks like anaconda 20-11.1 fixed it as it said it would.  Unfortunately, while this bug seems to be fixed, TC5 failed every time with bug BZ 1004846.

--- Additional comment from Fedora Update System on 2013-09-09 20:12:20 EDT ---

anaconda-20.13-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.13-1.fc20

--- Additional comment from Kamil Páral on 2013-09-10 07:31:12 EDT ---

Setting VERIFIED per comments 41 through 43.

--- Additional comment from Fedora Update System on 2013-09-10 15:49:31 EDT ---

anaconda-20.14-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.14-1.fc20

--- Additional comment from Fedora Update System on 2013-09-11 21:04:32 EDT ---

anaconda-20.15-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.15-1.fc20

--- Additional comment from Alex Perez on 2013-09-13 19:13:27 EDT ---

I just chose 1 for "text install" and it bombed

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   xdriver=vesa nomodeset text repo=http://mirrors.kernel.org/fedora/development/20/x86_64/os
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
package:        anaconda-20.10-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20

--- Additional comment from Alex Perez on 2013-09-13 19:26:52 EDT ---

just started VNC install via netboot

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   xdriver=vesa nomodeset text repo=http://mirrors.kernel.org/fedora/development/20/x86_64/os
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
package:        anaconda-20.10-1
product:        Fedora
reason:         AttributeError: 'DeviceFormat' object has no attribute 'mount'
release:        Cannot get release name.
version:        20
Comment 5 Michal Kovarik 2014-02-05 09:22:29 EST
Verified on anaconda-19.31.51-1.el7. I was able to install system with btrfs on one device via custom partition screen.
Comment 6 Ludek Smid 2014-06-13 08:38:37 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.