Bug 1004846 - AttributeError: 'NoneType' object has no attribute 'id'
AttributeError: 'NoneType' object has no attribute 'id'
Status: CLOSED DUPLICATE of bug 1004572
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:3ba05e85f6b14b9eb8ecb649727...
:
Depends On:
Blocks: F20BetaBlocker
  Show dependency treegraph
 
Reported: 2013-09-05 11:24 EDT by stan
Modified: 2013-09-10 16:07 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-10 16:07:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: anaconda-tb (514.61 KB, text/plain)
2013-09-05 11:25 EDT, stan
no flags Details
File: anaconda.log (21.95 KB, text/plain)
2013-09-05 11:25 EDT, stan
no flags Details
File: environ (441 bytes, text/plain)
2013-09-05 11:25 EDT, stan
no flags Details
File: lsblk_output (3.26 KB, text/plain)
2013-09-05 11:25 EDT, stan
no flags Details
File: nmcli_dev_list (4.40 KB, text/plain)
2013-09-05 11:25 EDT, stan
no flags Details
File: os_info (281 bytes, text/plain)
2013-09-05 11:25 EDT, stan
no flags Details
File: program.log (67.58 KB, text/plain)
2013-09-05 11:25 EDT, stan
no flags Details
File: storage.log (179.55 KB, text/plain)
2013-09-05 11:25 EDT, stan
no flags Details
File: syslog (87.77 KB, text/plain)
2013-09-05 11:25 EDT, stan
no flags Details
File: ifcfg.log (573 bytes, text/plain)
2013-09-05 11:25 EDT, stan
no flags Details
File: packaging.log (238.37 KB, text/plain)
2013-09-05 11:25 EDT, stan
no flags Details

  None (edit)
Description stan 2013-09-05 11:24:51 EDT
Description of problem:
Using netinst from CD

Got to custom partition screen (yay, progress)

Selecting an existing ext4 partition with + led to this error.  But only after setting as mount point /.

Several tries gave error while configuring custom partioning dialog.

Version-Release number of selected component:
anaconda-20.10-1

The following was filed automatically by anaconda:
anaconda 20.10-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 1948, in copy
    root.swaps = [new.devicetree.getDeviceByID(d.id) for d in root.swaps]
  File "/usr/lib/python2.7/site-packages/blivet/devicefactory.py", line 767, in _save_devicetree
    _blivet_copy = self.storage.copy()
  File "/usr/lib/python2.7/site-packages/blivet/devicefactory.py", line 704, in configure
    self._save_devicetree()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 1924, in factoryDevice
    factory.configure()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2001, in on_add_clicked
    **kwargs)
AttributeError: 'NoneType' object has no attribute 'id'

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha-TC4\x20x86_64 rd.live.check quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20-Alpha-TC4
Comment 1 stan 2013-09-05 11:25:02 EDT
Created attachment 794310 [details]
File: anaconda-tb
Comment 2 stan 2013-09-05 11:25:06 EDT
Created attachment 794311 [details]
File: anaconda.log
Comment 3 stan 2013-09-05 11:25:09 EDT
Created attachment 794312 [details]
File: environ
Comment 4 stan 2013-09-05 11:25:13 EDT
Created attachment 794313 [details]
File: lsblk_output
Comment 5 stan 2013-09-05 11:25:17 EDT
Created attachment 794314 [details]
File: nmcli_dev_list
Comment 6 stan 2013-09-05 11:25:21 EDT
Created attachment 794315 [details]
File: os_info
Comment 7 stan 2013-09-05 11:25:25 EDT
Created attachment 794316 [details]
File: program.log
Comment 8 stan 2013-09-05 11:25:31 EDT
Created attachment 794317 [details]
File: storage.log
Comment 9 stan 2013-09-05 11:25:35 EDT
Created attachment 794318 [details]
File: syslog
Comment 10 stan 2013-09-05 11:25:39 EDT
Created attachment 794320 [details]
File: ifcfg.log
Comment 11 stan 2013-09-05 11:25:45 EDT
Created attachment 794321 [details]
File: packaging.log
Comment 12 stan 2013-09-05 11:39:19 EDT
This is to flesh out the report a little bit.  I use a custom keyboard layout, and using qwerty is hunt and peck.  So I keep things very brief.

The first boot of the CD, I checked the media, which passed.  When I selected devices, I was immediately taken the the screen where I could select custom partitioning with standard partitions, and it brought up the custom partitioning screen.  But while I could select /boot and swap, no amount of selection could get a / partition.  Eventually, it received an error and aborted.  Incidentally, the custom partition screen brought up Fedora installations that weren't on the disk I selected for targeting.  I don't think that should happen.  

I tried rebooting several times, and never made it back to the custom partitioning screen.  I think I received the error from BZ 1000889.  Tried powering down before instead of reboot, using check media, no check.  Nothing seemed to work.

Eventually, I did make it back to the custom partition screen, but when I selected a / partition, it crashed again.

So the error on reaching custom partitioning seems to be intermittent, while the crash in custom partitioning is deterministic.
Comment 13 stan 2013-09-05 12:12:29 EDT
An observation on the custom partitioning.

The old anaconda worked flawlessly for me, and seemed so much more intuitively obvious.  Is there a way that the custom partitioning logic that used to work so well could be integrated into the new anaconda?

Maybe it will grow on me with familiarity, but I find this new way of doing custom partitioning confusing.  There seems to be two ways of specifying a mount point, or a sequence.  Clicking the + to assign a partition to a mount point, and then having to fill in the mount point in the upper right hand description, where the update button has to then be clicked.

Just thought of another strangeness.  When the custom partitioning screen came up, it assigned all the partitions on the selected disk to a Fedora installation that was on another disk, a disk that wasn't selected.  But it also assigned all the partitions on the disk to the two Fedora installations that are on the selected disk.  But those installations only use 2 partitions each (a / and a /boot).  That seems wrong, like the partition analysis can't figure out what's happening, and so assigns everything to everything as a backup.  I think it would be better to just list the partitions and their labels in that case, and forget about trying to assign them to existing installations.
Comment 14 stan 2013-09-05 19:30:45 EDT
I saw on the test list that someone had been able to successfully install F20 using the TC4 netinstall image, with standard partitions and custom partitions.  So I tried another half dozen times.  I never got as far as the first time I tried.  

All the errors except 1 were the error reported in BZ 1000889.  The other error went into reboot without any message.  I could consistently get to disk selection page, but it got the error once when I clicked done.  I also got a couple of errors on the custom partition dialog when I was selecting either standard partition or custom partition.  And when I made it to the custom partition page, I couldn't assign any partition to a mount point.  Once, it wouldn't expand the existing installations so I could see no partitions, and once it crashed as I tried to assign the /boot mount point.

I tried both a DVD reader and a CD reader.  And the media checked fine.  Bizarre!
Comment 15 Clyde E. Kunkel 2013-09-06 09:29:45 EDT
Selected single disk. Chose btrfs fs and custom partitioning.  Deleted existing btrfs fs on disk, clicked + to create 50GB btrfs fs.  Anaconda froze for about 25 seconds, then error dialogue came up.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:UUID=a9901eab-13b6-4f9d-8a40-991dd02acaa2 selinux=0 BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
package:        anaconda-20.10-1
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'id'
release:        Cannot get release name.
version:        20-Alpha-TC4
Comment 16 Clyde E. Kunkel 2013-09-08 22:32:28 EDT
This is rediculous that this problem has not been fixed as it has been reported many, many time during this cycle.

Selected a single disk, custom paritioning, btrfs fs.  Clicked + to create the / partition and then the error occurs.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:UUID=a9901eab-13b6-4f9d-8a40-991dd02acaa2 selinux=0 BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
package:        anaconda-20.12-1
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'id'
release:        Cannot get release name.
version:        20-Alpha-TC5
Comment 17 stan 2013-09-09 12:41:35 EDT
Select existing ext4 partition as root partition.  Install pauses, then has this error.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha-TC5\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
package:        anaconda-20.12-1
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'id'
release:        Cannot get release name.
version:        20-Alpha-TC5
Comment 18 stan 2013-09-09 13:06:53 EDT
Tried multiple times, got this error every time.  Sometimes it allowed the selection of a /boot partition, sometimes selecting /boot generated the error.  The good news is it reached the custom partition screen every time and there were no more BZ 1000889 errors.
Comment 19 Kamil Páral 2013-09-09 13:13:04 EDT
This seems to be violating https://fedoraproject.org/wiki/Fedora_20_Beta_Release_Criteria#Custom_partitioning . Proposing as a Beta blocker.
Comment 20 Flóki Pálsson 2013-09-09 19:25:50 EDT
Trying to create new partition

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang is_IS.utf8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-20-Al rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
other involved packages: python-blivet-0.20-1.fc20.noarch
package:        anaconda-20.10-2.fc20.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'id'
release:        Fedora release 20 (Null)
version:        20
Comment 21 David Lehman 2013-09-10 16:07:33 EDT

*** This bug has been marked as a duplicate of bug 1004572 ***

Note You need to log in before you can comment on or make changes to this bug.