Bug 1001239 - userspace-rcu : duplicate documentation files / potentially conflicting
Summary: userspace-rcu : duplicate documentation files / potentially conflicting
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: userspace-rcu
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Yannick Brosseau
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1308213 1320750 (view as bug list)
Depends On:
Blocks: epel7aarch64 F24FTBFS
TreeView+ depends on / blocked
 
Reported: 2013-08-26 19:54 UTC by Michael Schwendt
Modified: 2016-05-15 19:33 UTC (History)
5 users (show)

Fixed In Version: userspace-rcu-0.8.6-4.fc25
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-15 19:33:54 UTC
Type: ---


Attachments (Terms of Use)

Description Michael Schwendt 2013-08-26 19:54:20 UTC
Duplicate documentation files have been detected in the package
builds for Rawhide and Fedora 20. The likely cause is the unversioned
docdirs change in Fedora 20.

If your package %installs documentation files into %{_docdir}/%{name}/ to
store them in a subpackage, this now conflicts with using the %doc
macro in the base package. Since Fedora 20, the %doc macro installs into
the unversioned %{_docdir}/%{name}/ and includes everything in that
directory. One obvious fix is to decide between either using %doc or
installing into %{_docdir}/%{name}/ manually as explained in the
Packaging tricks Wiki section (for past dist releases and the versioned
docdir).

General discussion of this problem:
https://fedorahosted.org/fpc/ticket/338

Further information:
http://fedoraproject.org/wiki/Changes/UnversionedDocdirs
https://fedoraproject.org/wiki/Packaging_tricks#Installing_documentation:_2_paths

[semi-automated bug report]

[...]

=> userspace-rcu-0.7.7-2.fc20.src.rpm
=> userspace-rcu-devel-0.7.7-2.fc20.i686 in fedora-development-i386
  File conflict with: userspace-rcu-0.7.7-2.fc20.i686
     /usr/share/doc/userspace-rcu/README
     /usr/share/doc/userspace-rcu/cds-api.txt
     /usr/share/doc/userspace-rcu/gpl-2.0.txt
     /usr/share/doc/userspace-rcu/lgpl-2.1.txt
     /usr/share/doc/userspace-rcu/lgpl-relicensing.txt
     /usr/share/doc/userspace-rcu/rcu-api.txt
     /usr/share/doc/userspace-rcu/uatomic-api.txt

=> userspace-rcu-0.7.7-2.fc20.src.rpm
=> userspace-rcu-0.7.7-2.fc20.i686 in fedora-development-i386
  File conflict with: userspace-rcu-devel-0.7.7-2.fc20.i686
     /usr/share/doc/userspace-rcu/README
     /usr/share/doc/userspace-rcu/cds-api.txt
     /usr/share/doc/userspace-rcu/gpl-2.0.txt
     /usr/share/doc/userspace-rcu/lgpl-2.1.txt
     /usr/share/doc/userspace-rcu/lgpl-relicensing.txt
     /usr/share/doc/userspace-rcu/rcu-api.txt
     /usr/share/doc/userspace-rcu/uatomic-api.txt

Comment 1 Michael Schwendt 2013-12-18 00:29:46 UTC
Minor only. Easy to fix. Removing from tracker ticket, since the current docdir is non-versioned at least, despite the duplicated files.

Comment 2 Jaroslav Reznik 2015-03-03 15:00:36 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 3 Yaakov Selkowitz 2016-05-15 18:55:07 UTC
*** Bug 1308213 has been marked as a duplicate of this bug. ***

Comment 4 Yaakov Selkowitz 2016-05-15 18:58:46 UTC
*** Bug 1320750 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.