Bug 1320750 - userspace-rcu 0.8.x FTBFS for epel7
Summary: userspace-rcu 0.8.x FTBFS for epel7
Keywords:
Status: CLOSED DUPLICATE of bug 1001239
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: userspace-rcu
Version: epel7
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Yannick Brosseau
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: epel7aarch64
TreeView+ depends on / blocked
 
Reported: 2016-03-23 22:52 UTC by D. Marlin
Modified: 2016-05-15 18:58 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-15 18:58:46 UTC
Type: Bug


Attachments (Terms of Use)
userspace-rcu-0.8.5-1 mock EPEL7 build log (174.18 KB, text/plain)
2016-03-23 22:55 UTC, D. Marlin
no flags Details

Description D. Marlin 2016-03-23 22:52:49 UTC
Description of problem:

userspace-rcu 0.8.x fails to build from source for Fedora EPEL7.


Version-Release number of selected component (if applicable):

tested:
  userspace-rcu-0.8.1-2
  userspace-rcu-0.8.5-1


How reproducible:

  consistently


Steps to Reproduce:
1.  On a RHEL host:
    mock -r epel-7-x86_64 userspace-rcu-0.8.5-1.fc22.src.rpm
2.
3.

Actual results:

Fails to build with the following error:

        :
Processing files: userspace-rcu-debuginfo-0.8.5-1.el7.centos.x86_64
Provides: userspace-rcu-debuginfo = 0.8.5-1.el7.centos userspace-rcu-debuginfo(x86-64) = 0.8.5-1.el7.centos
Requires(rpmlib): rpmlib(FileDigests) <= 4.6.0-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1 rpmlib(CompressedFileNames) <= 3.0.4-1
Checking for unpackaged file(s): /usr/lib/rpm/check-files /builddir/build/BUILDROOT/userspace-rcu-0.8.5-1.el7.centos.x86_64


RPM build errors:
error: Installed (but unpackaged) file(s) found:
   /usr/share/doc/userspace-rcu/examples/Makefile
   /usr/share/doc/userspace-rcu/examples/Makefile.examples.template
   /usr/share/doc/userspace-rcu/examples/hlist/Makefile
   /usr/share/doc/userspace-rcu/examples/hlist/Makefile.cds_hlist_add_head_rcu
   /usr/share/doc/userspace-rcu/examples/hlist/Makefile.cds_hlist_del_rcu
   /usr/share/doc/userspace-rcu/examples/hlist/Makefile.cds_hlist_for_each_entry_rcu
   /usr/share/doc/userspace-rcu/examples/hlist/Makefile.cds_hlist_for_each_rcu
        :


Expected results:

builds without errors.


Additional info:

The same SRPM builds successfully for Fedora-22.

The error appears to be the same as described in:

  https://bugzilla.redhat.com/show_bug.cgi?id=1308213
    attachment 1126707 [details]

Comment 1 D. Marlin 2016-03-23 22:55:28 UTC
Created attachment 1139775 [details]
userspace-rcu-0.8.5-1 mock EPEL7 build log

Comment 2 Yaakov Selkowitz 2016-05-15 18:58:46 UTC

*** This bug has been marked as a duplicate of bug 1001239 ***


Note You need to log in before you can comment on or make changes to this bug.