Bug 1002436 - gnome-intial-setup offers “anthy” after an installation performed in Japanese, not kkc
gnome-intial-setup offers “anthy” after an installation performed in Japanese...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-initial-setup (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jasper St. Pierre
Fedora Extras Quality Assurance
AcceptedFreezeException
:
Depends On:
Blocks: F20AlphaFreezeException
  Show dependency treegraph
 
Reported: 2013-08-29 04:09 EDT by Mike FABIAN
Modified: 2013-09-13 23:09 EDT (History)
6 users (show)

See Also:
Fixed In Version: gnome-desktop3-3.9.91-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-13 23:09:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anthy-offered-by-default-by-gnome-initial-setup.png (1012.69 KB, image/png)
2013-08-29 04:09 EDT, Mike FABIAN
no flags Details

  None (edit)
Description Mike FABIAN 2013-08-29 04:09:54 EDT
Created attachment 791640 [details]
anthy-offered-by-default-by-gnome-initial-setup.png

Network Installation of Fedora 20 TC2 in Japanese in qemu, using:

ionice -c 3 qemu-kvm -enable-kvm -m 2048M -smp 4 -drive file=./Fedora-20-Alpha-TC2-x86_64-netinst.iso.qcow2,index=0,media=disk,cache=unsafe -localtime -serial file:/tmp/qemu-Fedora-20-Alpha-TC2-x86_64-netinst.iso.qcow2-output.log -name Fedora-20-Alpha-TC2-x86_64-netinst.iso.qcow2 -cdrom /local/mfabian/iso/Fedora-20-Alpha-TC2/Fedora-20-Alpha-TC2-x86_64-netinst.iso -boot c -spice port=6000,disable-ticketing -vga cirrus -display vnc=:4 -net nic -net user,hostname=Fedora-20-Alpha-TC2-x86_64-netinst.iso.qcow2,hostfwd=tcp::5556-:22 -monitor stdio -usb

When first logging into Gnome, gnome-initial-setup offers
“anthy” as the default Japanese input method and not “kkc”.

Although “anthy” is not even installed but “kkc” is installed.

See attached screenshot.
Comment 1 Mike FABIAN 2013-08-29 04:13:44 EDT
For Fedora 19, I reported bug#961270 (Anthy is shown in gnome-initial-setup after a Japanese install of Fedora 19 Beta TC3 although it is not even installed)
which has been closed as a duplicate of bug#948117 (gnome-settings-daemon should default to ibus-kkc [ja] and ibus-libpinyin [zh_CN]) which has been 
close as fixed.

But the problem seems to be back in Fedora 20.

Not sure whether the reason is the same.
Comment 2 Mike FABIAN 2013-09-06 07:54:35 EDT
The problem still exists in Fedora-20-Alpha-TC4-x86_64-DVD.iso.
Comment 3 Mike FABIAN 2013-09-09 03:53:36 EDT
The problem still exists in Fedora-20-Alpha-TC5-x86_64-netinst.iso.
Comment 4 Fedora Update System 2013-09-09 11:51:09 EDT
gnome-desktop3-3.9.91-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/gnome-desktop3-3.9.91-2.fc20
Comment 5 Fedora Update System 2013-09-10 12:24:22 EDT
Package gnome-desktop3-3.9.91-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-desktop3-3.9.91-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16294/gnome-desktop3-3.9.91-2.fc20
then log in and leave karma (feedback).
Comment 6 Kamil Páral 2013-09-12 04:53:15 EDT
Discussed at 2013-09-11 blocker review meeting [1]. This is more of a polish issue for japanese language installs but it can't be fixed with an update and a tested fix would be considered past freeze.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-09-11/
Comment 7 Mike FABIAN 2013-09-12 09:27:02 EDT
It seems fixed in Fedora-20-Alpha-RC1-x86_64-netinst.iso.

After a default installation in Japanese, I see

    日本語 (Kana Kanji)

by default in gnome-initial-setup now instead of anthy.
Comment 8 Fedora Update System 2013-09-13 23:09:40 EDT
gnome-desktop3-3.9.91-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.