Bug 948117 - gnome-settings-daemon should default to ibus-kkc [ja] and ibus-libpinyin [zh_CN]
Summary: gnome-settings-daemon should default to ibus-kkc [ja] and ibus-libpinyin [zh_CN]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
: 961270 (view as bug list)
Depends On:
Blocks: F19Beta-accepted, F19BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2013-04-04 05:32 UTC by Jens Petersen
Modified: 2013-05-16 04:33 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-05-14 04:29:24 UTC


Attachments (Terms of Use)
gnome-settings-daemon-3.8.0-anthy-kkc.patch (600 bytes, patch)
2013-04-04 05:32 UTC, Jens Petersen
no flags Details | Diff
gnome-settings-daemon-3.8.0-kkc-libpinyin.patch (947 bytes, patch)
2013-04-04 06:21 UTC, Jens Petersen
no flags Details | Diff

Description Jens Petersen 2013-04-04 05:32:14 UTC
Created attachment 731457 [details]
gnome-settings-daemon-3.8.0-anthy-kkc.patch

Description of problem:
GSD 3.8.0 still assumes ibus-anthy is the default IME for Japanese
but in F19 we are changing the default to ibus-kkc.
The attached patch should fix that, can you please apply it to F19 (and F20)?

I guess it may be too early to apply it upstream since
ibus-kkc is still pretty new but I hope it will happen
later when more distros move to ibus-kkc hopefully.

Version-Release number of selected component (if applicable):
gnome-settings-daemon-3.8.0

Steps to Reproduce:
1. start gnome 3.8.0 session in F19 in Japanese
2. open control-center for Input Sources
  
Actual results:
2. default input source is "anthy"

Expected results:
2. default input source should be "kkc"

Additional info:
gnome-settings-daemon should not really set an input-source
to a non-installed IME by default but that is probably harder
to fix and needs a separate upstream bug.

Comment 1 Jens Petersen 2013-04-04 06:21:00 UTC
Created attachment 731462 [details]
gnome-settings-daemon-3.8.0-kkc-libpinyin.patch

Same story for Simplified Chinese (since Fedora 18 default it libpinyin not pinyin).

Comment 2 Jens Petersen 2013-05-02 06:24:35 UTC
Ping

I would like to add this patch to Fedora for F19 Beta.

Comment 3 Adam Williamson 2013-05-08 17:30:47 UTC
Discussed at 2013-05-08 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-08/f19beta-blocker-review-4.2013-05-08-16.00.log.txt . Accepted as a freeze exception, as it's a clearly desirable change that can't be done with an update, and low impact.

Comment 4 Jens Petersen 2013-05-09 07:13:57 UTC
Okay I went ahead and fixed this for Fedora.

Comment 5 Fedora Update System 2013-05-09 07:46:36 UTC
gnome-settings-daemon-3.8.1-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gnome-settings-daemon-3.8.1-2.fc19

Comment 6 Fedora Update System 2013-05-09 17:57:08 UTC
Package gnome-settings-daemon-3.8.1-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-settings-daemon-3.8.1-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-7777/gnome-settings-daemon-3.8.1-2.fc19
then log in and leave karma (feedback).

Comment 7 Adam Williamson 2013-05-13 17:26:39 UTC
Well, the update is stable now. Not sure if we should close this, though. I did test doing a Japanese install of TC4 and I still don't get an IME by default, but I'm not sure if that's this bug or something else. Jens?

Comment 8 Jens Petersen 2013-05-14 03:49:54 UTC
(In reply to comment #7)
> Well, the update is stable now. Not sure if we should close this, though.

The original bug here was that g-s-d was setting up the old IMEs
for Japanese and Chinese instead of the new ones.  Now that g-i-s
is setting up an Input Source by default g-s-d probably don't do
any fallback setup of Input Source (maybe unless one doesn't
set any Input Source in g-i-s if that is even possible).

> I did test doing a Japanese install of TC4 and I still don't get an IME by
> default, but I'm not sure if that's this bug or something else. Jens?

That is bug 928645.

So I think it is okay to close this now (not sure why Bodhi didn't).

Comment 9 Adam Williamson 2013-05-14 04:29:24 UTC
Bodhi's buggy ATM. Closing.

Comment 10 Mike FABIAN 2013-05-14 05:14:55 UTC
(In reply to comment #7)
> Well, the update is stable now. Not sure if we should close this, though. I
> did test doing a Japanese install of TC4 and I still don't get an IME by
> default, but I'm not sure if that's this bug or something else. Jens?

I did get the Japanese input method "Kana Kanji" (ibus-kkc) automatically
after a netinstall  of Fedora-19-Beta-TC4-x86_64-netinst.iso.

gnome-initial-setup-0.9-2.fc19.x86_64

Comment 11 Jens Petersen 2013-05-16 04:33:08 UTC
*** Bug 961270 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.