Bug 1002542 - RuntimeError: cannot join thread before it is started
RuntimeError: cannot join thread before it is started
Status: CLOSED DUPLICATE of bug 970858
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:e6c446f37890a346f63229a342f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-29 08:21 EDT by Petr Schindler
Modified: 2013-11-15 10:02 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-15 10:02:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (312.03 KB, text/plain)
2013-08-29 08:21 EDT, Petr Schindler
no flags Details
File: anaconda.log (7.29 KB, text/plain)
2013-08-29 08:22 EDT, Petr Schindler
no flags Details
File: environ (441 bytes, text/plain)
2013-08-29 08:22 EDT, Petr Schindler
no flags Details
File: lsblk_output (1.37 KB, text/plain)
2013-08-29 08:22 EDT, Petr Schindler
no flags Details
File: nmcli_dev_list (480 bytes, text/plain)
2013-08-29 08:22 EDT, Petr Schindler
no flags Details
File: os_info (281 bytes, text/plain)
2013-08-29 08:22 EDT, Petr Schindler
no flags Details
File: program.log (22.69 KB, text/plain)
2013-08-29 08:22 EDT, Petr Schindler
no flags Details
File: storage.log (65.98 KB, text/plain)
2013-08-29 08:22 EDT, Petr Schindler
no flags Details
File: syslog (64.74 KB, text/plain)
2013-08-29 08:22 EDT, Petr Schindler
no flags Details
File: ifcfg.log (567 bytes, text/plain)
2013-08-29 08:22 EDT, Petr Schindler
no flags Details
File: packaging.log (436.54 KB, text/plain)
2013-08-29 08:22 EDT, Petr Schindler
no flags Details

  None (edit)
Description Petr Schindler 2013-08-29 08:21:48 EDT
Description of problem:
This bug appeared right after I confirmed language sellection and confirmed that it could ruin my data. Main hub was shown and after a short moment (or so) bug appeared.

Fedora20-Alpha-x86_64-TC2-DVD.iso
anaconda 20.9-1

Version-Release number of selected component:
anaconda-20.9-1

The following was filed automatically by anaconda:
anaconda 20.9-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/threading.py", line 939, in join
    raise RuntimeError("cannot join thread before it is started")
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 85, in wait
    self.get(name).join()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 675, in _initialize
    threadMgr.wait(constants.THREAD_CUSTOM_STORAGE_INIT)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
RuntimeError: cannot join thread before it is started

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha-TC2\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.0-0.rc7.git0.1.fc20.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20-Alpha-TC2

Potential duplicate: bug 980978
Comment 1 Petr Schindler 2013-08-29 08:21:58 EDT
Created attachment 791745 [details]
File: anaconda-tb
Comment 2 Petr Schindler 2013-08-29 08:22:02 EDT
Created attachment 791747 [details]
File: anaconda.log
Comment 3 Petr Schindler 2013-08-29 08:22:07 EDT
Created attachment 791748 [details]
File: environ
Comment 4 Petr Schindler 2013-08-29 08:22:12 EDT
Created attachment 791749 [details]
File: lsblk_output
Comment 5 Petr Schindler 2013-08-29 08:22:15 EDT
Created attachment 791750 [details]
File: nmcli_dev_list
Comment 6 Petr Schindler 2013-08-29 08:22:19 EDT
Created attachment 791751 [details]
File: os_info
Comment 7 Petr Schindler 2013-08-29 08:22:24 EDT
Created attachment 791752 [details]
File: program.log
Comment 8 Petr Schindler 2013-08-29 08:22:29 EDT
Created attachment 791753 [details]
File: storage.log
Comment 9 Petr Schindler 2013-08-29 08:22:34 EDT
Created attachment 791755 [details]
File: syslog
Comment 10 Petr Schindler 2013-08-29 08:22:39 EDT
Created attachment 791756 [details]
File: ifcfg.log
Comment 11 Petr Schindler 2013-08-29 08:22:54 EDT
Created attachment 791757 [details]
File: packaging.log
Comment 12 David Shea 2013-10-01 15:06:40 EDT
Fedora-20-Alpha-x86_64-DVD.iso

Crash occurred upon entering summary hub. Only action taken after boot was to hit continue at the Welcome screen.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.x86_64
package:        anaconda-20.18-1
product:        Fedora
reason:         RuntimeError: cannot join thread before it is started
release:        Cannot get release name.
version:        20-Alpha
Comment 13 Chris Lumens 2013-11-15 10:02:07 EST

*** This bug has been marked as a duplicate of bug 970858 ***

Note You need to log in before you can comment on or make changes to this bug.