Bug 100422 - Severe kernel latency issues
Severe kernel latency issues
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel (Show other bugs)
beta1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ingo Molnar
Brian Brock
:
: 100440 (view as bug list)
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-07-22 05:32 EDT by Bruce A. Locke
Modified: 2007-04-18 12:55 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-28 21:42:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruce A. Locke 2003-07-22 05:32:40 EDT
Description of problem:

This kernel fails the XMMS test miserably.

Time sensitive processes such as XMMS and mplayer "skip" very frequently when
doing various actions requiring either disk i/o or cpu time.


Version-Release number of selected component (if applicable):

2.4.21-20.1.2024.2.1.nptl (athlon)


How reproducible:

I am able to reliably reproduce this several times a minute during normal
desktop usage.


Steps to Reproduce:

Start XMMS and play an OGG file (with 'built-in' decorder) or an MP3 file (with
a third-party decoder).  While XMMS playing do one or all of the following:

1. find /
2. use the scroll wheel in mozilla or load a new page with lots of images
3. ls -lR /usr/lib (over and over again)
4. find /proc (over and over again)
Comment 1 Rik van Riel 2003-07-22 09:49:08 EDT
I suspect this is a CPU scheduler issue, the O(1) scheduler unfortunately has a
few known issues that aren't solved yet in any kernel version.  During heavy IO
my 500 MHz Celeron with 512MB of RAM is still snappy, but heavy CPU consumption
does indeed make the desktop less responsive...
Comment 2 Bill Nottingham 2003-07-28 15:33:32 EDT
*** Bug 100440 has been marked as a duplicate of this bug. ***
Comment 3 Brent Fox 2003-07-31 16:14:26 EDT
I am seeing this behavior as well.  The RHL 8 kernel didn't have this problem. 
The RHL 9 kernel was when I first started noticing interactivity slowdowns. 
However, the Severn kernel is much, much worse.  Resizing a window will bring
XMMS to a complete halt until the resizing is done.

After some investigation, it seems this issue only occurs on uniprocessor boxes.
 Once I added a second CPU to my workstation and installed the SMP Severn
kernel, things worked flawlessly.
Comment 4 Bruce A. Locke 2003-09-28 01:09:55 EDT
The kernel in Fedora Core Test 2 seems to fix this issue for me (as far as xmms
skipping goes).

I'm assuming Con's patches were backported from 2.6.0-test5-bk?

Comment 5 Dave Jones 2003-09-28 21:42:16 EDT
Glad to hear its working out. Yes, some of the scheduler improvements from
recent 2.6 are now in Fedora.
Comment 6 Yue Shi Lai 2003-11-07 12:51:15 EST
This problem seems also to be present in the up current Red Hat
Enterprise Linux kernel.
Comment 7 Dave Jones 2003-11-10 12:15:33 EST
Please open a new bug for RHEL reports. The scheduler there is quite
different to what we have in FC.

Note You need to log in before you can comment on or make changes to this bug.