Bug 100471 - redhat-config-network crashes when host entry is added
Summary: redhat-config-network crashes when host entry is added
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: redhat-config-network   
(Show other bugs)
Version: beta1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
: 100668 (view as bug list)
Depends On:
Blocks: CambridgeBlocker
TreeView+ depends on / blocked
 
Reported: 2003-07-22 19:20 UTC by Mike Basinger
Modified: 2007-04-18 16:55 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-05 08:04:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dump for 1.3.5 devices-edit (1.02 KB, text/plain)
2003-08-13 16:16 UTC, Joel
no flags Details

Description Mike Basinger 2003-07-22 19:20:06 UTC
Description of problem:
redhat-config-network crashes when trying to add enties to HOST table

Version-Release number of selected component (if applicable):


How reproducible:
every time

Steps to Reproduce:
1. Add an entry to host table
2.
3.
    
Actual results:
Errors
Component: redhat-config-network
Version: 1.3.1
Summary: TB maindialog.py:1065:on_hostsAddButton_clicked:NameError: global name
'Host' is not defined
Traceback (most recent call last):
  File
"/usr/src/build/273296-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 611, in on_addButton_clicked
  File
"/usr/src/build/273296-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 1065, in on_hostsAddButton_clicked
NameError: global name 'Host' is not defined

Local variables in innermost frame:
hostslist: HostsList.1.IP=127.0.0.1
HostsList.1.Hostname=localhost.localdomain
HostsList.1.AliasList.1=localhost

profilelist: ProfileList.default.HostsList.1.IP=127.0.0.1
ProfileList.default.HostsList.1.Hostname=localhost.localdomain
ProfileList.default.HostsList.1.AliasList.1=localhost
ProfileList.default.ActiveDevices.1=eth0
ProfileList.default.DNS.SecondaryDNS=155.97.12.176
ProfileList.default.DNS.SearchList.1=staff.library.utah.edu
ProfileList.default.DNS.Domainname=
ProfileList.default.DNS.PrimaryDNS=155.97.12.195
ProfileList.default.DNS.Hostname=portscan.staff.library.utah.edu
ProfileList.default.DNS.TertiaryDNS=155.97.12.175
ProfileList.default.Active=true
ProfileList.default.ProfileName=default

self: <netconfpkg.gui.maindialog.mainDialog instance at 0x9381fec>
args: (<gtk.Button object (GtkButton) at 0x940d074>,)
curr_prof: Profile.HostsList.1.IP=127.0.0.1
Profile.HostsList.1.Hostname=localhost.localdomain
Profile.HostsList.1.AliasList.1=localhost
Profile.ActiveDevices.1=eth0
Profile.DNS.SecondaryDNS=155.97.12.176
Profile.DNS.SearchList.1=staff.library.utah.edu
Profile.DNS.Domainname=
Profile.DNS.PrimaryDNS=155.97.12.195
Profile.DNS.Hostname=portscan.staff.library.utah.edu
Profile.DNS.TertiaryDNS=155.97.12.175
Profile.Active=true
Profile.ProfileName=default



Expected results:
entry is added to host table

Additional info:

Comment 1 Joel 2003-07-25 02:04:52 UTC
*** Bug 100668 has been marked as a duplicate of this bug. ***

Comment 2 Joel 2003-08-13 16:16:52 UTC
Created attachment 93615 [details]
dump for 1.3.5 devices-edit

Comment 3 Harald Hoyer 2003-08-14 09:47:05 UTC
fixed in 1.3.6


Note You need to log in before you can comment on or make changes to this bug.