Bug 1004744 - After doing fix-layout , gluster rebalance status message could be modified to mention that fix- layout is completed instead of just mentioning 'COMPLETED'
After doing fix-layout , gluster rebalance status message could be modified t...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ravishankar N
:
Depends On: 956693 1286073 1286076 1286077 1286079 1286081
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-05 07:53 EDT by Ravishankar N
Modified: 2015-11-27 05:39 EST (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.6.0beta1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 956693
Environment:
Last Closed: 2014-11-11 03:24:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-09-05 10:52:27 EDT
REVIEW: http://review.gluster.org/5826 (glusterd: improve rebalance fix-layout status reporting) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 2 Anand Avati 2013-09-10 03:08:28 EDT
REVIEW: http://review.gluster.org/5826 (glusterd: improve rebalance fix-layout status reporting) posted (#2) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 3 Anand Avati 2013-09-13 09:36:59 EDT
REVIEW: http://review.gluster.org/5826 (cli/glusterd: improve rebalance fix-layout status reporting) posted (#3) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 4 Anand Avati 2013-09-18 13:08:07 EDT
REVIEW: http://review.gluster.org/5826 (cli/glusterd: improve rebalance fix-layout status reporting) posted (#4) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 5 Anand Avati 2013-09-19 01:10:45 EDT
REVIEW: http://review.gluster.org/5826 (cli/glusterd: improve rebalance fix-layout status reporting) posted (#5) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 6 Anand Avati 2013-09-19 12:23:22 EDT
COMMIT: http://review.gluster.org/5826 committed in master by Anand Avati (avati@redhat.com) 
------
commit c550ae69526ad60b2f288ddc98a59141b9e64dcc
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Fri Sep 13 18:48:38 2013 +0530

    cli/glusterd: improve rebalance fix-layout status reporting
    
    Problem:
    Currenly the CLI rebalance status command output does not indicate the
    'type' of rebalance, i.e. whether a full rebalance or only a fix-layout
    was carried out.
    
    Fix: After the rebalance status of all peers is received by the
    originator glusterd, alter it to reflect the type of rebalance
    before passing it on to the CLI process.
    
    Change-Id: I1940ffda0d36e25e5b33c84a0ea210394cc9e1d3
    BUG: 1004744
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/5826
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 7 Anand Avati 2013-09-25 02:37:41 EDT
REVIEW: http://review.gluster.org/5999 (cli/glusterd: refactoring the merged patch) posted (#1) for review on master by susant palai (spalai@redhat.com)
Comment 8 Anand Avati 2013-09-25 03:43:23 EDT
REVIEW: http://review.gluster.org/5999 (cli/glusterd: refactoring the merged patch for Bug ID: 1004744) posted (#2) for review on master by susant palai (spalai@redhat.com)
Comment 9 Anand Avati 2013-09-25 05:20:25 EDT
REVIEW: http://review.gluster.org/5999 (cli/glusterd: refactoring the merged patch for Bug ID: 1004744) posted (#3) for review on master by susant palai (spalai@redhat.com)
Comment 10 Anand Avati 2014-01-29 08:41:27 EST
REVIEW: http://review.gluster.org/6855 (tests: Increase Expect Within time so that valid patches pass.) posted (#1) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 11 Anand Avati 2014-02-05 04:27:32 EST
REVIEW: http://review.gluster.org/6855 (tests: Increase Expect Within time so that valid patches pass) posted (#2) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 12 Anand Avati 2014-02-08 14:28:05 EST
COMMIT: http://review.gluster.org/6855 committed in master by Anand Avati (avati@redhat.com) 
------
commit 7e06ec5b1ed6ecab8853065c9ea0dd7c1c0c58f0
Author: Raghavendra Talur <rtalur@redhat.com>
Date:   Wed Jan 29 13:38:36 2014 +0000

    tests: Increase Expect Within time so that valid patches pass
    
    In some cases it is observed that fix-layout takes more
    than 20 seconds to complete, causing test to fail.
    Increasing it to a safe value of 30.
    
    Change-Id: I4ac8769e3a1594240ecda96700944ab3702daacc
    BUG: 1004744
    Signed-off-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-on: http://review.gluster.org/6855
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 13 Niels de Vos 2014-09-22 08:32:15 EDT
A beta release for GlusterFS 3.6.0 has been released. Please verify if the release solves this bug report for you. In case the glusterfs-3.6.0beta1 release does not have a resolution for this issue, leave a comment in this bug and move the status to ASSIGNED. If this release fixes the problem for you, leave a note and change the status to VERIFIED.

Packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update (possibly an "updates-testing" repository) infrastructure for your distribution.

[1] http://supercolony.gluster.org/pipermail/gluster-users/2014-September/018836.html
[2] http://supercolony.gluster.org/pipermail/gluster-users/
Comment 14 Niels de Vos 2014-11-11 03:24:07 EST
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.6.1, please reopen this bug report.

glusterfs-3.6.1 has been announced [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://supercolony.gluster.org/pipermail/gluster-users/2014-November/019410.html
[2] http://supercolony.gluster.org/mailman/listinfo/gluster-users

Note You need to log in before you can comment on or make changes to this bug.