Bug 100507 - cancelled LogOut hangs later LogOut
cancelled LogOut hangs later LogOut
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: gnome-session (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
: Triaged
: 100857 (view as bug list)
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-07-22 20:07 EDT by John Reiser
Modified: 2007-04-18 12:55 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-08 10:21:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2003-07-22 20:07:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
If you Cancel a LogOut request, then the next LogOut attemp will hang.

Version-Release number of selected component (if applicable):
gnome-session-2.2.2-2

How reproducible:
Always

Steps to Reproduce:
1.Graphical login to Gnome session.
2.RedHat > LogOut; Cancel
3.RedHat > LogOut
    

Actual Results:  Dialog box with options (LogOut, Reboot, ShutDown; Cancel OK)
is blank (no controls visible), and there is no response when clicking in the
known location of the Cancel or OK button.  Alternate text consoles are still
available, so you can log in there and kill the graphical session.

Expected Results:  Cancelling an earlier LogOut should have no effect on
subsequent attempts.

Additional info:
Comment 1 Bill Nottingham 2003-07-28 17:08:30 EDT
*** Bug 100857 has been marked as a duplicate of this bug. ***
Comment 2 Kyle R Maxwell 2003-08-01 18:05:20 EDT
Happens to me, too.
Comment 3 Alexander Larsson 2003-08-08 03:39:03 EDT
I'm pretty sure I saw another bug report about this too, but now i can't find it.
It said the problem was that gnome-session crashed, and bug-buddy was started,
but the server grab means the bug-buddy window doesn't show up.
 
Comment 4 Alexander Larsson 2003-08-08 08:35:55 EDT
This actually looks like a bluecurve gtk2 theme bug. Using another theme makes
this go away.
Comment 5 Alexander Larsson 2003-08-08 10:21:50 EDT
Fixed in redhat-artwork 0.78-1
Comment 6 Elton Woo 2003-08-08 11:12:20 EDT
I also experience this same behavoir *consistently*. My video card is a  
3D Force B-32 (nVidia). NOTE: nVidia drivers have _not been installed_ on 
this system (yet). 
Comment 7 Elton Woo 2003-08-09 16:41:48 EDT
Also, if one does a CTRL-ALT-BKSPC and logs out of the desktop in this manner,
the gdm menu is not visible.
Comment 8 Kyle R Maxwell 2003-08-09 23:21:56 EDT
I installed redhat-artwork.078-1 and now the "Log Out" selection on the main
GNOME menu has no effect, regardless of the theme I choose: previously I did not
see this behavior when using Mist, but now I see it with all of them.

Note You need to log in before you can comment on or make changes to this bug.