Bug 1005719 - network icon shows disconnected even when connected
network icon shows disconnected even when connected
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs
: 1006036 1006887 1008145 (view as bug list)
Depends On:
Blocks: F20BetaBlocker
  Show dependency treegraph
 
Reported: 2013-09-09 05:20 EDT by Ed Greshko
Modified: 2014-02-22 03:18 EST (History)
15 users (show)

See Also:
Fixed In Version: NetworkManager-0.9.9.0-11.git20130913.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-22 20:17:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot (83.45 KB, image/png)
2013-12-19 00:23 EST, Slava
no flags Details
Another example for mobile network, confusing and can be costly if you don't pay attention. (9.52 KB, image/png)
2014-02-22 03:18 EST, Joost Ringoot
no flags Details

  None (edit)
Description Ed Greshko 2013-09-09 05:20:48 EDT
Description of problem: Installed Gnome via the F20-TC5-DVD.  The network icon in the upper right corner has an "x" which seems to indicate no network connection even though there is a working connection.  This is a wired connection.


Version-Release number of selected component (if applicable): F20-TC5


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info: Running in a VBox VM
Comment 1 Florian Müllner 2013-09-12 16:37:26 EDT
*** Bug 1006887 has been marked as a duplicate of this bug. ***
Comment 2 Florian Müllner 2013-09-13 10:29:38 EDT
(In reply to Ed Greshko from comment #0)
> The network icon in the upper right corner has an "x" which seems to 
> indicate no network connection even though there is a working connection.

Yes, we need a newer NetworkManager snapshot.
Comment 3 Fedora Update System 2013-09-13 15:56:04 EDT
NetworkManager-0.9.9.0-11.git20130913.fc20,network-manager-applet-0.9.9.0-6.git20130913.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/NetworkManager-0.9.9.0-11.git20130913.fc20,network-manager-applet-0.9.9.0-6.git20130913.fc20
Comment 4 Fedora Update System 2013-09-14 13:44:51 EDT
Package NetworkManager-0.9.9.0-11.git20130913.fc20, network-manager-applet-0.9.9.0-6.git20130913.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-0.9.9.0-11.git20130913.fc20 network-manager-applet-0.9.9.0-6.git20130913.fc20'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16722/NetworkManager-0.9.9.0-11.git20130913.fc20,network-manager-applet-0.9.9.0-6.git20130913.fc20
then log in and leave karma (feedback).
Comment 5 Ed Greshko 2013-09-15 00:51:39 EDT
This proposed fix is "impossible" to test on the current RC2 release of F20 since I cannot get the network icon to appear.
Comment 6 Lukas Brabec 2013-09-16 04:39:43 EDT
I had wrong icon now I have no icon (after the update). F20 on 'production' machine installed from TC5.
Comment 7 Florian Müllner 2013-09-17 16:12:54 EDT
*** Bug 1008145 has been marked as a duplicate of this bug. ***
Comment 8 Florian Müllner 2013-09-17 16:18:32 EDT
(In reply to Ed Greshko from comment #5)
> I cannot get the network icon to appear.

Are you using a wired connection?
Comment 9 Robert Lightfoot 2013-09-17 18:19:35 EDT
Proposing as F20BetaBlocker based on "No part of any release-blocking desktop's panel (or equivalent) configuration may crash on startup or be entirely non-functional. "
Comment 10 Robert Lightfoot 2013-09-17 18:20:34 EDT
*** Bug 1006036 has been marked as a duplicate of this bug. ***
Comment 11 Ed Greshko 2013-09-17 18:54:43 EDT
(In reply to Florian Müllner from comment #8)
> (In reply to Ed Greshko from comment #5)
> > I cannot get the network icon to appear.
> 
> Are you using a wired connection?

Yes.  This is a bridged connection in a Vbox VM to a wired connection on the host.
Comment 12 Robert Lightfoot 2013-09-17 19:59:00 EDT
I've seen this on both a qemu/kvm guest system with bridged network and a win7 vbox system with non-bridged network.
Comment 13 Adam Williamson 2013-09-18 21:38:04 EDT
Maybe the icon not showing up is the 'fix'? The design document seems to imply it should be present, but that may be a misinterpretation.

In any case, I confirm the general experience here: in Alpha RC4 (which still has the 'old' NM) I see a 'disconnected' network icon when booted in a VM, on my desktop (which has updates-testing and hence the 'new' NM) I see no network status indicator at all unless I connect to my VPN. Haven't tested on a system with wireless yet. My desktop has two wired adapters but only one has a cable plugged into it.
Comment 14 Ed Greshko 2013-09-18 21:47:35 EDT
(In reply to Adam Williamson from comment #13)
> Maybe the icon not showing up is the 'fix'? The design document seems to
> imply it should be present, but that may be a misinterpretation.
> 
> In any case, I confirm the general experience here: in Alpha RC4 (which
> still has the 'old' NM) I see a 'disconnected' network icon when booted in a
> VM, on my desktop (which has updates-testing and hence the 'new' NM) I see
> no network status indicator at all unless I connect to my VPN. Haven't
> tested on a system with wireless yet. My desktop has two wired adapters but
> only one has a cable plugged into it.

One problem with that suggestion.  If it should show no icon when connected then one would expect/hope that a disconnected network would pop up a disconnected icon.  Well, when one un-checks the "cable connected" box in the Network Settings of the VM nothing happens.  There is no visual indication that you are no longer connected to the network.
Comment 15 Adam Williamson 2013-09-18 22:00:23 EDT
After talking to mclasen in #fedora-desktop, indeed, what I suspected is true: the design is not to have any kind of indicator for a wired network connection, on the basis that it's not really necessary. The assumption is that a wired network pretty much ought to work so long as it's plugged in; an indicator just doesn't provide much actual usefulness. The design might change if someone can point out a case where an indicator is actually useful, but for now this is the intended behaviour, per https://raw.github.com/gnome-design-team/gnome-mockups/master/shell/system-menu/combined-system-status-menu-v4-overview.png .

So this can indeed be CLOSED once the update is pushed stable.
Comment 16 Ed Greshko 2013-09-18 22:05:04 EDT
(In reply to Adam Williamson from comment #15)
> After talking to mclasen in #fedora-desktop, indeed, what I suspected is
> true: the design is not to have any kind of indicator for a wired network
> connection, on the basis that it's not really necessary. The assumption is
> that a wired network pretty much ought to work so long as it's plugged in;
> an indicator just doesn't provide much actual usefulness. The design might
> change if someone can point out a case where an indicator is actually
> useful, but for now this is the intended behaviour, per
> https://raw.github.com/gnome-design-team/gnome-mockups/master/shell/system-
> menu/combined-system-status-menu-v4-overview.png .
> 
> So this can indeed be CLOSED once the update is pushed stable.

I see....   FWIW, I would still rather see some sort of visual indication when a wired connection is lost.  Seems to be a bad idea not to inform a user of an abnormal condition.
Comment 17 Adam Williamson 2013-09-18 22:39:18 EDT
well, it's pretty obvious if your network isn't working, because...none of your network stuff works. I mean, it's not like you're not going to notice, or something.

If we had some neat code that could give you some kind of useful information on exactly where the problem is, maybe that'd be a useful thing to display. But AFAIK there isn't anything like this ATM. All Shell can tell you is 'it's up!' or 'it's down!', both of which are fairly bleeding obvious to you anyway.
Comment 18 Ed Greshko 2013-09-18 22:45:34 EDT
(In reply to Adam Williamson from comment #17)
> well, it's pretty obvious if your network isn't working, because...none of
> your network stuff works. I mean, it's not like you're not going to notice,
> or something.
> 
> If we had some neat code that could give you some kind of useful information
> on exactly where the problem is, maybe that'd be a useful thing to display.
> But AFAIK there isn't anything like this ATM. All Shell can tell you is
> 'it's up!' or 'it's down!', both of which are fairly bleeding obvious to you
> anyway.

While I basically agree with you I do so from a level of experience.  I know plenty of people who are not so experienced and having a red X appear over the network icon like it does in KDE would be "helpful".
Comment 19 Andre Robatino 2013-09-18 22:50:26 EDT
If you're using wireless and in motion, you may not be using the network continuously, but knowing where it tends to cut out could be useful. (Especially if one covers the same path regularly.)
Comment 20 Adam Williamson 2013-09-18 22:51:49 EDT
There is a wireless indicator.
Comment 21 Robert Lightfoot 2013-09-19 01:02:13 EDT
Can't speak for others, but I move from not only wireless network to wireless network, but also between several wired networks.  Having the network icon there has made it the first place I click when I want to change fixed IP or subnets os see what the cable threw me without opening a terminal window.  The network icon IMHO serves more uses than just a connected indicator.  I vote for thetraditional function if it can be provided without major upheaval.
Comment 22 Florian Müllner 2013-09-19 09:29:21 EDT
(In reply to Adam Williamson from comment #15)
> After talking to mclasen in #fedora-desktop, indeed, what I suspected is
> true: the design is not to have any kind of indicator for a wired network
> connection

Yeah, hence my question ...
Comment 23 Fedora Update System 2013-09-22 20:17:40 EDT
NetworkManager-0.9.9.0-11.git20130913.fc20, network-manager-applet-0.9.9.0-6.git20130913.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 24 Zbigniew Jędrzejewski-Szmek 2013-11-14 01:12:33 EST
C'mon, please add it back, at least as an option.
Comment 25 Adam Williamson 2013-11-14 01:52:39 EST
this bug isn't the place for such requests; there's an upstream bug referenced somewhere above.
Comment 26 Florian Müllner 2013-11-14 08:04:15 EST
The upstream bug in question is https://bugzilla.gnome.org/show_bug.cgi?id=708966.

Feel free to add your use case if it hasn't been mentioned before, but please refrain from "me too" comments, the bug report already has a rather low signal-to-noise ratio ...
Comment 27 Slava 2013-12-19 00:18:57 EST
I upgraded today to Fedora 20 x86_64 an NetworkManager shows wired connection icon disconnected, but connection up and running, 

[volga629@lap Pictures]$ rpm -qa | grep NetworkManager
NetworkManager-openvpn-0.9.8.2-3.fc20.x86_64
NetworkManager-pptp-0.9.8.2-3.fc20.x86_64
NetworkManager-vpnc-0.9.8.2-2.fc20.x86_64
NetworkManager-l2tp-0.9.8-4.fc20.x86_64
NetworkManager-pptp-gnome-0.9.8.2-3.fc20.x86_64
NetworkManager-glib-0.9.9.0-20.git20131003.fc20.x86_64
NetworkManager-0.9.9.0-20.git20131003.fc20.x86_64
NetworkManager-openconnect-0.9.8.0-2.fc20.x86_64

[volga629@lap Pictures]$ rpm -qa | grep network-manager-applet
network-manager-applet-0.9.9.0-7.git20131028.fc20.x86_64
Comment 28 Slava 2013-12-19 00:23:52 EST
Created attachment 838764 [details]
screen shot
Comment 29 Joost Ringoot 2014-02-22 03:18:10 EST
Created attachment 866358 [details]
Another example for mobile network, confusing and can be costly if you don't pay attention.

Note You need to log in before you can comment on or make changes to this bug.