Bug 1006254 - wrong path to lrelease
wrong path to lrelease
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qt5-qttools (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks: sigil-07
  Show dependency treegraph
 
Reported: 2013-09-10 06:23 EDT by Dan Horák
Modified: 2013-09-27 14:41 EDT (History)
7 users (show)

See Also:
Fixed In Version: qt5-qtwebkit-5.1.1-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-21 04:27:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Qt Bug Tracker QTBUG-32570 None None None Never

  None (edit)
Description Dan Horák 2013-09-10 06:23:08 EDT
copying from https://bugzilla.redhat.com/show_bug.cgi?id=915005#c38 as it is still present:

> there is probably a wrong path somewhere in the language tools setup, I get
> the following error when building sigil-0.7.1 
> 
> ...
> [ 11%] Generating sigil_ja.qm
> cd /home/dan/projects/fedora/sigil/sigil-0.7.1/build/src/Sigil &&
> /usr/lib64/cmake/Qt5LinguistTools/bin/lrelease
> /home/dan/projects/fedora/sigil/sigil-0.7.1/src/Sigil/Resource_Files/ts/
> sigil_ja.ts -qm
> /home/dan/projects/fedora/sigil/sigil-0.7.1/build/src/Sigil/sigil_ja.qm
> /bin/sh: /usr/lib64/cmake/Qt5LinguistTools/bin/lrelease: No such file or
> directory
> make[2]: *** [src/Sigil/sigil_ja.qm] Error 127

the path seems to be defined in ./src/linguist/Qt5LinguistToolsConfig.cmake.in


Version-Release number of selected component (if applicable):
qt5-qttools-5.1.1-1.fc18.x86_64
Comment 1 Rex Dieter 2013-09-11 14:14:08 EDT
Interesting, according to
https://bugreports.qt-project.org/browse/QTBUG-32570

this was supposed to be fixed in qttools-5.1.1, looking deeper
Comment 2 Fedora Update System 2013-09-11 18:08:03 EDT
qt5-qtwebkit-5.1.1-1.el6, qt5-qttools-5.1.1-3.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-11531/qt5-qtwebkit-5.1.1-1.el6,qt5-qttools-5.1.1-3.el6
Comment 3 Fedora Update System 2013-09-11 18:08:38 EDT
qt5-qttools-5.1.1-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/qt5-qttools-5.1.1-3.fc20
Comment 4 Fedora Update System 2013-09-11 18:09:44 EDT
qt5-qttools-5.1.1-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/qt5-qttools-5.1.1-3.fc19
Comment 5 Fedora Update System 2013-09-11 18:10:19 EDT
qt5-qttools-5.1.1-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/qt5-qttools-5.1.1-3.fc18
Comment 6 Rex Dieter 2013-09-11 18:10:51 EDT
qt5-qttools-5.1.1-3 builds include a hack to make things work for now, these are also tagged into koji buildroot overrides.
Comment 7 Fedora Update System 2013-09-12 12:29:25 EDT
Package qt5-qttools-5.1.1-3.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qt5-qttools-5.1.1-3.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16539/qt5-qttools-5.1.1-3.fc20
then log in and leave karma (feedback).
Comment 8 Rex Dieter 2013-09-19 09:45:19 EDT
*** Bug 1009893 has been marked as a duplicate of this bug. ***
Comment 9 tsteven4 2013-09-19 18:53:13 EDT
qt5-qttools-5.1.1-3.fc18 did not resolve the problem I reported in 1009893.
the symptom is unchanged.
Comment 10 tsteven4 2013-09-19 19:00:26 EDT
it looks like lupdate-qt5 is in qt5-qttools-devel-5.1.1-3.fc18 which I also had installed without changing the symptom.
Comment 11 Kevin Kofler 2013-09-19 20:39:20 EDT
Yeah, it's clearly not the same issue, I'm unduping the bug.
Comment 12 Fedora Update System 2013-09-21 04:27:33 EDT
qt5-qttools-5.1.1-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2013-09-21 04:33:56 EDT
qt5-qttools-5.1.1-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2013-09-22 20:38:36 EDT
qt5-qttools-5.1.1-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2013-09-27 14:41:05 EDT
qt5-qtwebkit-5.1.1-1.el6, qt5-qttools-5.1.1-3.el6 has been pushed to the Fedora EPEL 6 stable repository.

Note You need to log in before you can comment on or make changes to this bug.