Bug 1009893 - lupdate can't find qmake configuration file default
lupdate can't find qmake configuration file default
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qt5-qttools (Show other bugs)
18
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-19 08:48 EDT by tsteven4
Modified: 2013-10-08 13:43 EDT (History)
6 users (show)

See Also:
Fixed In Version: qt5-qttools-5.1.1-6.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-29 20:29:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
simple testcase (10.00 KB, application/octet-stream)
2013-09-20 20:36 EDT, tsteven4
no flags Details

  None (edit)
Description tsteven4 2013-09-19 08:48:04 EDT
Description of problem:
lupdate-qt5 cannot find qmake configuration file default.

Version-Release number of selected component (if applicable):
5.1.1-1.fc18

How reproducible:
100%

Steps to Reproduce:
1. svn co -r4619 http://gpsbabel.googlecode.com/svn/trunk/gpsbabel gpsbabel_wc
2. cd gpsbabel_wc
3. ./configure QMAKE=qmake-qt5 LUPDATE=lupdate-qt5 LRELEASE=lrelease-qt5
4. make EXTRA_CFLAGS='-fPIE' QT_LIBS='-L/usr/lib64 -l Qt5Core' linux-gui

Actual results:
the command 'cd gui; $(LUPDATE) app.pro' will fail with:
Could not find qmake configuration file default.
make: *** [gui] Error 1

Expected results:
make should succeed.  It has succeeded with Qt 5.1.1 that I compiled from source on this platform.

Additional info:
qmake-qt5, lupdate-qt5, lrelease-qt5 are found in /usr/bin by which.

qmake-qt5 -query results:
QT_SYSROOT:
QT_INSTALL_PREFIX:/usr/lib64/qt5
QT_INSTALL_ARCHDATA:/usr/lib64/qt5
QT_INSTALL_DATA:/usr/share/qt5
QT_INSTALL_DOCS:/usr/share/doc/qt5
QT_INSTALL_HEADERS:/usr/include/qt5
QT_INSTALL_LIBS:/usr/lib64
QT_INSTALL_LIBEXECS:/usr/lib64/qt5/libexec
QT_INSTALL_BINS:/usr/lib64/qt5/bin
QT_INSTALL_TESTS:/usr/lib64/qt5/tests
QT_INSTALL_PLUGINS:/usr/lib64/qt5/plugins
QT_INSTALL_IMPORTS:/usr/lib64/qt5/imports
QT_INSTALL_QML:/usr/lib64/qt5/qml
QT_INSTALL_TRANSLATIONS:/usr/share/qt5/translations
QT_INSTALL_CONFIGURATION:/etc/xdg
QT_INSTALL_EXAMPLES:/usr/lib64/qt5/examples
QT_INSTALL_DEMOS:/usr/lib64/qt5/examples
QT_HOST_PREFIX:/usr/lib64/qt5
QT_HOST_DATA:/usr/lib64/qt5
QT_HOST_BINS:/usr/lib64/qt5/bin
QT_HOST_LIBS:/usr/lib64
QMAKE_SPEC:linux-g++-64
QMAKE_XSPEC:linux-g++-64
QMAKE_VERSION:3.0
QT_VERSION:5.1.1
Comment 1 Rex Dieter 2013-09-19 09:45:19 EDT
See

https://admin.fedoraproject.org/updates/FEDORA-2013-16605/qt5-qttools-5.1.1-3.fc18

*** This bug has been marked as a duplicate of bug 1006254 ***
Comment 2 Rex Dieter 2013-09-19 09:47:32 EDT
Though, it may be preferable that instead trying:

 ./configure QMAKE=qmake-qt5 LUPDATE=lupdate-qt5 LRELEASE=lrelease-qt5

do this instead:

PATH=/usr/lib64/qt5/bin:$PATH ./configure

(but it may not help with this particular problem)
Comment 3 Kevin Kofler 2013-09-19 20:44:10 EDT
This is clearly not a duplicate of bug #1006254. Bug #1006254 is a CMake issue. Here, there is no CMake involved at all.

The problem here is that the lupdate-qt5 binary itself is not looking in the right place for the qmake configuration file default.

And by the way, I also think that
./configure QMAKE=qmake-qt5 LUPDATE=lupdate-qt5 LRELEASE=lrelease-qt5
is cleaner than messing with the PATH. Setting PATH shouldn't be necessary (if it'd help, it'd still be a bug in lupdate), and besides I don't expect it to help here (because lupdate probably isn't looking in PATH for data files, and it shouldn't, really).
Comment 4 tsteven4 2013-09-20 20:36:32 EDT
Created attachment 800804 [details]
simple testcase

untar the tar file in an empty directory.  run the script demo. my results are in demo.log

you can see my build of Qt 5.1.1 does something useful.  It creates test_de.qm (not included) and outputs
"Updating 'test_de.ts'...
    Found 0 source text(s) (0 new and 0 already existing)"

various ways of running the distributed Qt5 lupdate all return the message
"Could not find qmake configuration file default."

It doesn't matter if lupdate/lupdate-qt5 is in the path or not.

These test results are with 5.1.1-1.fc18, but I had similar output with 5.1.1-3.fc18.
Comment 5 tsteven4 2013-09-20 21:01:19 EDT
Part of my description was wrong, test_de.qm is produced by lrelease, not lupdate.

Please disregard the phrase "creates test_de.qm (not included)".
Comment 6 Rex Dieter 2013-09-21 02:00:45 EDT
Took awhile, but it looks like this is the Qt5 equivalent of bug #820767 , and a similar fix here does the trick.

To confirm,

QMAKE=/usr/lib64/qt5/bin/qmake lupdate-qt5 *.pro

this works.

Though... still not sure why manipulating $PATH doesn't help it to find qt5's qmake
Comment 7 Rex Dieter 2013-09-21 02:06:10 EDT
candidate f18 build:
https://koji.fedoraproject.org/koji/taskinfo?taskID=5963996
Comment 8 Fedora Update System 2013-09-21 09:56:07 EDT
qt5-qttools-5.1.1-5.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/qt5-qttools-5.1.1-5.fc20
Comment 9 tsteven4 2013-09-21 09:59:34 EDT
https://koji.fedoraproject.org/koji/buildinfo?buildID=466108 (qt5-qttools-5.1.1-5.fc18) did not resolve the issue for me.  the output of the simple test case is identical.

On the other hand, although it should not be required, setting QMAKE does work with 5.1.1-1.
Comment 10 Fedora Update System 2013-09-21 11:08:40 EDT
qt5-qttools-5.1.1-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/qt5-qttools-5.1.1-5.fc19
Comment 11 Fedora Update System 2013-09-21 11:09:58 EDT
qt5-qttools-5.1.1-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/qt5-qttools-5.1.1-5.fc18
Comment 12 Fedora Update System 2013-09-21 11:27:06 EDT
qt5-qttools-5.1.1-5.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/qt5-qttools-5.1.1-5.el6
Comment 13 Rex Dieter 2013-09-21 11:55:09 EDT
Heh, well, crap, that's what I get for not fully testing it first.  I think I'm on the right track though.

fix harder! :)
Comment 14 Fedora Update System 2013-09-21 15:08:02 EDT
qt5-qttools-5.1.1-6.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/qt5-qttools-5.1.1-6.fc20
Comment 15 Fedora Update System 2013-09-21 15:40:47 EDT
Package qt5-qttools-5.1.1-5.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qt5-qttools-5.1.1-5.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-17336/qt5-qttools-5.1.1-5.fc20
then log in and leave karma (feedback).
Comment 16 Fedora Update System 2013-09-29 20:29:54 EDT
qt5-qttools-5.1.1-6.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2013-09-29 20:31:53 EDT
qt5-qttools-5.1.1-6.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2013-09-29 20:33:05 EDT
qt5-qttools-5.1.1-6.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2013-10-08 13:43:11 EDT
qt5-qttools-5.1.1-6.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.