Bug 1006422 - packstack centos: install fails on centos due to pymongo
packstack centos: install fails on centos due to pymongo
Status: CLOSED DUPLICATE of bug 1006401
Product: RDO
Classification: Community
Component: openstack-ceilometer (Show other bugs)
unspecified
Unspecified Linux
unspecified Severity unspecified
: ---
: Havana
Assigned To: RHOS Maint
Ami Jeain
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-10 11:18 EDT by wes hayutin
Modified: 2013-09-10 12:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-10 12:14:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2013-09-10 11:18:31 EDT
Description of problem:

Centos needs to install python-pymongo like fedora does to successfully finish the packstack install


Applying 192.168.1.164_ceilometer.pp
192.168.1.164_osclient.pp :                 [ DONE ]
                        [ ERROR ]

ERROR : Error during puppet run : Error: Could not find package pymongo
Please check log file /var/tmp/packstack/20130910-103834-cj6lS5/openstack-setup.log for more information


Problem exists in the following file:
File: $parent/puppet/modules/ceilometer/manifests/params.pp

class ceilometer::params {

  $dbsync_command =
    'ceilometer-dbsync --config-file=/etc/ceilometer/ceilometer.conf'
  $log_dir        = '/var/log/ceilometer'

  case $::osfamily {
    'RedHat': {
      # package names
      $agent_central_package_name = 'openstack-ceilometer-central'
      $agent_compute_package_name = 'openstack-ceilometer-compute'
      $api_package_name           = 'openstack-ceilometer-api'
      $collector_package_name     = 'openstack-ceilometer-collector'
      $common_package_name        = 'openstack-ceilometer-common'
      $client_package_name        = 'python-ceilometerclient'
      # service names
      $agent_central_service_name = 'openstack-ceilometer-central'
      $agent_compute_service_name = 'openstack-ceilometer-compute'
      $api_service_name           = 'openstack-ceilometer-api'
      $collector_service_name     = 'openstack-ceilometer-collector'
      # db packages
      if $::operatingsystem == 'Fedora' and $::operatingsystemrelease >= 18 {
        # name change in f18 : https://bugzilla.redhat.com/show_bug.cgi?id=954155
        $pymongo_package_name     = 'python-pymongo'
        # fallback to stdlib version, not provided on fedora
        $sqlite_package_name      = undef
      } else {
        $pymongo_package_name     = 'pymongo'
        $sqlite_package_name      = 'python-sqlite2'
      }

    }
Comment 1 Pádraig Brady 2013-09-10 12:14:56 EDT

*** This bug has been marked as a duplicate of bug 1006401 ***

Note You need to log in before you can comment on or make changes to this bug.