Bug 1018843 - Update documentation for new BOMs in EAP 6.2
Update documentation for new BOMs in EAP 6.2
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity urgent
: ER7
: EAP 6.2.0
Assigned To: sgilda
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-14 09:56 EDT by Paul Gier
Modified: 2014-09-29 14:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:20:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Gier 2013-10-14 09:56:35 EDT
The customer BOMs have undergone changes in eap 6.2.  A new BOM is available that manages all supported EAP dependencies.  It's recomended that customers use this BOM in their Maven build if they need to manage transitive dependencies.

The GAV of the BOM is org.jboss.bom:eap6-supported-dependencies:<release ver>
Comment 1 Paul Gier 2013-10-14 09:58:33 EDT
Assigning to sgilda to work with me on doc updates.
Comment 2 Paul Gier 2013-10-15 16:17:49 EDT
Added the new documentation into docspace: https://docspace.corp.redhat.com/docs/DOC-156072
Comment 5 Paul Gier 2013-10-16 16:10:29 EDT
Marking as ON_QA because the updated docs are now on staging.
Comment 6 sgilda 2013-10-16 16:35:36 EDT
Paul, I don't see the fix staged here: 
http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/6.2/html-single/Development_Guide/index.html#Maven_BOM_Usage

I just talked to Russell and he said he ran out of time to build the books.

Moving back to modified.
Comment 7 sgilda 2013-10-16 21:51:53 EDT
It looks like it's now staged at the above link.
Comment 8 Nikoleta Ziakova 2013-10-21 11:04:48 EDT
The text is OK for Beta but for GA release the version of eap6-supported-artifacts BOM is updated to 6.2.0.GA so please update the documentation too:

    <dependency>
      <groupId>org.jboss.bom</groupId>
      <artifactId>eap6-supported-artifacts</artifactId>
      <version>6.2.0.GA</version>
    </dependency>
Comment 10 sgilda 2013-10-21 12:47:08 EDT
Changed both eap6-supported-artifacts and jboss-javaee-6.0-with-hibernate examples to 6.2.0.GA.
Comment 12 Nikoleta Ziakova 2013-10-24 09:32:16 EDT
Verified for EAP 6.2.0 ER6

Note You need to log in before you can comment on or make changes to this bug.