Bug 100655 - TB NCDevADSL.py:33:load:NameError: global name 'ConfDevice' is not defined
TB NCDevADSL.py:33:load:NameError: global name 'ConfDevice' is not defined
Status: CLOSED DUPLICATE of bug 98647
Product: Red Hat Linux Beta
Classification: Retired
Component: redhat-config-network (Show other bugs)
beta1
All Linux
high Severity high
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-07-23 21:13 EDT by Fulton Green
Modified: 2006-02-21 13:57 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:57:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fulton Green 2003-07-23 21:13:27 EDT
Description of problem:
The graphical version of the network configuration client errors out while
loading an ADSL configuration file.  The error appears to be related to a
missing Python variable called "ConfDevice".

Version-Release number of selected component (if applicable): 1.3.1-1

How reproducible:
I'm assuming the problem is easily reproducible on a machine upgraded from RH 9
(Shrike), which was my case.  The error occurred while loading in an ADSL "cfg"
file created in either Shrike or Severn.  I haven't determined yet if a clean
install can manifest the problem.

Steps to Reproduce:
1. Launch "Network" from the desktop bottom bar's "System Settings" menu.
2. Create (if necessary) the Ethernet entry that will be used by the ADSL entry
and save.  You may see a save error, but the information should still make it
out to disk.
3. Close the config app (if it didn't crash while saving) and restart.
    
Actual results:
An exception window pops up.

Expected results:
The app would appear with the previously saved configuration info.

Additional info:
I also noticed that bug #80343 dealt with the "ConfDevice" problem, but it also
looked as if it was going down a different path.

Traceback (most recent call last):
  File "/usr/sbin/redhat-config-network-gui", line 163, in main
    window = mainDialog()
  File
"/usr/src/build/273296-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 214, in __init__
  File
"/usr/src/build/273296-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 243, in load
  File
"/usr/src/build/273296-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 250, in loadDevices
  File
"/usr/src/build/273296-noarch/install/usr/share/redhat-config-network/netconfpkg/NCDeviceList.py",
line 312, in getDeviceList
  File
"/usr/src/build/273296-noarch/install/usr/share/redhat-config-network/netconfpkg/NCDeviceList.py",
line 135, in load
  File
"/usr/src/build/273296-noarch/install/usr/share/redhat-config-network/netconfpkg/plugins/NCDevADSL.py",
line 33, in load
NameError: global name 'ConfDevice' is not defined

Local variables in innermost frame:
self: Device.Type=xDSL

name: ppp0
Comment 1 Fulton Green 2003-07-26 12:44:05 EDT
I just tried a fresh install.  Same error.
Comment 2 Tadej Janež 2003-07-29 03:45:56 EDT
I can also confirm this bug on a fresh Severn install.

Additionaly, the same thing happens with redhat-config-network-gui and
redhat-config-network-tui.
Comment 3 Harald Hoyer 2003-07-30 07:47:38 EDT

*** This bug has been marked as a duplicate of 98647 ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:57:42 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.