Bug 1007205 - Guest can always get CAD combination key through RHEVM user portal
Guest can always get CAD combination key through RHEVM user portal
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.5
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
:
Depends On:
Blocks: 923072
  Show dependency treegraph
 
Reported: 2013-09-12 02:09 EDT by tingting zheng
Modified: 2013-12-10 19:16 EST (History)
11 users (show)

See Also:
Fixed In Version: virt-viewer-0.5.6-8.el6
Doc Type: Bug Fix
Doc Text:
no doc required (regression during rebase)
Story Points: ---
Clone Of: 923072
Environment:
Last Closed: 2013-11-21 03:11:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1578 normal SHIPPED_LIVE virt-viewer bug fix and enhancement update 2013-11-20 16:39:50 EST

  None (edit)
Comment 2 Christophe Fergeau 2013-09-12 07:44:56 EDT
Patch 0033-Propagate-SEND_CAD-from-controller-to-SpiceSession.patch from the rhel-6.4 build got lost during the 6.5 rebase.
Comment 3 David Blechter 2013-09-12 10:02:13 EDT
acking, need to be added asap.
Comment 4 Marc-Andre Lureau 2013-09-12 10:17:27 EDT
All of this CAD patches should either be upstream by now or discarded. There is no good reason to carry a some RH-only patches and stay in this undecided state forever.
Comment 5 Marc-Andre Lureau 2013-09-12 10:21:09 EDT
Tbh, I still don't understand from a user point of view the point of this feature, and I would like to know what's going to be the behaviour when speicifying a CAD hotkey. Should it be discarded too?
Comment 6 Christophe Fergeau 2013-09-12 10:29:39 EDT
(In reply to Marc-Andre Lureau from comment #4)
> All of this CAD patches should either be upstream by now or discarded. There
> is no good reason to carry a some RH-only patches and stay in this undecided
> state forever.

This is not in an undecided state, the CAD stuff is being removed from RHEV UI, see bug #996570 and bug #996564. In the mean time, we can keep these patches a bit longer.
Comment 7 Marc-Andre Lureau 2013-09-13 04:15:13 EDT
(In reply to Christophe Fergeau from comment #6)
> (In reply to Marc-Andre Lureau from comment #4)
> > All of this CAD patches should either be upstream by now or discarded. There
> > is no good reason to carry a some RH-only patches and stay in this undecided
> > state forever.
> 
> This is not in an undecided state, the CAD stuff is being removed from RHEV
> UI, see bug #996570 and bug #996564. In the mean time, we can keep these
> patches a bit longer.

So with newer version of RHEV UI you won't be able to use that switch?
Why should the new client still support a deprecated option for older RHEV?

If someone really relied on that, there will be a problem anyway later and we would have made a mistake to remove it from RHEV. It could be removed from the client too, without waiting.
Comment 8 Marc-Andre Lureau 2013-09-13 04:47:46 EDT
I opened bug 1007726 to remove that feature from vv
Comment 10 CongDong 2013-09-16 23:39:23 EDT
I can reproduce with :
virt-viewer-0.5.6-7.el6.x86_64

Steps:
Same as the description.

Result:
Guest could get the CAD keys.

Verify:
virt-viewer-0.5.6-8.el6.x86_64

Steps:
Same as the description.

Result:
Guest can't get the CAD keys.

If check the option, guest can get the CAD keys.


As the result, set VERIFIED.
Comment 11 errata-xmlrpc 2013-11-21 03:11:58 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1578.html

Note You need to log in before you can comment on or make changes to this bug.