Bug 1007726 - Remove RHEL-only support for RHEVM 'Pass Ctrl+Alt+Delete to virtual machine'
Remove RHEL-only support for RHEVM 'Pass Ctrl+Alt+Delete to virtual machine'
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Virt Viewer Maint
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-13 04:40 EDT by Marc-Andre Lureau
Modified: 2014-10-14 02:29 EDT (History)
10 users (show)

See Also:
Fixed In Version: virt-viewer-0.6.0-3.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 02:29:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc-Andre Lureau 2013-09-13 04:40:20 EDT
virt-viewer has RHEL-only support for RHEVM CAD option.

It has been agreed to remove that option from RHEVM. See bug 996564, Remove 'Pass Ctrl+Alt+Delete to virtual machine' from Console Options.

Similarly, virt-viewer should drop this custom feature.

Whether, and how long, to support older RHEVM CAD option or not remains to be decided by PM.
Comment 2 Christophe Fergeau 2013-09-13 05:37:21 EDT
Definitely not 6.5 material, the bug should probably be 6.5.0- 6.6.0?, but I prefer not to touch them as I'm not familiar enough with changing these flags ;)
Comment 3 Christophe Fergeau 2013-09-13 05:46:57 EDT
Most of this support is in spice-gtk, so this bug will need to be cloned to track the removal there as well.
Comment 4 Marc-Andre Lureau 2013-09-13 05:50:03 EDT
(In reply to Christophe Fergeau from comment #2)
> Definitely not 6.5 material, the bug should probably be 6.5.0- 6.6.0?, but I

Yes, it's late in schedule, but it's already there (by mistake). If PM is fine with droping support in 6.5, this is basically already verified by bug 1007205.
Comment 8 Marc-Andre Lureau 2014-03-12 16:54:03 EDT
devel ack, please pm ack (bug 996564 is pm_ack+ already)
Comment 10 tingting zheng 2014-06-10 06:57:24 EDT
Tested with:
virt-viewer-0.6.0-5.el6.x86_64
rhevm-3.4.0-0.21.el6ev.noarch

Steps:
1.Configure a spice guest on rhev.
2.Check VM Console options,it has option "Map control-alt-del shortcut to ctrl+alt+end".
3.Test the new option "Map control-alt-del shortcut to ctrl+alt+end".
3.1 Enabled "Map control-alt-del shortcut to ctrl+alt+end".
Checked in remote-viewer console,there is "ctrl+alt+end" listed in "Send key".
Press "ctrl+alt+end",it is passed to the guest (VM) as Ctrl+Alt+Del.
3.2 Disalbe "Map control-alt-del shortcut to ctrl+alt+end".
Checked in remote-viewer console,there is no "ctrl+alt+end" listed in "Send key".
Press "ctrl+alt+end",no keys are sent to guest.
4.If choose open console as "save file" as console.vv,in the console.vv,there is content as: 
"secure-attention=ctrl+alt+end".
And the shotcut keys work when I lanuch guest using remote-viewer console.vv.

Refer to the above comments,move the bug to VERIFIED.
Comment 11 errata-xmlrpc 2014-10-14 02:29:52 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1379.html

Note You need to log in before you can comment on or make changes to this bug.