Bug 1007408 - [redhat-support-plugin-rhev] "Would you like transactions from the Red Hat Access Plugin sent from the RHEV Manager to be brokered through a proxy server" is asked again during upgrade
[redhat-support-plugin-rhev] "Would you like transactions from the Red Hat Ac...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: redhat-support-plugin-rhev (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.3.0
Assigned To: Sandro Bonazzola
Jiri Belka
integration
:
Depends On: 1013790
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-12 08:34 EDT by Jiri Belka
Modified: 2015-09-22 09 EDT (History)
12 users (show)

See Also:
Fixed In Version: redhat-support-plugin-rhev-3.3.0-10.el6ev.noarch.rpm
Doc Type: Bug Fix
Doc Text:
A message "Would you like transactions from the Red Hat Access Plugin sent from the RHEV Manager to be brokered through a proxy server" was asked again during an upgrade even if the same question was answered during initial engine-setup. The old implementation always ran interactive proxy configuration. The new implementation tries to read the configuration file to check whether proxy was already defined.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:58:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Belka 2013-09-12 08:34:19 EDT
Description of problem:

"Would you like transactions from the Red Hat Access Plugin sent from the RHEV Manager to be brokered through a proxy server" is asked again during upgrade even the same question was answered during initial engine-setup. Initially from BZ1007242.

Version-Release number of selected component (if applicable):
is14

How reproducible:
100%

Steps to Reproduce:
1. clean rhevm install & engine-setup
2. upgrade
3. engine-setup

Actual results:
the question is asked again during upgrade

Expected results:
remember the answer

Additional info:
Comment 3 Shai Revivo 2013-10-05 09:12:13 EDT
not nice, worth verifying
Comment 4 Jiri Belka 2013-10-07 08:50:27 EDT
It asks me still for the answer. Procedure:

- rhevm build is16
- manual upgrade to redhat-support-plugin-rhev-3.3.0-8.el6ev.noarch (rpm --nodeps -Uhv ...)
- engine-setup
- change yum repo to rhevm is17
- yum update rhevm-setup
- engine-setup
Comment 5 Alex Lourie 2013-10-07 12:21:02 EDT
The current implementation handles upgrades from 3.3.

1. Can you please verify it works as expected in 3.3 -> further?
2. I will need to check what can we do for 3.2 -> 3.3 upgrade.
Comment 6 Jiri Belka 2013-10-07 12:23:56 EDT
Sorry but this is 3.3 (latest two 3.3 builds).
Comment 7 Alex Lourie 2013-10-09 10:30:59 EDT
@Jiri

To verify it works correctly in 3.3, you need to take *this* version, install it clean, and then run upgrade on it (or even run setup again on the same system).

The code that handles the problem is only introduced with this release and doesn't exist on previous 3.3 builds.

Please verify under these conditions.
Comment 12 Bill Sanford 2013-10-21 09:56:24 EDT
I have tested the *new* install of 3.3 (is19) and this has nothing to do with upgrading. The answer file does not contain the correct value to be passed to the plugin.

The bug I filed is: 
https://bugzilla.redhat.com/show_bug.cgi?id=1013790
Comment 13 Jiri Belka 2013-11-08 10:58:38 EST
ok, is22.
Comment 14 Charlie 2013-11-27 20:33:48 EST
This bug is currently attached to errata RHBA-2013:15513. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 18 errata-xmlrpc 2014-01-21 11:58:21 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0082.html

Note You need to log in before you can comment on or make changes to this bug.