Bug 1008471 - Project Explorer sometimes doesn't load fully
Project Explorer sometimes doesn't load fully
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity high
: ER5
: 6.0.0
Assigned To: Alexandre Porcelli
Zuzana Krejčová
:
: 1026958 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-16 08:43 EDT by Zuzana Krejčová
Modified: 2016-07-31 21:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:16:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (13.91 KB, image/png)
2013-09-16 08:43 EDT, Zuzana Krejčová
no flags Details
deployments (14.51 KB, image/png)
2013-09-16 08:47 EDT, Zuzana Krejčová
no flags Details

  None (edit)
Description Zuzana Krejčová 2013-09-16 08:43:02 EDT
Created attachment 798277 [details]
screenshot

Description of problem:
See screenshot - sometimes, the Project Explorer doesn't fully load. If this happens, you can fix it by going to Authoring -> Project Authoring again (sometimes multiple times) or switching perspectives. It happens to me in about 1/2 of the attempts.


Version-Release number of selected component (if applicable):
BPMS 6.0 ER3
Comment 1 Zuzana Krejčová 2013-09-16 08:47:45 EDT
Created attachment 798279 [details]
deployments

It seems like an Uberfire problem - the same happens for Deployments screen, as you can see from the screenshot. It's quite probable this will happen for other panels and perspectives as well.
Comment 2 manstis 2013-09-20 03:47:15 EDT
Looks like a resize problem when the panel first loads?
Comment 3 Zuzana Krejčová 2013-09-20 04:09:28 EDT
(In reply to manstis from comment #2)
> Looks like a resize problem when the panel first loads?

I'm not sure. But just to add more information - I got the same problem for a Test Scenario editor, when I tried to run the TS - which opens the Reporting panel - the TS editor got corrupted.

It also seems to me that this and the bug 1008422 happens more often when I only have one repository with almost no assets, but that might have been just a coincidence.
Comment 7 Alexandre Porcelli 2013-11-05 12:48:26 EST
This was a very hard to fix, as it was almost impossible to have a step-by-step to reproduce.. but seems that is fixes by the following commits:

https://github.com/droolsjbpm/uberfire/commit/4b426677a
https://github.com/droolsjbpm/uberfire/commit/b29694abb
Comment 8 Alexandre Porcelli 2013-11-05 12:53:11 EST
*** Bug 1026958 has been marked as a duplicate of this bug. ***
Comment 10 Zuzana Krejčová 2013-12-17 06:22:41 EST
This seems to be fixed in ER5.

Note You need to log in before you can comment on or make changes to this bug.