Bug 1008496 - New Virtual Machine Dialog - help (?) is missing.
New Virtual Machine Dialog - help (?) is missing.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhevm-doc (Show other bugs)
3.3.0
All All
unspecified Severity urgent
: ---
: 3.3.0
Assigned To: Kiril Nesenko
meital avital
ux
: Regression, Reopened
: 1008932 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-16 09:30 EDT by meital avital
Modified: 2014-07-10 20:09 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
New windows introduced for Red Hat Enterprise Virtualization 3.3 in the manager user interface did not have a context-sensitive help icon. This has now been fixed, and all windows now have a question mark icon which leads users to relevant instructions in product documentation.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 09:43:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
file: DocumentationPath.csv (17.06 KB, text/csv)
2013-11-02 19:56 EDT, Einav Cohen
no flags Details
file: UserPortalDocumentationPath.csv (2.63 KB, text/csv)
2013-11-02 19:57 EDT, Einav Cohen
no flags Details
explanations for the new dialogs in rhevm 3.3 (5.15 KB, text/plain)
2013-11-02 19:58 EDT, Einav Cohen
no flags Details
Admin Portal map (19.30 KB, text/csv)
2013-11-21 00:21 EST, Cheryn Tan
no flags Details
User Portal map (3.04 KB, text/csv)
2013-11-21 00:21 EST, Cheryn Tan
no flags Details

  None (edit)
Description meital avital 2013-09-16 09:30:01 EDT
Description of problem:
There is no help (?) in the New Virtual Machine tab.

Version-Release number of selected component (if applicable):
rhevm-3.3.0-0.19.master.el6ev.noarch


How reproducible:
Always


Steps to Reproduce:
1.Open the web admin
2.Click on the virtual tab
3.Click on the New Virtual Machine
4.Missing (?) help in the title of this page


Actual results:
There is no help in the title.


Expected results:
Should be (blue (?)) help in the title as usual.


Additional info:
Comment 1 meital avital 2013-09-16 09:32:59 EDT
Missing also in New Volumes tab.
Comment 2 Itamar Heim 2013-09-17 05:02:05 EDT
I think it means its missing in the docs csv.
Comment 3 Einav Cohen 2013-09-17 14:42:20 EDT
similarly to bug 1001091, closing until csv is updated (see https://bugzilla.redhat.com/show_bug.cgi?id=1001091#c4)
Comment 4 Einav Cohen 2013-09-19 10:12:31 EDT
*** Bug 1008932 has been marked as a duplicate of this bug. ***
Comment 5 Jiri Belka 2013-10-24 10:54:50 EDT
Still missing in is19. Hasn't been this forgotten?
Comment 6 Kiril Nesenko 2013-10-24 11:02:35 EDT
(In reply to Jiri Belka from comment #5)
> Still missing in is19. Hasn't been this forgotten?

We didn't updated docs csv files for a long time.

Hello Cheryn,

Can you send me updated csv files for 3.3 build ?

- Kiril
Comment 7 Jiri Belka 2013-10-25 03:22:48 EDT
I don't understand how could be this BZ closed if one is not sure it is 100% solved.
Comment 8 Jiri Belka 2013-10-25 03:23:55 EDT
Reopening. Please close only until you are sure it is solved. We need a BZ to track this issue.
Comment 9 Cheryn Tan 2013-10-27 20:12:15 EDT
Hi Kiril,

I think you'll need to generate a new CSV file containing the entries for any new dialogs, then I can update it with links to the documentation. The newest version I have is from 3.2, some of the dialogs have changed since then.

Please send me the updated copies for both the admin and user portals, or point me to where I can find them.

Thank you,
Cheryn
Comment 10 Kiril Nesenko 2013-10-28 04:23:14 EDT
(In reply to Cheryn Tan from comment #9)
> Hi Kiril,
> 
> I think you'll need to generate a new CSV file containing the entries for
> any new dialogs, then I can update it with links to the documentation. The
> newest version I have is from 3.2, some of the dialogs have changed since
> then.
> 
> Please send me the updated copies for both the admin and user portals, or
> point me to where I can find them.
> 
> Thank you,
> Cheryn

I have no idea how to generate these CSV files, never did it before. Maybe Einav/Steve can help ?

- Kiril
Comment 11 Stephen Gordon 2013-10-28 08:39:58 EDT
(In reply to Kiril Nesenko from comment #10)
> (In reply to Cheryn Tan from comment #9)
> > Hi Kiril,
> > 
> > I think you'll need to generate a new CSV file containing the entries for
> > any new dialogs, then I can update it with links to the documentation. The
> > newest version I have is from 3.2, some of the dialogs have changed since
> > then.
> > 
> > Please send me the updated copies for both the admin and user portals, or
> > point me to where I can find them.
> > 
> > Thank you,
> > Cheryn
> 
> I have no idea how to generate these CSV files, never did it before. Maybe
> Einav/Steve can help ?
> 
> - Kiril

Engineering provide the documentation team with an updated CSV file based on the list of GUI dialogs (existing rows which have already been mapped + new rows for new dialogs).

Documentation then fill in the new links, and update the existing ones, where required, they then hand it back to you and you ship it in the RPM.

I am assuming it is Einav who needs to provide the updates list of dialogs.
Comment 12 Einav Cohen 2013-11-02 19:56:26 EDT
Created attachment 818671 [details]
file: DocumentationPath.csv
Comment 13 Einav Cohen 2013-11-02 19:57:09 EDT
Created attachment 818673 [details]
file: UserPortalDocumentationPath.csv
Comment 14 Einav Cohen 2013-11-02 19:58:05 EDT
Created attachment 818674 [details]
explanations for the new dialogs in rhevm 3.3
Comment 15 Einav Cohen 2013-11-02 20:00:04 EDT
see attachment 818671 [details] and attachment 818673 [details] to be completed with the relevant documentation URLs (rows for newly-added dialogs are at the end of each file).

see attachment 818674 [details] for an explanation for each new dialog.

also sent a separate e-mails.
Comment 16 Cheryn Tan 2013-11-21 00:21:02 EST
Created attachment 827001 [details]
Admin Portal map
Comment 17 Cheryn Tan 2013-11-21 00:21:33 EST
Created attachment 827002 [details]
User Portal map
Comment 18 Cheryn Tan 2013-11-21 00:25:12 EST
Many thanks to Andrew Dahms for filling in the urls for the context-sensitive map, and even testing that all the older links work. 
"Admin Portal map" contains DocumentationPath.csv
"User Portal map" contains UserDocumentationPath.csv

Please let us know if you have any issues. When is the cutoff date for building the RC rhevm-doc package?
Comment 19 Kiril Nesenko 2013-12-02 10:29:12 EST
Meital, Arthur please ack the bz.

- Kiril
Comment 21 Kiril Nesenko 2013-12-16 03:37:19 EST
Meital,

Please ack the bug.

- Kiril
Comment 23 meital avital 2014-01-19 14:07:25 EST
Verified on IS32.2
rhevm-doc-3.3.0-3.el6eng.noarch
Comment 25 errata-xmlrpc 2014-01-21 09:43:41 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0062.html

Note You need to log in before you can comment on or make changes to this bug.