Bug 100874 - Mouse moves erratically only while firstboot is run
Mouse moves erratically only while firstboot is run
Product: Red Hat Linux Beta
Classification: Retired
Component: rhgb (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Mike McLean
: 105627 106497 (view as bug list)
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
Reported: 2003-07-26 08:47 EDT by Carl T. Miller
Modified: 2007-04-18 12:56 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-08-04 16:15:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Carl T. Miller 2003-07-26 08:47:53 EDT
Description of problem:
Mouse moves erratically while firstboot is run, although it works normally
during the graphical install and after firstboot is finished.

Version-Release number of selected component (if applicable):

How reproducible:
It happened both times I installed it.

Steps to Reproduce:
1. Install severn beta1
2. Reboot and log in
Actual results:
During configuration the mouse is erratic.  I had to use the keys to
navigate, since the pointer kept hopping to the bottom left corner
of the screen.

Expected results:
Pointer would move as the mouse is moved.

Additional info:
The mouse is /dev/psaux, and it works perfectly during the install and
after firstboot.  I'm installing this in a virtual machine using VMware,
and this shouldn't make any difference, since the mouse works perfectly
in my other virtual machines.  It only has a problem with firstboot.
Comment 1 Bob Cochran 2003-07-26 12:31:39 EDT
This issue happens to me also on a normal Workstation install of Severn on a
Dell XPS T550 system. The mouse is impossible to use during firstboot. 

Comment 2 Brent Fox 2003-07-28 12:04:49 EDT
jrb, I've started to see numerous reports of wonky mouse and keyboard behavior
in firstboot in the Severn beta that I have not seen in previous releases.  My
guess is that there is something strange with rhgb that is causing input devices
to misbehave.  I'm changing the component to rhgb although the problem may lie
with X itself.
Comment 3 Peter van Egdom 2003-08-01 13:54:30 EDT
I've also seen this happen (with a fresh install, no VMware) on a HP Vectra
VL400 DT.
Comment 4 Sander Steffann 2003-08-01 18:51:04 EDT
Same problem here using VMWare 4.01. The mouse jumps to the bottom left corner.
If I move the mouse up or to the right the cursor moves as expected, but if I 
move the mouse a little bit to the left or to the bottom it jumps to the bottom 
left corner of the screen immediately.
Comment 5 Warren Togami 2003-09-21 07:43:19 EDT
That particular erratic mouse behavior sounds suspiciously like how an IMPS/2
wheel-mouse behaves with 2-button PS/2 mouse protocol.  Check the current mouse
protocol when this behavior occurs.
Comment 6 Need Real Name 2003-09-28 16:09:00 EDT
This bug is with real hardware as well.(and I have check the mouse protocol)

HP Pavilion 533c
i845g motherboard
standard ps/2 mouse

the mouse stays almost stuck in the left-bottem corner of the screen. My guess
iss something with graphical boot+ X and firstboot
Comment 7 Need Real Name 2003-09-28 16:09:54 EDT
forogt to mention I'm using Fedora test2
Comment 8 Bill Nottingham 2003-09-29 00:01:00 EDT
*** Bug 105627 has been marked as a duplicate of this bug. ***
Comment 9 Joao Pinto 2003-09-29 16:35:05 EDT
I have experienced the same problem on the first boot run.
I have noticed this same "mouse jam" happens always during graphical boot
display if you try to move the mouse pointer.
Comment 10 Bill Nottingham 2003-10-02 00:52:13 EDT
Does it behave sanely if you disable kudzu (chckonfig --level 5 kudzu off)
Comment 11 Joao Pinto 2003-10-02 12:39:15 EDT
Disabling kudzu fixed the problem for me.
Comment 12 das_deniz 2003-10-06 10:36:38 EDT
i would add to this that after using the keyboard to alt-tab and 'ok' around -
the mouse started working (flakey) but i was unable to *INPUT TEXT* in dialogue
boxes about NIS settings or other information.
Comment 13 Bill Nottingham 2003-10-06 15:17:31 EDT
Assuming kudzu is reenabled, does kudzu-1.1.31-1 or later behave OK for you?
Comment 14 Gene Czarcinski 2003-10-06 15:40:53 EDT
How do you suggest we test this?

I have a severn test 2 system which has been updated to "current" as of 03 Oct
2003.  My "plan" is to edit /etc/sysconfig/firstboot and change it be

Will this test things?
Comment 15 Bill Nottingham 2003-10-06 16:31:44 EDT
rm -f /etc/sysconfig/firstboot
chkconfig --level 5 firstboot on
Comment 16 Gene Czarcinski 2003-10-06 16:40:56 EDT
OK, I see your update and will thry that.  I did do the following:

I tried changing /etc/sysconfig/firstboot as described above ... no firstboot

I looked at /etc/init.d/firstboot and saw that a "reconfig" boot parameter
should do it and that /etc/sysconfig/firstboot was not really referenced ...
still no firstboot

I then looked at /etc/init.d/firstboot and saw the file so I "touch
/etc/reconfigSys" ... still no firstboot.

Based on what you said, I assume that firstboot turns itself off once it runs.

What is the purpose of the reconfig and /etc/reconfigSys stuff?
Comment 17 Gene Czarcinski 2003-10-06 16:51:01 EDT
OK, sorry but it is still broken (and a real pain to get though firstboot since
if the mouse is not over the firstboot panel, I cannot even use tabbing to

BTW, I am not sure if this has anything to do with the problem ... I am booting
with the gui bootup.  During that bootup, moving the mouse is also a bit erratic.
Comment 18 Bill Nottingham 2003-10-07 18:57:30 EDT
*** Bug 106497 has been marked as a duplicate of this bug. ***
Comment 19 Johan Dahl 2003-10-08 17:57:05 EDT
Installed new rhgb-0.10.2-1.i386.rpm which makes the bootscreen look very nice
but now the mouse behaves like this (returning to lower-left corner) as long as
the bootscreen is showing. 
Comment 20 Bill Nottingham 2003-10-08 18:11:28 EDT
Fixed in kudzu-1.1.32-1.
Comment 21 Alexandre Oliva 2003-10-09 01:53:28 EDT
That fixed it for me, but I'll leave it up to the original reporter to actually
close it.
Comment 22 Gene Czarcinski 2003-10-09 11:46:54 EDT
OK, mostly fixed ...

I installed al of the updates as of morning of 9 Oct.  I then rebooted.  I
figured that the problem was mostly fixed when the cursor stayed after the
hardware probing.

I then removed /etc/sysconfig/firstboot and did:
chkconfig --level 5 firstboot on

I then rebooted.

Went throught the rhgb as before and then entered fistboot.  AT FIRST, the
cursor skipped around like it did before but after a couple of movements, it
settled down and I was able the the firstboot stuff.

I am going to try one more thing and move the cursor during the gui boot to see
if that makes a difference.
Comment 23 Gene Czarcinski 2003-10-09 11:56:38 EDT
OK, I played with the mouse (actually trackball) during the gui boot.  At first
it moved but then disappeared.  A bit later it reappeared as an hour-glass
around the middle of the screen.  When it got to firstboot, the cursor was no
apparent so I moved it and it appeared in the bottom left (no the corner).  This
time it stayed stable and I could get through firstboot OK.

While not perfect, the kudzu fix seems to fix most of the problem.  I am not
sure what is going on but it is likely some strange corner case.  While there is
higher priority stuff to be fixed, this is likely "good enough" for now.  For
compleness and to always "look good", this needs to be fixed someday.
Comment 24 Jonathan Blandford 2003-10-09 13:44:25 EDT
Note that the cursor was intentionally made to disappear as a feature.  I have
removed this in the version in CVS and replaced it with a standard cursor.
Comment 25 Brent Fox 2003-10-15 20:45:43 EDT
*** Bug 105627 has been marked as a duplicate of this bug. ***
Comment 26 Bill Nottingham 2006-08-04 16:15:19 EDT
Red Hat Linux and Red Hat Powertools are currently no longer supported by Red
Hat, Inc. In an effort to clean up bugzilla, we are closing all bugs in MODIFIED
state for these products.

However, we do want to make sure that nothing important slips through the
cracks. If, in fact, these issues are not resolved in a current Fedora Core
Release (such as Fedora Core 5), please open a new issues stating so. Thanks.

Note You need to log in before you can comment on or make changes to this bug.