Bug 100879 - Missing symbols cause PHP modules not to load
Summary: Missing symbols cause PHP modules not to load
Status: CLOSED DUPLICATE of bug 103690
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: php   
(Show other bugs)
Version: beta1
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: CambridgeBlocker
TreeView+ depends on / blocked
 
Reported: 2003-07-26 13:48 UTC by Nils Philippsen
Modified: 2007-03-27 04:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:57:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nils Philippsen 2003-07-26 13:48:12 UTC
Description of problem:

When starting httpd, PHP modules don't get loaded due to missing symbols, cf.
/var/log/httpd/error_log:

[...]
PHP Warning:  Unknown(): Unable to load dynamic library '/usr/lib/php4/imap.so'
- /usr/lib/php4/imap.so: undefined symbol: executor_globals in Unknown on line 0
PHP Warning:  Unknown(): Unable to load dynamic library '/usr/lib/php4/ldap.so'
- /usr/lib/php4/ldap.so: undefined symbol: OnUpdateInt in Unknown on line 0
PHP Warning:  Unknown(): Unable to load dynamic library '/usr/lib/php4/mysql.so'
- /usr/lib/php4/mysql.so: undefined symbol: OnUpdateInt in Unknown on line 0
PHP Warning:  Unknown(): Unable to load dynamic library '/usr/lib/php4/pgsql.so'
- /usr/lib/php4/pgsql.so: undefined symbol: OnUpdateBool in Unknown on line 0
[...]

PHP scripts using these modules break (tested with php-pgsql).

Version-Release number of selected component (if applicable):

php-4.3.2-7
(httpd-2.40.47-{1,2,3})

How reproducible:

Always

Steps to Reproduce:
1. Install said php
2. (Re)Start httpd
3. run php script that uses one of these modules
    
Actual results:

Error message, PHP script can't access PostgreSQL database

Expected results:

No error message, PHP scripts can access PostgreSQL database

Additional Info:

php-4.3.2-6 works flawlessly in that regard.

Comment 1 Nils Philippsen 2003-07-26 14:05:31 UTC
Digging a little further, I noticed the total absence of .text and .bss dynamic
symbols in /usr/lib/httpd/modules/libphp4.so of 4.3.2-7.

Running "objdump -Tt /usr/lib/httpd/modules/libphp4.so | LANG=C egrep
'\.text|\.bss'" on 4.3.2-6 gives a file with about 170KB while on 4.3.2-7 it's a
mere 91 bytes:

--- 8< ---
0001a640 l    d  .text  00000000
001f2180 l    d  .bss   00000000
--- >8 ---

Sounds like strip running amok while building the RPM -- but I'm not fit enough
in that area to confirm or let alone fix that.

Comment 2 Joe Orton 2003-07-27 08:01:36 UTC
Is this a clean Severn install?  You see these error_log messages just from
doing "service httpd start"?



Comment 3 Joe Orton 2003-07-27 08:10:43 UTC
Ignore me, you've answered that question already.

Comment 4 Nils Philippsen 2003-09-08 09:25:51 UTC
The problem still persists with php-4.3.3-1, httpd-2.0.47-5.

/var/log/httpd/error_log:
[...]
PHP Warning:  Unknown(): Unable to load dynamic library '/usr/lib/php4/imap.so'
- /usr/lib/php4/imap.so: undefined symbol: file_globals in Unknown on line 0
PHP Warning:  Unknown(): Unable to load dynamic library '/usr/lib/php4/ldap.so'
- /usr/lib/php4/ldap.so: undefined symbol: OnUpdateInt in Unknown on line 0
PHP Warning:  Unknown(): Unable to load dynamic library '/usr/lib/php4/mysql.so'
- /usr/lib/php4/mysql.so: undefined symbol: OnUpdateInt in Unknown on line 0
PHP Warning:  Unknown(): Unable to load dynamic library '/usr/lib/php4/pgsql.so'
- /usr/lib/php4/pgsql.so: undefined symbol: OnUpdateBool in Unknown on line 0
[...]

Comment 5 Joe Orton 2003-09-08 09:30:02 UTC
Its finally fixed in 4.3.3-2.

*** This bug has been marked as a duplicate of 103690 ***

Comment 6 Red Hat Bugzilla 2006-02-21 18:57:45 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.