Bug 103690 - php libraries fail to load - undefined symbols
php libraries fail to load - undefined symbols
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: php (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
: 100879 102503 (view as bug list)
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-09-03 17:31 EDT by Need Real Name
Modified: 2007-04-18 12:57 EDT (History)
2 users (show)

See Also:
Fixed In Version: 4.3.3-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-07 18:10:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-09-03 17:31:03 EDT
Description of problem:
started with clean redhat 9 install.

upgraded php, php-imap, php-ldap and php-mysql to 4.3.2-7 release, now get
unable to load dynamic library errors on apache startup, the libraries are in
the correct place in /usr/lib/php4

updated all other installed packages to rawhide release to try to fix

Version-Release number of selected component (if applicable):
4.3.2-7

How reproducible:
every time

Steps to Reproduce:
1.install new httpd, php, php-libraries + dependencies
2.start httpd
    
Actual results:

PHP Warning:  Unknown(): Unable to load dynamic library '/usr/lib/php4/imap.so'
- /usr/lib/php4/imap.so: undefined symbol: executor_globals in Unknown on line 0
PHP Warning:  Unknown(): Unable to load dynamic library '/usr/lib/php4/ldap.so'
- /usr/lib/php4/ldap.so: undefined symbol: OnUpdateInt in Unknown on line 0PHP
Warning:  Unknown(): Unable to load dynamic library '/usr/lib/php4/mysql.so' -
/usr/lib/php4/mysql.so: undefined symbol: OnUpdateInt in Unknown on line 0

Expected results:
none
Comment 1 Joe Orton 2003-09-07 18:10:43 EDT
Thanks for the report; fixed in php-4.3.3-2.
Comment 2 Joe Orton 2003-09-07 18:14:06 EDT
*** Bug 102503 has been marked as a duplicate of this bug. ***
Comment 3 Joe Orton 2003-09-08 05:30:04 EDT
*** Bug 100879 has been marked as a duplicate of this bug. ***
Comment 4 Joe Orton 2003-09-10 07:58:49 EDT
Fixed packages available at:

http://people.redhat.com/jorton/php-Severn/

Note You need to log in before you can comment on or make changes to this bug.