Bug 100884 - Adaptec AIC-7902 PCI ID (new) missing
Summary: Adaptec AIC-7902 PCI ID (new) missing
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: hwdata (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-07-26 16:04 UTC by Kaj J. Niemi
Modified: 2014-03-17 02:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-05 15:18:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -vvv (13.22 KB, text/plain)
2003-07-26 16:09 UTC, Kaj J. Niemi
no flags Details
patch for device AIC-7902 0x9005 0x801d against hwdata-0.89-1.1 pci.ids (346 bytes, patch)
2003-07-30 19:43 UTC, Kaj J. Niemi
no flags Details | Diff

Description Kaj J. Niemi 2003-07-26 16:04:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030719
Mozilla Firebird/0.6

Description of problem:
PCI ID 0x9005, 0x801d is unknown. It might be good to add it... I guess pcitable
is used for autodetecting since without it the drivers aren't loaded properly.

0x801d is not found in the AIC-79xx pcitables list at
<http://people.freebsd.org/~gibbs/linux/> either.

Attached is the output of "lspci -vvv" for reference.



Version-Release number of selected component (if applicable):
hwdata-0.75-1

How reproducible:
Always

Steps to Reproduce:
1. RFE really
2.
3.
    

Additional info:

Adding it and using AIC-79xx v1.3.10 or later makes all servers with Supermicro
X5DPR-iG2+/8G2+ motherboards really happy.

Comment 1 Kaj J. Niemi 2003-07-26 16:09:10 UTC
Created attachment 93161 [details]
lspci -vvv

Comment 2 Bill Nottingham 2003-07-28 01:13:14 UTC
Assigning to kernel so it can get added to the driver, added in cvs to pcitable.

Comment 3 Kaj J. Niemi 2003-07-28 20:54:21 UTC
Would suggest adding this as blocker to bug #100643 as well.

Comment 4 Jesse Keating 2003-07-30 19:34:58 UTC
Of note, the kernel from Severn works just fine, although it shows up as an
unknown device still in a lspci -v.

Comment 5 Kaj J. Niemi 2003-07-30 19:43:44 UTC
Created attachment 93270 [details]
patch for device AIC-7902 0x9005 0x801d against hwdata-0.89-1.1 pci.ids

That is because /usr/share/hwdata/pci.ids doesn't contain the entry for 801d
under 9005 Adaptec. :) Attached patch solves this.
									       
			  
03:02.0 SCSI storage controller: Adaptec AIC-7902 U320 OEM (rev 10)
	Subsystem: Adaptec: Unknown device 005e
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr-
Stepping- SERR+ FastB2B-
	Status: Cap+ 66Mhz+ UDF- FastB2B- ParErr- DEVSEL=slow >TAbort- <TAbort-
<MAbort- >SERR- <PERR-
	Latency: 64 (10000ns min, 6250ns max), cache line size 08
	Interrupt: pin A routed to IRQ 28
	Region 0: I/O ports at 4400 [disabled] [size=256]
	Region 1: Memory at fc300000 (64-bit, non-prefetchable) [size=8K]
	Region 3: I/O ports at 4000 [disabled] [size=256]
	Expansion ROM at <unassigned> [disabled] [size=512K]
	Capabilities: <available only to root>
									       
			  
03:02.1 SCSI storage controller: Adaptec AIC-7902 U320 OEM (rev 10)
	Subsystem: Adaptec: Unknown device 005e
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr-
Stepping- SERR+ FastB2B-
	Status: Cap+ 66Mhz+ UDF- FastB2B- ParErr- DEVSEL=slow >TAbort- <TAbort-
<MAbort- >SERR- <PERR-
	Latency: 64 (10000ns min, 6250ns max), cache line size 08
	Interrupt: pin B routed to IRQ 29
	Region 0: I/O ports at 4c00 [disabled] [size=256]
	Region 1: Memory at fc302000 (64-bit, non-prefetchable) [size=8K]
	Region 3: I/O ports at 4800 [disabled] [size=256]
	Expansion ROM at <unassigned> [disabled] [size=512K]
	Capabilities: <available only to root>

Comment 6 Kaj J. Niemi 2003-09-05 14:54:52 UTC
Seems like at least hwdata-0.93-1.1 includes 0x9005 0x801d. You guys resolve
this if it's really fixed :-)

Comment 7 Kaj J. Niemi 2003-09-05 14:56:03 UTC
Actually /usr/share/hwdata/pci.ids doesn't contain it but
/usr/share/hwdata/pci.ids does.



Comment 8 Kaj J. Niemi 2003-09-05 14:57:51 UTC
Component should be hwdata, not kernel.

Comment 9 Kaj J. Niemi 2003-09-05 15:01:12 UTC
First think THEN comment on bug... ;(

 /usr/share/hwdata/pci.ids does contain the entry (see patch)
 /usr/share/hwdata/pcitable has it


Comment 10 Kaj J. Niemi 2003-09-05 15:02:06 UTC
ahem... pci.ids does __NOT__ contain the entry.

Not my day today at all.

Comment 11 Bill Nottingham 2003-09-05 15:17:13 UTC
Please submit pci.ids upstream at pciids.sf.net too. Added in CVS, will get
rebuilt eventually (the important part, pcitable, is there.)


Note You need to log in before you can comment on or make changes to this bug.