Bug 100895 - Have trouble adding user to existing Groups
Have trouble adding user to existing Groups
Status: CLOSED DUPLICATE of bug 98000
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-users (Show other bugs)
9
athlon Linux
high Severity high
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-07-26 17:46 EDT by Justin Churchey
Modified: 2006-02-21 13:57 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:57:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Churchey 2003-07-26 17:46:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
Added a user and created a custom group for it.  I edited /etc/passwd and
/etc/shadow to add an underscore to the username.  I had to delete the user b/c
Linux kept saying that the password would have to be reset in 0 days (which may
be another bug).  I added the user again (no underscores).  A dialog prompted me
asking whether or not I wanted to add the user to the already existing custom
group that it made before or add them to the "users" group.  I chose yes, and
the program hangs giving the following output to terminal: 

  File "/usr/share/redhat-config-users/userWindow.py", line 290, in
on_userWin_ok_button_clicked
    self.userWinReset()
  File "/usr/share/redhat-config-users/userWindow.py", line 92, in userWinReset
    self.uidSpinButton.set_value(500)
TypeError: argument 2 must be list, not str

Version-Release number of selected component (if applicable):
redhat-config-users-1.1.10-1

How reproducible:
Always

Steps to Reproduce:
1.Run redhat-config-users
2.Add user where a custom group had already been made under that name
3.Choose to add to existing group when the dialog box appears
    

Actual Results:  The program hangs

Expected Results:  The program should add the user to the existing group with no
problems

Additional info:
Comment 1 Brent Fox 2003-10-15 20:52:01 EDT

*** This bug has been marked as a duplicate of 98000 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:57:46 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.