Bug 98000 - Unable to add just created user to pre-existing group with same name
Unable to add just created user to pre-existing group with same name
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: redhat-config-users (Show other bugs)
alpha 3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
: 100895 105031 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-25 08:07 EDT by Leonid Kanter
Modified: 2007-04-18 12:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-23 17:53:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leonid Kanter 2003-06-25 08:07:03 EDT
Description of problem:

Unable to add just created user to pre-existing group with same name

Version-Release number of selected component (if applicable):

redhat-config-users-1.1.9-1

How reproducible:

always

Steps to Reproduce:
1. start redhat-config-users
2. add group "test" with manually entered group ID 502
3. add user "test" with manually entered user ID 502
    
Actual results:

redhat-config-users will hang forever

Expected results:

user must be added

Additional info:

message on console:
Traceback (most recent call last):
  File "/usr/share/redhat-config-users/userWindow.py", line 290, in
on_userWin_ok_button_clicked
    self.userWinReset()
  File "/usr/share/redhat-config-users/userWindow.py", line 92, in userWinReset
    self.uidSpinButton.set_value(500)
TypeError: argument 2 must be list, not str
Comment 1 Harald Hoyer 2003-06-25 08:29:30 EDT
assigned to the right component
Comment 2 Brent Fox 2003-07-23 17:53:13 EDT
I can't say for sure, but I suspect that this is a bug in the gtkSpinButton.  I
don't know how the spinButton could ever be expecting a list instead of a
string.  However, I've not been able to create a small test program that
reliably demonstrates the error.

Anyway, I've just added a try/except loop that will catch the error and allow
the program to continue.  Should appear in redhat-config-users-1.1.12-1 in
Rawhide.  I'll file a separate bug against GTK if I can ever get a small test
case to demonstrate the behavior.
Comment 3 Brent Fox 2003-10-06 22:14:05 EDT
*** Bug 105031 has been marked as a duplicate of this bug. ***
Comment 4 Brent Fox 2003-10-15 20:52:06 EDT
*** Bug 100895 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.