Bug 1010132 - zanata-cli failed to push the locales with underscore (e.g. gettext project), unless specify them using map-from
zanata-cli failed to push the locales with underscore (e.g. gettext project),...
Status: CLOSED UPSTREAM
Product: Zanata
Classification: Community
Component: Component-zanata-client (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: David Mason
Zanata-QA Mailling List
:
Depends On: 1098836 1139950
Blocks: 1110627
  Show dependency treegraph
 
Reported: 2013-09-20 00:59 EDT by Ding-Yi Chen
Modified: 2015-07-30 21:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-30 21:13:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2013-09-20 00:59:03 EDT
Description of problem:
gettext project usually contains the po file with underscore filename, such as pt_BR.po,zh_CN.po,zh_TW.po. However, unless map-from is set, those files are skipped, thus not push to server.

Version-Release number of selected component (if applicable):
zanata-cli-3.1.2
Zanata version 3.0.4-SNAPSHOT (20130920-0021)

How reproducible:
Always

Steps to Reproduce: 
1. Download and extract ibus-chewing (http://ibus.googlecode.com/files/ibus-chewing-1.4.3-Source.tar.gz)
2. cd po
3. Create project ibus-chewing and version master
4. Make sure zh_CN and zh_TW are in the locale list.
5. Download zanata.xml by clicking Action "Config file" in ibus-chewing/master in WebUI
6. zanata-cli push --push-type both -s . -t .

Actual results:
zh_CN and zh_TW are ignored.

Expected results:
zh_CN and zh_TW are pushed.

Additional info:
Pulling also suffer similar bug. zh_CN is pulled as zh-CN.po thus cannot be used directly in build.
Comment 1 Sean Flanigan 2014-07-17 04:15:25 EDT
Each project type in the client should do any required mapping between the locale format used by that project type (ie with underscores for Java properties or gettext software) and the locale format used in Zanata server (with hyphens).  We do this for "properties" projects, and we should also do it for "gettext" projects.

Since there is a workaround [1], I would be inclined to reduce the priority to medium, but as this is likely to affect virtually all gettext software projects (including Fedora software projects) I think we should keep the priority as high.

[1] Workaround: specify map-from in zanata.xml for the affected locales.
Comment 2 Zanata Migrator 2015-07-30 21:13:24 EDT
Migrated; check JIRA for bug status: http://zanata.atlassian.net/browse/ZNTA-362

Note You need to log in before you can comment on or make changes to this bug.