Bug 1098836 - mvn failed to push the locales with underscore (e.g. gettext project), unless specify them using map-from
Summary: mvn failed to push the locales with underscore (e.g. gettext project), unless...
Keywords:
Status: CLOSED DUPLICATE of bug 1139950
Alias: None
Product: Zanata
Classification: Retired
Component: Component-Maven
Version: 3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Patrick Huang
QA Contact: Zanata-QA Mailling List
URL:
Whiteboard:
Depends On:
Blocks: 1010132 1124615
TreeView+ depends on / blocked
 
Reported: 2014-05-19 01:27 UTC by Ding-Yi Chen
Modified: 2014-10-08 03:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-08 03:12:18 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1139950 None None None Never

Internal Links: 1139950

Description Ding-Yi Chen 2014-05-19 01:27:36 UTC
Description of problem:
gettext project usually contains the po file with underscore filename, such as pt_BR.po,zh_CN.po,zh_TW.po. However, unless map-from is set, those files are skipped, thus not push to server.

Version-Release number of selected component (if applicable):
Zanata 3.4.0-SNAPSHOT (git-server-3.3.2-345-gaa6d307
zanata-maven-plugin:3.3.0

How reproducible:
Always

Steps to Reproduce: 
1. Download and extract ibus-chewing (http://ibus.googlecode.com/files/ibus-chewing-1.4.3-Source.tar.gz)
2. cd po
3. Create project ibus-chewing and version master
4. Make sure zh_CN and zh_TW are in the locale list.
5. Download zanata.xml by clicking Action "Config file" in ibus-chewing/master in WebUI
6. mvn zanata:push -Dzanata.pushType=both

Actual results:
zh_CN and zh_TW are ignored.

Expected results:
zh_CN and zh_TW are pushed.

Additional info:
Pulling also suffer similar bug. zh_CN is pulled as zh-CN.po thus cannot be used directly in build.

Comment 1 Ding-Yi Chen 2014-07-17 06:26:39 UTC
Veteran users may already have zanata.xml from other projects to copy and rename from. However, this will definitely shock the new users.

Comment 2 Ding-Yi Chen 2014-10-08 03:12:18 UTC
Bug 1139950 also fixed this bug.

*** This bug has been marked as a duplicate of bug 1139950 ***


Note You need to log in before you can comment on or make changes to this bug.