Bug 1139950 - RFE: Flexible Translation file naming
RFE: Flexible Translation file naming
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-Maven, Component-zanata-client, Component-zanata-client-ivy (Show other bugs)
client-3.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: client-3.4
Assigned To: Patrick Huang
Ding-Yi Chen
:
: 1098836 (view as bug list)
Depends On:
Blocks: 1010132 1124615
  Show dependency treegraph
 
Reported: 2014-09-10 00:37 EDT by Carlos Munoz
Modified: 2015-04-19 21:14 EDT (History)
3 users (show)

See Also:
Fixed In Version: commit 07f42ed1ac87976f8a68a5109aa2c91d6e404011
Doc Type: Bug Fix
Doc Text:
Story Points: 5
Clone Of:
Environment:
Last Closed: 2015-04-19 21:14:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carlos Munoz 2014-09-10 00:37:48 EDT
The client will get all source files that match the includes pattern. Then, it will try to find all translation files using the given rule patterns. 

Multiple mapping rules are possible.

The rules will be available in zanata.xml only.

Existing projects are still handled in the current way.

The client will try to apply the mapping pattern to any found translation file, and based on that result it will choose a source document to upload to.

This is only for translation files.

Available placeholders: {path}/{filename}/{locale}/{localeWithUnderscores}/{extension}
(The placeholder delimiter is TBD, but {} sounds like a good fit.)
Comment 1 Patrick Huang 2014-09-11 01:43:18 EDT
placeholder {path} is anything between src-dir and filename. 
For example, if src-dir is my/directory and the source file found is my/directory/foo/bar/message.pot, then {path} is "foo/bar", {filename} is "message", {extension} is "pot". 

Given locale "de-DE", trans-dir "trans" and rule "{path}/{filename}_{local_with_underscore}.po",

The final translation file will be put under:
trans/foo/bar/message_de_DE.po
Comment 2 Patrick Huang 2014-09-17 20:47:48 EDT
This bug will also address bug 1098836. For gettext project it will auto covert '-' to '_' in locale code.
Comment 3 Patrick Huang 2014-09-25 02:01:37 EDT
https://github.com/zanata/zanata-client/pull/31
Comment 5 Ding-Yi Chen 2014-10-07 23:12:18 EDT
*** Bug 1098836 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.