Bug 1010440 - cups-pdf output is incorrect due to incomplete upgrade; cups-pdf should detect and correct or report this situation
cups-pdf output is incorrect due to incomplete upgrade; cups-pdf should detec...
Product: Fedora
Classification: Fedora
Component: cups-pdf (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Remi Collet
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2013-09-20 15:13 EDT by Dale R. Worley
Modified: 2013-09-21 01:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-09-21 01:39:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
The /etc/cups/printers.conf before deleting and recreating the Cups-PDF printer. (448 bytes, text/plain)
2013-09-20 15:13 EDT, Dale R. Worley
no flags Details

  None (edit)
Description Dale R. Worley 2013-09-20 15:13:27 EDT
Created attachment 800636 [details]
The /etc/cups/printers.conf before deleting and recreating the Cups-PDF printer.

Description of problem:

Carrying forward the Fedora 16 CUPS configuration to Fedora 19 left the Cups-PDF printer appearing to be installed, but it is not functional.  This is probably unavoidable, but the Cups-PDF system failed to detect the problem and instead generated empty PDFs.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:

Actual results:

Expected results:

Additional info:

What was seen was:

After fixing the problems described in https://bugzilla.redhat.com/show_bug.cgi?id=1009609:

1. Delete all files in ~/Desktop.

2. Create a LibreOffice text document containing "The quick brown fox jumps over the lazy dog."

3. Select File->Print and print the document to the printer "Cups-PDF".

4. A file named "Videos_.pdf" is created in ~/Desktop.

5. Viewing ~/Desktop/Videos_.pdf using either Adobe Reader 9 (AdobeReader_enu-9.5.5-1.i486) or DocView within Emacs (24.3.1) shows the PDF to be empty.

Using Firefox to print https://bugzilla.redhat.com/show_bug.cgi?id=1009609 to Cups-PDF produces the same result, viz., generating ~/Desktop/Videos_.pdf which is shown as empty by both readers.  The two Videos_.pdf files are similar but not identical.

After these two tests, /var/log/cups/cups-pdf_log shows:

Fri Sep 20 14:12:07 2013  [STATUS] PDF creation successfully finished (worley)
Fri Sep 20 14:16:20 2013  [STATUS] PDF creation successfully finished (worley)

/var/log/cups/access_log shows:

localhost - - [20/Sep/2013:14:12:06 -0400] "POST /printers/Cups-PDF HTTP/1.1" 200 197 Create-Job successful-ok
localhost - - [20/Sep/2013:14:12:06 -0400] "POST /printers/Cups-PDF HTTP/1.1" 200 26644 Send-Document successful-ok
localhost - - [20/Sep/2013:14:16:20 -0400] "POST /printers/Cups-PDF HTTP/1.1" 200 81128 Print-Job successful-ok

(This is another aspect of https://bugzilla.redhat.com/show_bug.cgi?id=1010434, cups-pdf does not report failures.)

/var/spool/cups shows two pairs of entries:

  -rw-------.  1 root lp        851 Sep 20 14:16 c00013
  -rw-r-----.  1 root lp      80810 Sep 20 14:16 d00013-001
  -rw-------.  1 root lp        751 Sep 20 14:12 c00012
  -rw-r-----.  1 root lp      26383 Sep 20 14:12 d00012-001

Copying the d*-001 files to another location and giving them a .pdf extension shows them to contain the desired PDFs.

However, following the clues in https://bugzilla.redhat.com/show_bug.cgi?id=1005492 I used system-config-printer to delete the Cups-PDF printer and then re-create it.  After that, Cups-PDF worked correctly.

Thus, it appears that the problem is that copying the printer configuration (/etc/cups/printers.conf) from my previous system (Fedora 16) to Fedora 19 leaves the Cups-PDF printer mis-configured. The Fedora 19 code should detect and report this problem more effectively.
Comment 1 Remi Collet 2013-09-21 01:39:39 EDT
/etc/cups/printers.conf is not managed by cups-pdf (but by cups).

Sorry, but I don't see anything we can't do (in cups-pdf) to fix this upgrade issue.

Note You need to log in before you can comment on or make changes to this bug.