Bug 101075 - Bluetooth operation fails because no RFCOMM devices in /dev
Bluetooth operation fails because no RFCOMM devices in /dev
Status: CLOSED DUPLICATE of bug 88802
Product: Red Hat Linux Beta
Classification: Retired
Component: MAKEDEV (Show other bugs)
beta1
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brock Organ
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-07-28 18:11 EDT by Ryan Muldoon
Modified: 2007-04-18 12:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:57:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Muldoon 2003-07-28 18:11:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686) Gecko/20030530 Galeon/1.3.5

Description of problem:
I could not get the "rfcomm" utility that comes with bluez-utils with Severn
because there were no "rfcomm0" or "rfcomm1".  I created these devices using:
mknod rfcomm0 c 216 0 && mknod rfcomm1 c 216 1 

which allowed RFCOMM to work, so I could then use the OBEX utilities.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1./etc/rc.d/init.d/bluetooth restart

    

Actual Results:  This resulted in an RFCOMM failure: No file or Directory Found
(because there were no rfcomm devices in /dev)

Expected Results:  RFCOMM should have worked properly so my bluetooth adapter
could send files back and forth to my phone.

Additional info:

In general, I followed the advice of
http://blog.chris.de/archives/19_Bluetooth_Linux_and_a_Mobile.html
and was able to get my bluetooth phone to talk to Severn.  It would be great if
these steps were taken to work by default. (Like the various kernel modules
being loaded on the presence of a bluetooth adapter...)

Finally, Bluetooth could be a lot easier for normal users if the GNOME-Bluetooth
programs were included by default.  These can be found here:
http://usefulinc.com/software/gnome-bluetooth/
Thanks!
Comment 1 Bastien Nocera 2004-06-01 06:18:07 EDT

*** This bug has been marked as a duplicate of 88802 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:57:49 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.