Bug 1012024 - python-nova erroneously requires webob1.0 [openstack-4]
python-nova erroneously requires webob1.0 [openstack-4]
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
3.0
All All
unspecified Severity medium
: beta
: 4.0
Assigned To: Xavier Queralt
Ami Jeain
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-25 10:56 EDT by Dan Yocum
Modified: 2014-06-18 03:00 EDT (History)
10 users (show)

See Also:
Fixed In Version: openstack-nova-2013.2-2.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1012694 1016515 (view as bug list)
Environment:
Last Closed: 2013-12-19 19:25:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Yocum 2013-09-25 10:56:31 EDT
Description of problem:

Remove webob1.0 from RHOSv3 package requirements - everything should be using webob1.2.3.

>>> [root@public-comp050 ~]# rpm -q --whatrequires python-webob1.0
>>> python-keystone-2013.1.3-1.el6ost.noarch
>>> python-nova-2013.1.3-3.el6ost.noarch

That should be fixed, both Nova and Keystone have WebOb==1.2.3 in upstream pip-requires.
Please file BZs and we'll fix that in the next 3.0.z update.

Cheers,
Alan
Comment 2 Dan Yocum 2013-09-25 11:23:26 EDT
Changed target release to 3.0.x? per Alan's comment in the original ticket.
Comment 6 Scott Lewis 2013-11-19 11:54:43 EST
Auto adding >= MODIFIED bugs to beta
Comment 7 Ami Jeain 2013-11-26 09:27:54 EST
verified:
# rpm -q --whatrequires python-webob1.0
python-neutron-2013.2-9.el6ost.noarch

although the list is not empty, the following bug already fixes this issue in the next neutron version:
https://bugzilla.redhat.com/show_bug.cgi?id=1031849
Comment 11 errata-xmlrpc 2013-12-19 19:25:00 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.