Bug 101209 - /dev/cdrom link not set up correctly for ide-cdrw drive
/dev/cdrom link not set up correctly for ide-cdrw drive
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux Beta
Classification: Retired
Component: kudzu (Show other bugs)
beta1
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
: 81558 99056 (view as bug list)
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-07-29 21:06 EDT by Justin Clacherty
Modified: 2014-03-16 22:37 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-29 15:58:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kudzu -p output (2.76 KB, text/plain)
2003-07-29 21:48 EDT, Justin Clacherty
no flags Details

  None (edit)
Description Justin Clacherty 2003-07-29 21:06:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
I presume this is a kudzu issue, not really sure.

After installing Severn I was unable to mount the cdrom.  I have an IDE CD-RW 
drive attached to /dev/hdc, the install set this up using the ide-scsi driver 
and pointed the /dev/cdrom link to /dev/hdc.  Changing /dev/cdrom to point 
to /dev/scd0 allows me to mount the cdrom correctly.

I noticed that someone on the rhl-beta-list has experienced a similar problem.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Severn
2. Try to mount /mnt/cdrom
    

Actual Results:  fs would not mount

Expected Results:  fs should mount

Additional info:

[root@leo root]# mount /mnt/cdrom
mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
       or too many mounted file systems
       (could this be the IDE device where you in fact use
       ide-scsi so that sr0 or sda or so is needed?)
[root@leo root]#
Comment 1 Bill Nottingham 2003-07-29 21:33:23 EDT
Please post the output of 'kudzu -p'; thanks!
Comment 2 Justin Clacherty 2003-07-29 21:48:17 EDT
Created attachment 93248 [details]
kudzu -p output

Here you go.
Comment 3 Bill Nottingham 2003-08-01 16:14:13 EDT
*** Bug 99056 has been marked as a duplicate of this bug. ***
Comment 4 Bill Nottingham 2003-08-01 16:17:19 EDT
*** Bug 81558 has been marked as a duplicate of this bug. ***
Comment 5 Justin Clacherty 2003-08-03 07:12:10 EDT
Something that might help.

I re-installed the system a few days ago picking the server class install and 
the /dev/cdrom link is set up correctly.  I re-installed today picking a 
workstation install (just to test this issue) and /dev/cdrom is set up 
incorrectly.  Did another server install and /dev/cdrom is set up correctly.
Comment 6 Warren Togami 2003-09-21 07:51:07 EDT
"me too".  Strangely I've never seen this until the Cambridge alpha and beta
releases.  RH9 and earlier were fine on my laptop.
Comment 7 Bill Nottingham 2003-10-22 17:24:03 EDT
Warren: it does the same for you vis-a-vis server/workstation installs?
Comment 8 Bill Nottingham 2003-10-22 17:24:56 EDT
Are you booting with rhgb?
Comment 9 Behdad Esfahbod 2003-11-05 09:02:28 EST
I have the same problem:  Before FC test releases (up to RH 9
updated), I never new about scd0.  Oh, wrong, when I compiled any
vanilla kernel, I did pointed cdrom to scd0, but Red Hat kernels
always liked hdc itself.  But with FC tests it's always scd0, but it
was originally pointing to hdc for me too.
Comment 10 Bill Nottingham 2005-03-29 15:58:18 EST
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

With 2.6, ide-scsi is no longer needed, and this should be all cleared up.

Note You need to log in before you can comment on or make changes to this bug.