Bug 1013501 - Drush fails as regular user (permission denied)
Drush fails as regular user (permission denied)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: php-drush-drush (Show other bugs)
19
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Shawn Iwinski
Fedora Extras Quality Assurance
:
Depends On: 997843 1016260
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-30 04:36 EDT by Claus Conrad
Modified: 2013-12-24 12:57 EST (History)
4 users (show)

See Also:
Fixed In Version: php-drush-drush-6.2.0-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-24 12:57:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 997843 None None None Never

  None (edit)
Description Claus Conrad 2013-09-30 04:36:13 EDT
Description of problem:

Permission denied when run as regular user; tries to write to /usr/share.

Version-Release number of selected component (if applicable): 5.9

How reproducible:

When I run "drush <some-command>" on a Drupal website somewhere below my home folder it complains about not being able to write to /usr/share/pear/drush.

Steps to Reproduce:
1. sudo yum install -y php-drush-drush
2. cd
3. drush status

Actual results:

[claus@localhost]$ drush status
Directory /usr/share/pear/drush exists, but is not writable. Please  [error]
check directory permissions.

Expected results:

A message that the current directory is not a Drupal site.

Additional info:

Reporting this bug as suggested at https://ask.fedoraproject.org/question/33217/drush-fails-as-regular-user-permission-denied/ , where a workaround is described.

Fixing https://bugzilla.redhat.com/show_bug.cgi?id=997843 would probably fix this one too.
Comment 1 John Friar 2013-10-08 14:01:36 EDT
This problem is being caused because the drush RPM does not include "/usr/share/pear/drush/lib/", which drush requires (but doesn't require to be writeable), and a non-root user cannot create that folder

"/usr/share/pear/drush/lib/" should be included in the drush RPM.

When I created that folder (as root), my non-root user was able to run drush.
Comment 2 Shawn Iwinski 2013-10-08 20:39:34 EDT
Claus & John -- Would two like to have a quick fix for this (comment #1) or would you like to wait until I have time to get the pkg updated (bug #997843).  I could do the quick fix tomorrow, but the update will take me a little longer.
Comment 3 Claus Conrad 2013-10-09 04:30:56 EDT
This is not urgent for me. I am working with the upstream 6.0 release at the moment.
Comment 4 John Friar 2013-10-09 13:19:55 EDT
I've manually fixed this by creating "/usr/share/pear/drush/lib" on my machines with drush, so, assuming bug #997843 will be available for RHEL6 (via EPEL), then I'm fine with waiting for version 6 as well.
Comment 5 Fedora Update System 2013-12-09 12:29:55 EST
php-drush-drush-6.2.0-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/php-drush-drush-6.2.0-1.fc18
Comment 6 Fedora Update System 2013-12-09 12:30:20 EST
php-drush-drush-6.2.0-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/php-drush-drush-6.2.0-1.fc19
Comment 7 Fedora Update System 2013-12-09 12:30:45 EST
php-drush-drush-6.2.0-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/php-drush-drush-6.2.0-1.fc20
Comment 8 Fedora Update System 2013-12-09 12:31:15 EST
php-drush-drush-6.2.0-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/php-drush-drush-6.2.0-1.el6
Comment 9 Fedora Update System 2013-12-22 00:31:59 EST
php-drush-drush-6.2.0-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-12-22 00:45:46 EST
php-drush-drush-6.2.0-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2013-12-22 00:47:49 EST
php-drush-drush-6.2.0-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2013-12-24 12:57:32 EST
php-drush-drush-6.2.0-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.