Bug 1020111 - devicetree.py:1294:addLV:ValueError: 'File descriptor 3 (/tmp/anaconda.log) leaked on lvm invocation. Parent PID 2234: /usr/bin/python' is not in list
devicetree.py:1294:addLV:ValueError: 'File descriptor 3 (/tmp/anaconda.log) l...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:11b93e9988e1d3f5ad83e80e8a8...
:
: 1020117 (view as bug list)
Depends On:
Blocks: F20BetaBlocker 1013800
  Show dependency treegraph
 
Reported: 2013-10-16 23:44 EDT by Chris Murphy
Modified: 2013-11-04 22:39 EST (History)
13 users (show)

See Also:
Fixed In Version: anaconda-20.25.4-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-04 22:39:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: environ (453 bytes, text/plain)
2013-10-16 23:44 EDT, Chris Murphy
no flags Details
File: os_info (291 bytes, text/plain)
2013-10-16 23:44 EDT, Chris Murphy
no flags Details
anaconda.log (2.77 KB, text/plain)
2013-10-16 23:47 EDT, Chris Murphy
no flags Details
storage.log (127.38 KB, text/plain)
2013-10-16 23:47 EDT, Chris Murphy
no flags Details
program.log (37.83 KB, text/plain)
2013-10-16 23:48 EDT, Chris Murphy
no flags Details
journalctl -b (237.61 KB, text/plain)
2013-10-16 23:50 EDT, Chris Murphy
no flags Details
backtrace for reproduced crash (4.68 KB, text/plain)
2013-10-17 00:16 EDT, Chris Murphy
no flags Details
c11 anaconda.log (2.81 KB, text/plain)
2013-10-17 15:25 EDT, Chris Murphy
no flags Details
c11 backtrace (4.80 KB, text/plain)
2013-10-17 15:26 EDT, Chris Murphy
no flags Details

  None (edit)
Description Chris Murphy 2013-10-16 23:44:14 EDT
Description of problem:
Crash on launch. Prior system it's finding is a successful Thin Provisioning installation. The following updated RPMs were applied to F20 Live Beta TC4:
anaconda-20.25.1-1
anaconda-widgets ""
python-blivet-0.23.1-1

Version-Release number of selected component:
anaconda-20.25.1-1.fc20

Additional info:
cmdline:        /usr/bin/python /usr/bin/anaconda-cleanup anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
dso_list:       python-blivet-0.23.1-1.fc20.noarch
executable:     /usr/bin/anaconda-cleanup
kernel:         3.11.4-302.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            0
Comment 1 Chris Murphy 2013-10-16 23:44:18 EDT
Created attachment 813168 [details]
File: environ
Comment 2 Chris Murphy 2013-10-16 23:44:21 EDT
Created attachment 813169 [details]
File: os_info
Comment 3 Chris Murphy 2013-10-16 23:47:39 EDT
Created attachment 813170 [details]
anaconda.log
Comment 4 Chris Murphy 2013-10-16 23:47:52 EDT
Created attachment 813171 [details]
storage.log
Comment 5 Chris Murphy 2013-10-16 23:48:09 EDT
Created attachment 813172 [details]
program.log
Comment 6 Chris Murphy 2013-10-16 23:50:02 EDT
Created attachment 813173 [details]
journalctl -b
Comment 7 Chris Murphy 2013-10-17 00:13:24 EDT
*** Bug 1020117 has been marked as a duplicate of this bug. ***
Comment 8 Chris Murphy 2013-10-17 00:16:09 EDT
Created attachment 813176 [details]
backtrace for reproduced crash
Comment 9 David Lehman 2013-10-17 11:06:47 EDT
See if this updates image helps:

  http://dlehman.fedorapeople.org/updates/updates-1020111.0.img

Thanks.
Comment 10 Chris Murphy 2013-10-17 15:02:25 EDT
DVD ISO beta TC5 without this updates img applied, does not crash. So this bug 102011 or bug 101300 appears squashed.

Live desktop beta TC4 with the three rpm updates, and this updates img, still crashes. Maybe it's better to just axe TC4 and this update img, and move to live desktop TC5.
Comment 11 Chris Murphy 2013-10-17 15:17:34 EDT
c10 correction: bug 1020111 or bug 103800

Fedora-Live-Desktop-x86_64-20-Beta-TC5.iso crashes with or without updates-1020111.0.img.
Comment 12 Chris Murphy 2013-10-17 15:25:09 EDT
Created attachment 813524 [details]
c11 anaconda.log

update.img is present
ll /tmp
3499 Oct 17 15:22 updates.img
Comment 13 Chris Murphy 2013-10-17 15:26:02 EDT
Created attachment 813526 [details]
c11 backtrace
Comment 14 David Lehman 2013-10-21 13:32:26 EDT
(In reply to Chris Murphy from comment #12)
> Created attachment 813524 [details]
> c11 anaconda.log
> 
> update.img is present
> ll /tmp
> 3499 Oct 17 15:22 updates.img

How are you applying the updates image? On the boot/kernel cmdline?

I am asking because the patch in the updates image fixes the lvm leaked fd messages completely for me. I'm not even seeing a crash with Fedora-Live-Desktop-x86_64-20-Beta-TC5.iso without the updates/patch.
Comment 15 Chris Murphy 2013-10-21 14:15:55 EDT
It's applied on kernel command line from the isolinux boot menu. No crash for DVD ISO, but I get a crash with or without update applied with live desktop; anaconda UI still comes up but right before that I have an abrt crash notification.
Comment 16 Chris Murphy 2013-10-21 14:54:04 EDT
So far the easiest way to always reproduce this is:
1. qemu/kvm using qcow2 for disk backing, boot F20 beta TC5 DVD ISO, guided partitioning scheme=LVM Thin Provisioning, minimal package set, install.
2. Switch to F20 beta TC5 live desktop ISO, boot, at Welcome to Fedora splash choose Install to Hard Drive.

Result:
At the bottom of the screen an abrt message appears: "A Problem Has Occurred A problem in the anaconda-20.25.1-1..." And behind it I see anaconda's select language page. I can get to the hub just fine.

If I launch ABRT, one item is listed in the System tab which is how I originally filed this bug:

anaconda crashed
devicetree.py:1294:addLV:ValueError: 'File desc...

Occurs with or without the c9 updates.img on isolinux boot line.
Comment 17 David Lehman 2013-10-21 14:59:07 EDT
Please run this command on the live system with updates applied:

  grep -n close_fds /usr/lib/python2.7/site-packages/blivet/util.py

And report the output here. Thanks.
Comment 18 Chris Murphy 2013-10-21 15:24:02 EDT
There is no output from that command before or after launching anaconda (updates.img doesn't appear in /tmp until after launching anaconda).
Comment 19 Chris Murphy 2013-10-21 15:46:18 EDT
If I go into /tmp/updates/blivet and run the command:

[liveuser@localhost blivet]$ grep -n close_fds util.py
39:                                    close_fds=True,

So I think the updates haven't been downloaded by the time the bug is hit. If I quit anaconda, and relaunch, there is no abrt message a 2nd go around. So I think this is fixed, but I don't understand the updates mechanism very well.
Comment 20 Adam Williamson 2013-10-23 13:10:00 EDT
Discussed at 2013-10-23 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-10-23/f20-blocker-review.2013-10-23-16.00.log.txt .  Accepted as a blocker as a conditional violation of Alpha criterion "The installer must run when launched normally from the release-blocking images." - https://fedoraproject.org/wiki/Fedora_20_Alpha_Release_Criteria#Installer_must_run - in the case of a system with a pre-existing, anaconda-created LVM thinp layout.
Comment 21 Fedora Update System 2013-10-25 21:13:13 EDT
anaconda-20.25.4-1.fc20, pykickstart-1.99.44-1.fc20, python-blivet-0.23.2-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/pykickstart-1.99.44-1.fc20,python-blivet-0.23.2-1.fc20,anaconda-20.25.4-1.fc20
Comment 22 Fedora Update System 2013-10-26 14:49:36 EDT
Package anaconda-20.25.4-1.fc20, pykickstart-1.99.44-1.fc20, python-blivet-0.23.2-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-20.25.4-1.fc20 pykickstart-1.99.44-1.fc20 python-blivet-0.23.2-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20033/pykickstart-1.99.44-1.fc20,python-blivet-0.23.2-1.fc20,anaconda-20.25.4-1.fc20
then log in and leave karma (feedback).
Comment 23 Chris Murphy 2013-10-27 22:44:13 EDT
Not reproducible with Fedora-20-Beta-TC6-x86_64-DVD.iso or Fedora-Live-Desktop-x86_64-20-Beta-TC6.iso which has:

anaconda-20.25.4-1.fc20 
pykickstart-1.99.44-1.fc20 
python-blivet-0.23.2-1.fc20
Comment 24 Jan Sedlák 2013-10-30 08:14:46 EDT
Seems fixed in Fedora 20 Beta TC6.
Comment 25 Fedora Update System 2013-11-04 22:39:25 EST
anaconda-20.25.4-1.fc20, pykickstart-1.99.44-1.fc20, python-blivet-0.23.2-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.