Bug 1014297 - unable to add partitions
unable to add partitions
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 12:47 EDT by mock
Modified: 2014-03-04 11:43 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-04 11:43:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
walk-through of the steps listed above showing the problem (3.20 MB, video/webm)
2013-10-01 12:47 EDT, mock
no flags Details
anaconda.log (27.85 KB, text/x-log)
2013-10-01 15:42 EDT, mock
no flags Details
anaconda-tb-e10HLr (554.21 KB, text/plain)
2013-10-01 15:44 EDT, mock
no flags Details
storage.log (130.75 KB, text/x-log)
2013-10-01 15:45 EDT, mock
no flags Details
storage.state (20.00 KB, application/octet-stream)
2013-10-01 15:45 EDT, mock
no flags Details
syslog (78.89 KB, text/plain)
2013-10-01 15:46 EDT, mock
no flags Details
X.log (21.48 KB, text/x-log)
2013-10-01 15:47 EDT, mock
no flags Details

  None (edit)
Description mock 2013-10-01 12:47:04 EDT
Created attachment 806088 [details]
walk-through of the steps listed above showing the problem

Description of problem:

unable to add partitions when modifying the recommended configuration to remove a swap partition for a usb device and re-add the root partition.


Version-Release number of selected component (if applicable):

fedora 20 alpha


How reproducible:

can reproduce at will.


Steps to Reproduce:
1. configure vm to include a usb device
2. boot from the fedora 20 alpha netinstall
3. enter the drive selection and choose usb
4. choose either lvm or standard partitions and press done
5. choose the drive selection again pick the usb and choose to review the partitions and press done
6. remove the swap and root partitions
7. attempt to add the root partition back without specifying the size to use the full amount
8. new partition does not list


Actual results:
the process completes with no errors or crashes yet does not include the newly added partition.


Expected results:
newly added partition should be listed.


Additional info:
see the included screencast for a reenactment.
Comment 1 David Lehman 2013-10-01 14:02:16 EDT
Please attach /tmp/anaconda.log, /tmp/storage.log, and anything matching /tmp/anaconda-tb-* to this bug report. Attach them individually -- not as an archive. Thanks.
Comment 2 mock 2013-10-01 15:42:25 EDT
Created attachment 806149 [details]
anaconda.log
Comment 3 mock 2013-10-01 15:44:32 EDT
Created attachment 806153 [details]
anaconda-tb-e10HLr
Comment 4 mock 2013-10-01 15:45:10 EDT
Created attachment 806155 [details]
storage.log
Comment 5 mock 2013-10-01 15:45:40 EDT
Created attachment 806156 [details]
storage.state
Comment 6 mock 2013-10-01 15:46:20 EDT
Created attachment 806157 [details]
syslog
Comment 7 mock 2013-10-01 15:47:03 EDT
Created attachment 806158 [details]
X.log
Comment 8 mock 2013-10-01 15:49:37 EDT
when i recreated the situation to access the log files you requested, i started getting an error i wasn't getting before. when i tried to submit it as a bug, it was lumped in with a closed bug. the output is below, but the error was reproducable using the same steps listed in this ticket.


--- Running report_Bugzilla ---
Logging into Bugzilla at https://bugzilla.redhat.com
Checking for duplicates
Bug is already reported: 1004846
Bug 1004846 is a duplicate, using parent bug 1004572
Logging out
Status: CLOSED ERRATA https://bugzilla.redhat.com/show_bug.cgi?id=1004572
Comment 9 David Lehman 2013-10-01 17:40:51 EDT
I don't think you would hit bug 1004846 if you used the reclaim dialog to remove your old partitions.
Comment 10 mock 2013-10-01 22:10:06 EDT
ok, but i did find it happening repeatedly after following the the steps. i don't know why i didn't see it happening before.

was any of this helpful? do you need anymore?
Comment 11 David Lehman 2013-10-02 09:07:01 EDT
The logs you sent were not very useful as you didn't reach the point of reproducing the original problem. If you didn't change your disk layout and you didn't change your install media, you must have changed the procedure you are using to try to hit the error. You could always watch the screencast again to refresh your memory.
Comment 12 mock 2013-10-02 11:32:24 EDT
i did reach the point of reproducing the problem; and if there was any data in the logs, it should have been there. the other error ('NoneType') i experienced occurred after the original failure (screencast) to recreate partitions. (the 'NoneType' was an additional error after the fact.) since there was no real error or crash which occurred with my problem, it makes sense why the logs didn't capture anything.

however, i will go back and review my screencast and recreate it. if no errors are being captured in the logs, then i would consider it a bug in the process not triggering any messaging. (you can see the behavior in the screencast.)

other than that, i don't know what to say. i am open to suggestions regarding virt-manager configurations or settings which might accommodate a working solution.
Comment 13 mock 2013-10-02 12:48:06 EDT
well, let me update this bug. so, instead of letting anaconda deal with reclaiming space, i used gnome disks manager to wipe out the partitions on the usb drive and then i was able to delete and add partitions to the usb drive from anaconda during another installation attempt.

so, it can be done if you clear off the partitions using prior to trying to install. i wonder if this will still be problematic when i go to preserve my partitions when i install f20 gold? i've not been successful at preserving partitions in an lvm, such as /home, in the last two versions of fedora.

as far as i'm concerned, i have a solution for this. as far as it working as expected, that call i'll defer.
Comment 14 David Shea 2014-03-04 11:43:00 EST
Appears to work fine in F20 release

Note You need to log in before you can comment on or make changes to this bug.