Bug 101519 - (ACPI) Freeze loading usb-ohci
(ACPI) Freeze loading usb-ohci
Status: CLOSED UPSTREAM
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel (Show other bugs)
beta1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 101520 (view as bug list)
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-08-02 05:57 EDT by Jean Francois Martinez
Modified: 2015-01-04 17:02 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-24 18:11:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of acpidmp (85.50 KB, text/plain)
2003-08-05 01:52 EDT, Jean Francois Martinez
no flags Details
Output of dmidecode (5.08 KB, text/plain)
2003-08-05 01:54 EDT, Jean Francois Martinez
no flags Details
The /proc/interrupts after booting with pci=noacpi (455 bytes, text/plain)
2003-08-05 16:35 EDT, Jean Francois Martinez
no flags Details
Output of lspci -vv (8.63 KB, text/plain)
2003-08-05 16:36 EDT, Jean Francois Martinez
no flags Details
dmesg after booting with pci=noacpi (10.32 KB, text/plain)
2003-08-06 10:56 EDT, Jean Francois Martinez
no flags Details
dmesg after boot without disabling acpi (and USB disabled) (9.13 KB, text/plain)
2003-08-06 10:58 EDT, Jean Francois Martinez
no flags Details
ACPI VT86/Award PCI interrupt patch. (12.21 KB, patch)
2003-08-21 18:22 EDT, Len Brown
no flags Details | Diff

  None (edit)
Description Jean Francois Martinez 2003-08-02 05:57:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
Kernel boots and then I get a message "loading installer" but it does not go
past that.   I tried it on an older box who has no ACPI and it installed.  I
retried then on the box where it had failed but this time I inserted "acpi=off"
and this time it worked.

The box where it failed is an Athlon XP with an NFORCE2 chipset.  Given that the
chipset is quite popular betwee new machines it would be better to get this
right (ie without the user having to know about the ACPI trick).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot from standard iso
2.
3.
    

Additional info:
Comment 1 Bill Nottingham 2003-08-04 23:30:11 EDT
Can you post the output of 'dmidecode' and 'acpidmp'?
Comment 2 Bill Nottingham 2003-08-04 23:30:59 EDT
*** Bug 101520 has been marked as a duplicate of this bug. ***
Comment 3 Jean Francois Martinez 2003-08-05 01:52:46 EDT
Created attachment 93395 [details]
Output of acpidmp
Comment 4 Jean Francois Martinez 2003-08-05 01:54:17 EDT
Created attachment 93396 [details]
Output of dmidecode
Comment 5 Jean Francois Martinez 2003-08-05 02:09:30 EDT
I tweaked the boot scripts for allowing me to load USB modules manually
(obviously in normal boot not on install) and found that I could load usbcore
but that loading usb-ohci locked the machine (no response to keyboard).

A quick and dirty fix for the problem could be to disable acpi if nforce2 is
detected.  Could be done either through a patch or trough the post-install
scripts forcing acpi=off in the bootloader conf.
Comment 6 Len Brown 2003-08-05 15:06:01 EDT
Does the ISO install kernel boot if you use pci=noacpi ? 
Can you attach /proc/interrupts from the working system & lspci output? 
 
 
Comment 7 Jean Francois Martinez 2003-08-05 16:35:15 EDT
Created attachment 93413 [details]
The /proc/interrupts after booting with pci=noacpi
Comment 8 Jean Francois Martinez 2003-08-05 16:36:35 EDT
Created attachment 93414 [details]
Output of lspci -vv
Comment 9 Jean Francois Martinez 2003-08-05 16:45:47 EDT
Booting the install kernel without "apm=off" but with "pci=noacpi" no longer
freezes on "loading installer".

Booting the normal kernel without "apm=off" but with "pci=noacpi" no longer
freezes when loading the USB modules.   



Comment 10 Len Brown 2003-08-05 22:50:17 EDT
ACPI interrupt is active but quiesence in the pci=noacpi case, at least that much is 
normal. 
 
curious that /proc/interrupts shows the 3 USB controllers, but doesn't show the 
integrated Ethernet or Audio seen by lspci -- are they disabled? 
 
can you attach dmesg -s40000 output for the default acpi, as well as pci=noacpi 
cases?  You'll need to use your trick of disabling the usb-ohci module load for the acpi 
case so you can get the system up. 
 
What USB devices are attached to the system -- does it boot if you remove them? 
 
 
 
 
 
 
Comment 11 Jean Francois Martinez 2003-08-06 07:51:56 EDT
Theree is one peripheral connected to the USB port: a Logitec optic mouse. 
Removing it doesn't bring changes: it still doesn't boot.

For the integrated ethernet and audio the drivers haven't been probably loaded.
It is certain for the ethernet since the driver is proprietary and I want to
keep the kernel in pristine state as long as I am in bug reporting.  I am not 
sure about the integrated audio but I know it works.

BTW do you object if I install the redhat 2.6 kernel to see how acpi works on
my box?  It requires some changes to user space tools so perhaps this could
cause trouble for debugging present problem.

I will post the dmesg files in couple hours.
Comment 12 Jean Francois Martinez 2003-08-06 10:56:14 EDT
Created attachment 93437 [details]
dmesg after booting with pci=noacpi

I loaded the sound module manually so you will find messages about it in the
submitted file.  After that the audio device showed up at interrupt 12.
Comment 13 Jean Francois Martinez 2003-08-06 10:58:39 EDT
Created attachment 93438 [details]
dmesg after boot without disabling acpi (and USB disabled)

Due to a problem with kudzu I had to boot single user.	I didn't load sound
this time.  But I manually started acpid.
Comment 14 Len Brown 2003-08-21 18:22:18 EDT
Created attachment 93837 [details]
ACPI VT86/Award PCI interrupt patch. 


This patch has fixed the ACPI interrupt problem for similar systems.
Please try applying it to a copy of your Severn BETA1 kernel to
see if works for you too:

~/src/linux-2.4.21-20.1.2024.2.1.nptl> patch -Np1 < ./pci_link-severn.patch
patching file arch/i386/kernel/io_apic.c
patching file arch/i386/kernel/mpparse.c
patching file drivers/acpi/pci_irq.c
patching file drivers/acpi/pci_link.c
patching file include/acpi/acpi_drivers.h
Comment 15 Jean Francois Martinez 2003-08-23 14:48:59 EDT
The patch doesn't compile.  I tried by compiling from the tree set by the
kernel-source (after copying the kernel-athlon config file, make menuconfig
(without modification), make dep, make clean, make bziMage, make modules: it
chokes during make modules in the acpi part), I thought it would be better to
use the SRPM in order to get the exact same options you had used so I hacked
the SRPM, rpmbuild --target=athlon myspecfile and goty the same results (ie
failing to compile an acpi file during make modules)
Comment 16 Len Brown 2003-08-23 23:41:54 EDT
Did the patch apply cleanly to your Severn Beta1 source tree? 
Does the tree build w/ this config file _before_ the patch is applied? 
If you can attach your .config and the build output, i'll try it here. 
 
Comment 17 Jean Francois Martinez 2003-08-24 16:17:46 EDT
It applied cleanly.  I discovered that the RPM build was crashing while
compiling the SMP kernel so I disabled it and the UP kernel built nicely.

This solved the problem (ie the kernel no longer freezes when loading USB
modules) but... the kernel freezes when kudzu tries to probe
the hardware.  I rebooted in runlevel 2 (where kudzu is not started) and started
it by hand: it froze again and since I was unable to switch consoles or
CTRL-ALT-DEL I had the proof it was a kernel problem, not a kudzu one.

Then I tried rebooting with pci=noacpi and this time it worked, just like the
previous kernel.
Comment 18 Jeff Garzik 2004-03-03 03:47:06 EST
Can you re-test against Fedora Core 1 or FC2 (with acpi=on)?
Comment 19 Jean Francois Martinez 2004-03-18 17:03:06 EST
Fedora Core 1 worked with acpi=on.  kernel is not the vanilla one but
an  official bugfix.  Don't have number here.
Comment 20 Len Brown 2004-03-24 18:11:49 EST
Thanks for verifying that acpi=on works.
closing.

-Len

Note You need to log in before you can comment on or make changes to this bug.