Bug 1016474 - Cannot create deployment in DTGov
Cannot create deployment in DTGov
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: DT Governance (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity urgent
: ER4
: ---
Assigned To: Kurt T Stam
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 04:47 EDT by Stefan Bunciak
Modified: 2015-08-02 19:45 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ProjectLifeCycle process definition (16.37 KB, application/xml)
2013-10-08 18:33 EDT, kconner
no flags Details
SimpleReleaseProcess process definition (136.56 KB, application/xml)
2013-10-08 18:34 EDT, kconner
no flags Details

  None (edit)
Description Stefan Bunciak 2013-10-08 04:47:52 EDT
Description of problem:

* Unable to build KieBaseModel:SRAMPPackage

Version-Release number of selected component (if applicable):
* 6.0.0.ER4

How reproducible:
* 100%

Steps to Reproduce:
1. Install FSW 6.0.0.ER4
2. From 'data' dir run mvn clean install - as a workaround for https://bugzilla.redhat.com/show_bug.cgi?id=1010048
3. Start the server
4. From http://localhost:8080/dtgov-ui/#deployments create new deployment

Actual results:

* Server start-up: http://pastebin.test.redhat.com/168751 (follow up of https://bugzilla.redhat.com/show_bug.cgi?id=1002003)
* Deployment creation failure: http://pastebin.test.redhat.com/168750

Expected results:
* Deployment is created without ERRORS

Additional info:
* I've also deployed dtgov workflows to s-ramp the way Eric described here:
Comment 1 Stefan Bunciak 2013-10-08 04:49:19 EDT
* https://docspace.corp.redhat.com/docs/DOC-147383
Comment 2 Kurt T Stam 2013-10-08 09:24:30 EDT
*** Bug 1002003 has been marked as a duplicate of this bug. ***
Comment 3 Kurt T Stam 2013-10-08 10:05:12 EDT
Are you sure the workflow is deployed? I think you will need to run something
like mvn deploy (not install?) and making sure the srampWagon is invoked.
Comment 4 Stefan Bunciak 2013-10-08 11:16:04 EDT
I can reproduce even after clean install and running from data dir:

* maven clean install
* maven clean deploy (i had correct credentials set in settings.xml)
Comment 5 kconner 2013-10-08 13:09:05 EDT
The deploy step does not appear to be necessary as it looks as if the jBPM code also tries to load the artifact from the local ~/.m2 directory.

I reproduced the error doing the following
- install the server
- run 'mvn clean install' in the data directory
- start the server using standalone.sh script

Without the 'mvn install' step you see the following

Cannot find KieModule: org.overlord.dtgov:dtgov-workflows:1.0.1.Final-redhat-4: java.lang.RuntimeException: Cannot find KieModule: org.overlord.dtgov:dtgov-workfl

With the 'mvn install' you see the validation errors.

I have also deployed the artifact to the S-RAMP server and see the same validation errors on startup, even when removing ~/.m2/repository/org/overlord/dtgov/dtgov-workflows, so it looks as if the artifact can either be located in the local maven repo *or* the S-RAMP repository.
Comment 6 kconner 2013-10-08 13:36:56 EDT
It looks like this has been prompted by recent changes in the jBPM codebase as the DTGov workflows have not changed in two months.
Comment 7 kconner 2013-10-08 18:29:52 EDT
The failure seems to be as a result of the second set of ERROR messages, i.e. the following errors

09:42:22,266 ERROR [org.drools.compiler.kie.builder.impl.AbstractKieModule] (ServerService Thread Pool -- 72) Unable to build KieBaseModel:SRAMPPackage
[-1,-1]: Process 'Project Life Cycle' [overlord.demo.ProjectLifeCycle]: Task node 'Architecture Modeling' [4] has no work name.
[-1,-1]: Process 'Project Life Cycle' [overlord.demo.ProjectLifeCycle]: Task node 'Service Oriented Analysis' [5] has no work name.
[-1,-1]: Process 'Project Life Cycle' [overlord.demo.ProjectLifeCycle]: Task node 'Service Oriented Design' [6] has no work name.
[-1,-1]: Process 'Project Life Cycle' [overlord.demo.ProjectLifeCycle]: Task node 'Service Testing' [7] has no work name.
[-1,-1]: Process 'Project Life Cycle' [overlord.demo.ProjectLifeCycle]: Task node 'Deployed' [8] has no work name.
[-1,-1]: Process 'Project Life Cycle' [overlord.demo.ProjectLifeCycle]: Task node 'Retired' [9] has no work name.
Comment 8 kconner 2013-10-08 18:33:22 EDT
Created attachment 809581 [details]
ProjectLifeCycle process definition
Comment 9 kconner 2013-10-08 18:34:06 EDT
Created attachment 809582 [details]
SimpleReleaseProcess process definition
Comment 10 kconner 2013-10-08 18:36:00 EDT
The attached process definitions have been modified by hand to remove the errors.  They can be deployed by replacing the versions under the data directory and then running
  mvn clean install

There is no need to deploy the process definition to S-RAMP as the jBPM codebase appears to ignore the S-RAMP artifact in favour of whatever is located in the local maven repository.
Comment 11 Stefan Bunciak 2013-10-09 07:43:53 EDT
I can confirm that after installing dtgov workflows with these new process definition into my local workspace fixed all the error messages and the deployment was successfully created.
Comment 12 Stefan Bunciak 2013-10-09 07:55:18 EDT
* my local maven repository (sorry for typo)
Comment 13 George Varsamis 2013-10-09 11:03:41 EDT
I can confirm that this works but IT MUST me installed on .m2/repository otherwise it will fail.
Comment 14 Kurt T Stam 2013-10-10 10:19:04 EDT
I guess I'm not understanding why it must be deployed to .m2. The way it should work is that you deploy it to S-RAMP, then when it is used it get's cached in the .m2 as well (such is how maven works). It's important the workflow package is in S-RAMP as we extract the individual files like task forms etc and use them at runtime. Anyway in a few hrs I will check in brand new 'clean' workflows.
Comment 15 George Varsamis 2013-10-10 11:52:20 EDT
The cause is the latest changes  jBPM. It seems to be looking into the local m2 repository and not S-RAMP Repo. I've been speaking to Kev about this extensively yesterday. I have submitted bug 1017283  about this.
Comment 16 George Varsamis 2013-10-11 06:34:00 EDT
Kurt is right. If deployed onto S-RAMP it will work.
Comment 17 Stefan Bunciak 2013-10-18 11:07:17 EDT
Workflows could be loaded from S-RAMP and in .m2 just cached.
Verified in FSW 6.0.0.ER5
Comment 18 Stefan Bunciak 2013-10-18 11:14:14 EDT
Verified in FSW 6.0.0.ER6, not ER5 (sorry for typo).

Note You need to log in before you can comment on or make changes to this bug.