Bug 1017358 - The admin client requires --name for consumer updates
The admin client requires --name for consumer updates
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.2
Unspecified Unspecified
low Severity low (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
: Triaged
Depends On: 979587
Blocks: 950743
  Show dependency treegraph
 
Reported: 2013-10-09 13:23 EDT by Eric Helms
Modified: 2014-01-27 09:22 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 979587
Environment:
Last Closed: 2013-10-22 14:10:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Helms 2013-10-09 13:23:58 EDT
+++ This bug was initially created as a clone of Bug #979587 +++

Note that the --name flag is required:

$ pulp-admin rpm consumer package update run
Command: run
Description: triggers an immediate package update on a consumer

Available Arguments:

  --consumer-id - (required) unique identifier; only alphanumeric, -, and _
                  allowed
  --name, -n    - (required) package name; may repeat for multiple packages
  --no-commit   - test the transaction without committing it
  --reboot      - reboot after a successful transaction
  --import-keys - import GPG keys as needed
  --all, -a     - update all content units
The following options are required but were not specified:
  --consumer-id
  --name

This is not useful for users who want to apply all available updates to a consumer.

Instead, it would make more sense if we got rid of the -a flag, and defaulted to installing all updates if no -n flags were passed. This would be more consistent with yum and other package managers' behaviors.

--- Additional comment from Michael Hrivnak on 2013-08-02 14:54:28 EDT ---



--- Additional comment from Sayli Karmarkar on 2013-09-06 11:56:44 EDT ---

Merged. 

$ pulp-admin rpm consumer package update run --help
Command: run
Description: triggers an immediate package update on a consumer

Available Arguments:

  --bg          - if specified, the client process will end immediately (the
                  task will continue to run on the server)
  --consumer-id - (required) unique identifier; only alphanumeric, ., -, and _
                  allowed
  --name, -n    - package name; may repeat for multiple packages. if
                  unspecified, all packages are updated
  --no-commit   - test the transaction without committing it
  --reboot      - reboot after a successful transaction
  --import-keys - import GPG keys as needed

--- Additional comment from Jeff Ortel on 2013-09-12 18:35:29 EDT ---

build: 2.3.0-0.10.alpha

--- Additional comment from Preethi Thomas on 2013-09-19 13:58:50 EDT ---

[root@pulp-v2-server ~]# rpm -qa pulp-admin-client
pulp-admin-client-2.3.0-0.14.alpha.el6.noarch
[root@pulp-v2-server ~]# 

[root@pulp-v2-server ~]#  pulp-admin rpm consumer package update run
Command: run
Description: triggers an immediate package update on a consumer

Available Arguments:

  --bg          - if specified, the client process will end immediately (the
                  task will continue to run on the server)
  --consumer-id - (required) unique identifier; only alphanumeric, ., -, and _
                  allowed
  --name, -n    - package name; may repeat for multiple packages. if
                  unspecified, all packages are updated
  --no-commit   - test the transaction without committing it
  --reboot      - reboot after a successful transaction
  --import-keys - import GPG keys as needed
The following options are required but were not specified:
  --consumer-id
[root@pulp-v2-server ~]#
Comment 2 Randy Barlow 2013-10-09 14:46:37 EDT
This particular bug is for the Pulp CLI, which as I understand it, is not used by Satellite 6. Perhaps you had intended to clone a different bug?
Comment 3 Mike McCune 2013-10-22 14:10:24 EDT
closing:NOTABUG for sat6.  mistakenly added to sat6-pulp-blocker

Note You need to log in before you can comment on or make changes to this bug.