Bug 979587 - The admin client requires --name for consumer updates
The admin client requires --name for consumer updates
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: rpm-support (Show other bugs)
2.1.1
Unspecified Unspecified
low Severity low
: ---
: 2.3.0
Assigned To: Sayli Karmarkar
Preethi Thomas
: Triaged
: 978376 (view as bug list)
Depends On:
Blocks: 1017358
  Show dependency treegraph
 
Reported: 2013-06-28 16:49 EDT by Randy Barlow
Modified: 2015-03-22 21:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1017358 (view as bug list)
Environment:
Last Closed: 2013-12-09 09:29:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Randy Barlow 2013-06-28 16:49:50 EDT
Note that the --name flag is required:

$ pulp-admin rpm consumer package update run
Command: run
Description: triggers an immediate package update on a consumer

Available Arguments:

  --consumer-id - (required) unique identifier; only alphanumeric, -, and _
                  allowed
  --name, -n    - (required) package name; may repeat for multiple packages
  --no-commit   - test the transaction without committing it
  --reboot      - reboot after a successful transaction
  --import-keys - import GPG keys as needed
  --all, -a     - update all content units
The following options are required but were not specified:
  --consumer-id
  --name

This is not useful for users who want to apply all available updates to a consumer.

Instead, it would make more sense if we got rid of the -a flag, and defaulted to installing all updates if no -n flags were passed. This would be more consistent with yum and other package managers' behaviors.
Comment 1 Michael Hrivnak 2013-08-02 14:54:28 EDT
*** Bug 978376 has been marked as a duplicate of this bug. ***
Comment 2 Sayli Karmarkar 2013-09-06 11:56:44 EDT
Merged. 

$ pulp-admin rpm consumer package update run --help
Command: run
Description: triggers an immediate package update on a consumer

Available Arguments:

  --bg          - if specified, the client process will end immediately (the
                  task will continue to run on the server)
  --consumer-id - (required) unique identifier; only alphanumeric, ., -, and _
                  allowed
  --name, -n    - package name; may repeat for multiple packages. if
                  unspecified, all packages are updated
  --no-commit   - test the transaction without committing it
  --reboot      - reboot after a successful transaction
  --import-keys - import GPG keys as needed
Comment 3 Jeff Ortel 2013-09-12 18:35:29 EDT
build: 2.3.0-0.10.alpha
Comment 4 Preethi Thomas 2013-09-19 13:58:50 EDT
[root@pulp-v2-server ~]# rpm -qa pulp-admin-client
pulp-admin-client-2.3.0-0.14.alpha.el6.noarch
[root@pulp-v2-server ~]# 

[root@pulp-v2-server ~]#  pulp-admin rpm consumer package update run
Command: run
Description: triggers an immediate package update on a consumer

Available Arguments:

  --bg          - if specified, the client process will end immediately (the
                  task will continue to run on the server)
  --consumer-id - (required) unique identifier; only alphanumeric, ., -, and _
                  allowed
  --name, -n    - package name; may repeat for multiple packages. if
                  unspecified, all packages are updated
  --no-commit   - test the transaction without committing it
  --reboot      - reboot after a successful transaction
  --import-keys - import GPG keys as needed
The following options are required but were not specified:
  --consumer-id
[root@pulp-v2-server ~]#
Comment 5 Preethi Thomas 2013-12-09 09:29:56 EST
Pulp 2.3 released.

Note You need to log in before you can comment on or make changes to this bug.