Bug 1018444 - [abrt] gnome-software-3.11.1-0.45.20131009git.fc20: __strcmp_ssse3: Process /usr/bin/gnome-software was killed by signal 11 (SIGSEGV)
[abrt] gnome-software-3.11.1-0.45.20131009git.fc20: __strcmp_ssse3: Process /...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-software (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
abrt_hash:8bb289833c9e34382f3d0fe0ca5...
: Reopened
Depends On:
Blocks: F20BetaBlocker F20BetaFreezeException
  Show dependency treegraph
 
Reported: 2013-10-12 01:00 EDT by D. Charles Pyle
Modified: 2013-10-15 15:22 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-14 15:03:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (75.18 KB, text/plain)
2013-10-12 01:00 EDT, D. Charles Pyle
no flags Details
File: cgroup (160 bytes, text/plain)
2013-10-12 01:00 EDT, D. Charles Pyle
no flags Details
File: core_backtrace (14.28 KB, text/plain)
2013-10-12 01:00 EDT, D. Charles Pyle
no flags Details
File: dso_list (12.55 KB, text/plain)
2013-10-12 01:00 EDT, D. Charles Pyle
no flags Details
File: environ (1.98 KB, text/plain)
2013-10-12 01:01 EDT, D. Charles Pyle
no flags Details
File: limits (1.29 KB, text/plain)
2013-10-12 01:01 EDT, D. Charles Pyle
no flags Details
File: maps (60.51 KB, text/plain)
2013-10-12 01:01 EDT, D. Charles Pyle
no flags Details
File: open_fds (1.11 KB, text/plain)
2013-10-12 01:01 EDT, D. Charles Pyle
no flags Details
File: proc_pid_status (945 bytes, text/plain)
2013-10-12 01:01 EDT, D. Charles Pyle
no flags Details
File: var_log_messages (380 bytes, text/plain)
2013-10-12 01:01 EDT, D. Charles Pyle
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 710108 None None None Never

  None (edit)
Description D. Charles Pyle 2013-10-12 01:00:48 EDT
Description of problem:
Tried to install gnome-maps using this utility.  As soon as I clicked the Install button the application crashed.

Version-Release number of selected component:
gnome-software-3.11.1-0.45.20131009git.fc20

Additional info:
reporter:       libreport-2.1.7
backtrace_rating: 4
cmdline:        gnome-software
crash_function: __strcmp_ssse3
executable:     /usr/bin/gnome-software
kernel:         3.11.3-301.fc20.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 __strcmp_ssse3 at ../sysdeps/x86_64/strcmp.S:210
 #1 gs_plugin_packagekit_refine_details at gs-plugin-packagekit-refine.c:417
 #2 gs_plugin_refine_require_details at gs-plugin-packagekit-refine.c:501
 #3 gs_plugin_refine at gs-plugin-packagekit-refine.c:592
 #4 gs_plugin_loader_run_refine at gs-plugin-loader.c:201
 #5 gs_plugin_loader_app_refine_thread_cb at gs-plugin-loader.c:1541
 #6 run_in_thread at gsimpleasyncresult.c:871
 #7 io_job_thread at gioscheduler.c:89
 #8 g_task_thread_pool_thread at gtask.c:1245
 #10 g_thread_proxy at gthread.c:798
Comment 1 D. Charles Pyle 2013-10-12 01:00:51 EDT
Created attachment 811510 [details]
File: backtrace
Comment 2 D. Charles Pyle 2013-10-12 01:00:54 EDT
Created attachment 811511 [details]
File: cgroup
Comment 3 D. Charles Pyle 2013-10-12 01:00:56 EDT
Created attachment 811512 [details]
File: core_backtrace
Comment 4 D. Charles Pyle 2013-10-12 01:00:59 EDT
Created attachment 811513 [details]
File: dso_list
Comment 5 D. Charles Pyle 2013-10-12 01:01:01 EDT
Created attachment 811514 [details]
File: environ
Comment 6 D. Charles Pyle 2013-10-12 01:01:04 EDT
Created attachment 811515 [details]
File: limits
Comment 7 D. Charles Pyle 2013-10-12 01:01:07 EDT
Created attachment 811516 [details]
File: maps
Comment 8 D. Charles Pyle 2013-10-12 01:01:09 EDT
Created attachment 811517 [details]
File: open_fds
Comment 9 D. Charles Pyle 2013-10-12 01:01:11 EDT
Created attachment 811518 [details]
File: proc_pid_status
Comment 10 D. Charles Pyle 2013-10-12 01:01:14 EDT
Created attachment 811519 [details]
File: var_log_messages
Comment 11 Adam Williamson 2013-10-13 07:20:36 EDT
Same as Charles: after updating to the gnome-software and PackageKit builds from http://people.freedesktop.org/~hughsient/fedora/20/x86_64/ , gnome-software still crashes on install of a package (gnome-weather), with this trace instead of the one from https://bugzilla.redhat.com/show_bug.cgi?id=1012253 .
Comment 12 Adam Williamson 2013-10-13 07:22:09 EDT
Not sure if this can affect update installation, but if it does, then it would block the Beta. If it doesn't, we should certainly make it a freeze exception issue.
Comment 13 D. Charles Pyle 2013-10-13 12:08:31 EDT
Since that update and the last round of system updates I have been unable to install any new kernels, and attempting to rebuild initramfs files in previously installed kernels results in failures to load the older kernels.

During the phase of the installation when a new initramfs is made by calling dracut, many prelink errors were generated, followed by truncated initramfs files that always result in kernel panics.  By truncated, I mean unusable files that should be between 10.5 and 11.5 Mbytes in size but instead end up between 5.0 and 7.1 Mbytes in size.

I ran prelink -auv and removed prelink, and no longer see the prelink errors but still have the same truncated initramfs files.  I have tried downgrading dracut and associated files, as well as the last spate of system updates, but the result remains the same no matter the versions.

I tried to downgrade all the files associated with the gnome-software, PackageKit, yum plugins, etc., updates mentioned above, as well as one of the kernels installed, but so far have been unable to do so.  Results range from attempting to uninstall nearly half the system to serious dependency problems, depending upon method used to attempt to remove the files.
Comment 14 D. Charles Pyle 2013-10-13 12:22:45 EDT
I just attempted to use gnome-software to install updates.  It stated that there were no updates available when yum shows that there actually are updates available for my system.  This was followed by several error reports.  After multiple abrt reports of PackageKit and gnome-software errors, updates were not installed.
Comment 15 Adam Williamson 2013-10-14 04:23:23 EDT
charles: it doesn't seem entirely clear that the other problems you're seeing relate to this gnome-software crash, from your above description. Could you perhaps try a fresh install and try to isolate whether the two are related or not?
Comment 16 Ryan Lerch 2013-10-14 10:02:46 EDT
(In reply to D. Charles Pyle from comment #14)
> I just attempted to use gnome-software to install updates.  It stated that
> there were no updates available when yum shows that there actually are
> updates available for my system.  This was followed by several error
> reports.  After multiple abrt reports of PackageKit and gnome-software
> errors, updates were not installed.

We have a bug for the no-updates thing:
https://bugzilla.redhat.com/show_bug.cgi?id=1017137

and an upstream one for it too:
https://bugzilla.gnome.org/show_bug.cgi?id=709742
Comment 17 Ryan Lerch 2013-10-14 10:10:35 EDT
Filed upstream bug for this.

http://bugzilla.gnome.org/show_bug.cgi?id=710108
Comment 18 Richard Hughes 2013-10-14 11:28:33 EDT
(In reply to Adam Williamson from comment #11)
> Same as Charles: after updating to the gnome-software and PackageKit builds
> from http://people.freedesktop.org/~hughsient/fedora/20/x86_64/ ,

These are development builds, and apart from the fact it compiles, no testing has been done on them at all. They might crash, marry your dog or remove every 5th brick on your house walls. I'd really avoid using them for any sort of QA.
Comment 19 Adam Williamson 2013-10-14 12:32:37 EDT
Well, I installed them because that's what you said to do in https://bugzilla.redhat.com/show_bug.cgi?id=1012253#c19 .

When I test the Software Installer Application, and  find that instead of installing software it crashes, and I find the bug report for the crash and it has a comment from the maintainer of the Software Installer Application saying that a build that should fix the crash is available somewhere else and setting the bug to MODIFIED, then installing that build and trying it seems like the logical thing to do, yes? Do advise if I missed a step somewhere.
Comment 20 Ryan Lerch 2013-10-14 14:58:20 EDT
My apologies, i thought those were the 3.10 builds, but it appears they were not. I will close this one as notabug, since we were testing a too-new version.

I will see if we can get a test build of the 3.10 one for the other bug.
Comment 21 D. Charles Pyle 2013-10-14 15:00:00 EDT
(In reply to Adam Williamson from comment #15)
> charles: it doesn't seem entirely clear that the other problems you're
> seeing relate to this gnome-software crash, from your above description.
> Could you perhaps try a fresh install and try to isolate whether the two are
> related or not?

I had no choice but to do a fresh install.  My system was trashed and I was unable to use PackageKit or even yum to fix it.  I still could not fix the problems with installed kernels.  I am not going to touch that PackageKit update in that directory again but will try the gnome-software packages that are there sometime today.

As to the current state of my system, I have all the latest versions of software packages that are in official Fedora repositories.  I see zero problems with configuration.  So far, I also see zero problems with kernel installation, which problems did not start until after I upgraded all the packages that were in the above URL.  I'll post an update on this later on, if I see any further issues.
Comment 22 D. Charles Pyle 2013-10-15 15:22:13 EDT
I won't be able to upgrade gnome-software from that repository.  It insists on installing the newer PackageKit as one of several dependencies.  Since I am not touching that PackageKit version again, I will be unable to install that version of gnome-software.

Note You need to log in before you can comment on or make changes to this bug.