Bug 1022949 - zenity --list --height does not stretch list widget to window height
zenity --list --height does not stretch list widget to window height
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: zenity (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Branislav Blaškovič
:
: 1045683 1062941 (view as bug list)
Depends On:
Blocks: 1257890
  Show dependency treegraph
 
Reported: 2013-10-24 06:41 EDT by Branislav Blaškovič
Modified: 2015-08-28 06:31 EDT (History)
10 users (show)

See Also:
Fixed In Version: zenity-3.8.0-4.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1251137 1257890 (view as bug list)
Environment:
Last Closed: 2014-04-30 00:06:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Zenity list is not stretched (4.85 KB, image/png)
2013-10-24 06:41 EDT, Branislav Blaškovič
no flags Details

  None (edit)
Description Branislav Blaškovič 2013-10-24 06:41:16 EDT
Created attachment 815723 [details]
Zenity list is not stretched

Version-Release number of selected component (if applicable):
zenity-3.8.0-3.fc20.x86_64

Steps to Reproduce:
1. zenity --list --column test --height 300 a b c d e f g

Actual results:
See attached image

Expected results:
List stretched to window size
Comment 1 Marco Falchi 2013-11-08 10:21:50 EST
Hi,
same problem for me.


# rpm -qa | grep zenity 
zenity-3.8.0-3.fc20.x86_64

# cat /etc/redhat-release 
Fedora release 20 (Heisenbug)

Steps to Reproduce:
1. zenity --list --title "Foobar" --width 800 --height 500 --checklist --column Category --column Purple --column Green --column Blue --column Pink --column Grey
Comment 2 MartinKG 2013-12-23 12:29:38 EST
same here on f20 with

reproduce with:
zenity --list --column "Playlists" FALSE $(ls -d -1 */) --title "Please select one or more playlists" --width=300 --height=600 --checklist --column "Select" --separator="/ "
Comment 3 larchunix 2014-01-02 15:31:12 EST
This bug has been reported upstream already : https://bugzilla.gnome.org/show_bug.cgi?id=702535.

This commit fix the issue : https://git.gnome.org/browse/zenity/commit/?id=80bc8ce643979fec201c4ebd5cd6405b6310357f
Comment 4 MartinKG 2014-01-03 04:31:17 EST
patch confirmed, zenity works now as expected.
Comment 5 Miroslav Vadkerti 2014-01-13 05:05:38 EST
Thanks for the fix, works for me also. Looking forward to test the build.
Comment 6 Rafael Luik 2014-01-18 20:41:34 EST
Hey, is Bug 1045683 a duplicate of this one?
Comment 7 Robert Hancock 2014-02-12 11:03:08 EST
I have seen this issue as well. It sounds like upstream has fixed the bug, but we need a Fedora release with the patch included.
Comment 8 Ejner Fergo 2014-03-01 15:16:18 EST
I can also confirm this bug in F20 (works as expected in Arch Linux). Would appreciate an update for Fedora. Thanks!
Comment 9 David Jansen 2014-04-24 04:31:28 EDT
Any news on this, other than downloading from upstream? I just ran into this bug with a script which displays properly on Ubuntu. Can we expect an update for Fedora 20 soon?
Comment 10 Branislav Blaškovič 2014-04-24 04:58:59 EDT
This bug needs to be in Fedora ASAP as it breaks lot of applications.
Comment 11 Fedora Update System 2014-04-28 08:47:14 EDT
zenity-3.8.0-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/zenity-3.8.0-4.fc20
Comment 12 Fedora Update System 2014-04-29 01:24:39 EDT
Package zenity-3.8.0-4.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing zenity-3.8.0-4.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-5754/zenity-3.8.0-4.fc20
then log in and leave karma (feedback).
Comment 13 Branislav Blaškovič 2014-04-29 10:34:07 EDT
Working. Thank you.

Karma +1
Comment 14 Rafael Luik 2014-04-29 16:27:18 EDT
*** Bug 1045683 has been marked as a duplicate of this bug. ***
Comment 15 Fedora Update System 2014-04-30 00:06:08 EDT
zenity-3.8.0-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Ville Skyttä 2014-05-01 10:29:44 EDT
*** Bug 1062941 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.