Bug 1251137 - zenity --list --height does not stretch list widget to window height
zenity --list --height does not stretch list widget to window height
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: zenity (Show other bugs)
7.2
Unspecified Unspecified
medium Severity high
: rc
: ---
Assigned To: Alexander Larsson
Desktop QE
:
: 1257890 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-06 10:15 EDT by Marek Haicman
Modified: 2015-11-19 02:34 EST (History)
5 users (show)

See Also:
Fixed In Version: zenity-3.8.0-5.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1022949
Environment:
Last Closed: 2015-11-19 02:34:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
image from cloned BZ (4.85 KB, image/png)
2015-08-06 13:00 EDT, Marek Haicman
no flags Details

  None (edit)
Description Marek Haicman 2015-08-06 10:15:09 EDT
+++ This bug was initially created as a clone of Bug #1022949 +++

Version-Release number of selected component (if applicable):
zenity-3.8.0-3.fc20.x86_64

Steps to Reproduce:
1. zenity --list --column test --height 300 a b c d e f g

Actual results:
See attached image

Expected results:
List stretched to window size
Comment 2 Marek Haicman 2015-08-06 13:00:23 EDT
Created attachment 1060047 [details]
image from cloned BZ
Comment 4 Matthias Clasen 2015-08-17 14:20:07 EDT
Should be easy to backport the upstream fix:

https://git.gnome.org/browse/zenity/commit/?h=gnome-3-16&id=08e8f3e05da467930bb7c24ca7280f7d18fc9122
Comment 6 Marek Haicman 2015-08-20 05:22:59 EDT
Verified it on x86_64 - it works there. Thanks!
Comment 7 Matthias Clasen 2015-09-02 18:22:20 EDT
*** Bug 1257890 has been marked as a duplicate of this bug. ***
Comment 9 errata-xmlrpc 2015-11-19 02:34:04 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2215.html

Note You need to log in before you can comment on or make changes to this bug.