Bug 1257890 - zenity --list --height does not stretch list widget to window height
zenity --list --height does not stretch list widget to window height
Status: CLOSED DUPLICATE of bug 1251137
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: zenity (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Alexander Larsson
Desktop QE
Depends On: 1022949
  Show dependency treegraph
Reported: 2015-08-28 06:31 EDT by Branislav Blaškovič
Modified: 2015-09-02 18:22 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1022949
Last Closed: 2015-09-02 18:22:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Branislav Blaškovič 2015-08-28 06:31:14 EDT
Same problem on RHEL7 with zenity-3.8.0-4.el7.x86_64

+++ This bug was initially created as a clone of Bug #1022949 +++

Version-Release number of selected component (if applicable):

Steps to Reproduce:
1. zenity --list --column test --height 300 a b c d e f g

Actual results:
See attached image

Expected results:
List stretched to window size

--- Additional comment from Marco Falchi on 2013-11-08 16:21:50 CET ---

same problem for me.

# rpm -qa | grep zenity 

# cat /etc/redhat-release 
Fedora release 20 (Heisenbug)

Steps to Reproduce:
1. zenity --list --title "Foobar" --width 800 --height 500 --checklist --column Category --column Purple --column Green --column Blue --column Pink --column Grey

--- Additional comment from MartinKG on 2013-12-23 18:29:38 CET ---

same here on f20 with

reproduce with:
zenity --list --column "Playlists" FALSE $(ls -d -1 */) --title "Please select one or more playlists" --width=300 --height=600 --checklist --column "Select" --separator="/ "

--- Additional comment from  on 2014-01-02 21:31:12 CET ---

This bug has been reported upstream already : https://bugzilla.gnome.org/show_bug.cgi?id=702535.

This commit fix the issue : https://git.gnome.org/browse/zenity/commit/?id=80bc8ce643979fec201c4ebd5cd6405b6310357f

--- Additional comment from MartinKG on 2014-01-03 10:31:17 CET ---

patch confirmed, zenity works now as expected.

--- Additional comment from Miroslav Vadkerti on 2014-01-13 11:05:38 CET ---

Thanks for the fix, works for me also. Looking forward to test the build.

--- Additional comment from Rafael Luik on 2014-01-19 02:41:34 CET ---

Hey, is Bug 1045683 a duplicate of this one?

--- Additional comment from Robert Hancock on 2014-02-12 17:03:08 CET ---

I have seen this issue as well. It sounds like upstream has fixed the bug, but we need a Fedora release with the patch included.

--- Additional comment from Ejner Fergo on 2014-03-01 21:16:18 CET ---

I can also confirm this bug in F20 (works as expected in Arch Linux). Would appreciate an update for Fedora. Thanks!

--- Additional comment from David Jansen on 2014-04-24 10:31:28 CEST ---

Any news on this, other than downloading from upstream? I just ran into this bug with a script which displays properly on Ubuntu. Can we expect an update for Fedora 20 soon?

--- Additional comment from Branislav Blaškovič on 2014-04-24 10:58:59 CEST ---

This bug needs to be in Fedora ASAP as it breaks lot of applications.

--- Additional comment from Fedora Update System on 2014-04-28 14:47:14 CEST ---

zenity-3.8.0-4.fc20 has been submitted as an update for Fedora 20.

--- Additional comment from Fedora Update System on 2014-04-29 07:24:39 CEST ---

Package zenity-3.8.0-4.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing zenity-3.8.0-4.fc20'
as soon as you are able to.
Please go to the following url:
then log in and leave karma (feedback).

--- Additional comment from Branislav Blaškovič on 2014-04-29 16:34:07 CEST ---

Working. Thank you.

Karma +1

--- Additional comment from Rafael Luik on 2014-04-29 22:27:18 CEST ---

--- Additional comment from Fedora Update System on 2014-04-30 06:06:08 CEST ---

zenity-3.8.0-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

--- Additional comment from Ville Skyttä on 2014-05-01 16:29:44 CEST ---
Comment 2 Matthias Clasen 2015-09-02 18:22:20 EDT

*** This bug has been marked as a duplicate of bug 1251137 ***

Note You need to log in before you can comment on or make changes to this bug.